1. Tim Liberty's Avatar
    I got a nexus 7 yesterday and it is awesome and everything works great other than the weird issue I'm having with the wifi. It will work great then if it let it sleep for awhile it will lose its connection even though it says its connected. When I try to reconnect it won't let me. My galaxy s2 seems to be doing the same thing but I don't think our laptops have been affected. If I reset my router it works great until I let it sleep awhile again and the process starts all over again.
    12-26-2012 10:55 AM
  2. Groid's Avatar
    Settings > Wi-Fi > menu (3 vertical dots in upper right) > Advanced > Keep WiFi on during sleep, set to always. I also have wi-fi optimization checked, but I don't know if that matters. This will prevent loss of connection during sleep. However, some mostly older routers don't seem to play nicely with current phone/tablet chipsets. Lots of threads in lots of forums about that.
    12-26-2012 12:05 PM
  3. still1's Avatar
    like mentioned above. but i would also uncheck "wi-fi optimization"
    just to test it.
    12-26-2012 12:36 PM
  4. Tim Liberty's Avatar
    Wifi on during sleep was checked so i will try un checking it see if that works.

    The Router is a somewhat new netgear.( less than a year old)
    12-26-2012 02:34 PM
  5. Tim Liberty's Avatar
    Sorry for double post but UN checking (having it turned off) the WiFi during sleep seemed to have worked so far for me.

    I also turned off my tablet, unplugged router, reset modem, plugged router back in and the turned tablet back on but I don't think that is what did it.

    Keep your fingers crossed that it stays working.

    Sent from my Nexus 7 using Tapatalk 2
    12-26-2012 05:54 PM
  6. mouseglider's Avatar
    Sorry for double post but UN checking (having it turned off) the WiFi during sleep seemed to have worked so far for me.

    I also turned off my tablet, unplugged router, reset modem, plugged router back in and the turned tablet back on but I don't think that is what did it.

    Keep your fingers crossed that it stays working.

    Sent from my Nexus 7 using Tapatalk 2
    If that doesn't work, try using a static ip address - therefore when it wakes up, it will lock to the static ip address - use the same address that it picks when it is working, that way both auto and static are the same - but as you have done in the past if all else fails, is simply unplug the router, no need to hit reset, wait 10seconds and plug power back in and the device should pick the ip address up again without any problems.
    12-27-2012 02:14 AM
  7. Tim Liberty's Avatar
    If that doesn't work, try using a static ip address - therefore when it wakes up, it will lock to the static ip address - use the same address that it picks when it is working, that way both auto and static are the same - but as you have done in the past if all else fails, is simply unplug the router, no need to hit reset, wait 10seconds and plug power back in and the device should pick the ip address up again without any problems.
    Yea. My solution did not last. I have had it on static and still had this problem. I'm starting to think it has to do with my router because my phone, tablet, and one of my laptops can not reconnect after it acts up till after we reset the router again.

    I have a net gear wnr2000.

    Sent from my Nexus 7 using Tapatalk 2
    12-27-2012 11:06 PM
  8. mouseglider's Avatar
    Yea. My solution did not last. I have had it on static and still had this problem. I'm starting to think it has to do with my router because my phone, tablet, and one of my laptops can not reconnect after it acts up till after we reset the router again.

    I have a net gear wnr2000.

    Sent from my Nexus 7 using Tapatalk 2
    I believe you are probably correct, because if all your other devices have problems at the same time, then it only point to one thing. Good Luck!
    12-28-2012 12:06 AM
  9. Tim Liberty's Avatar
    I believe you are probably correct, because if all your other devices have problems at the same time, then it only point to one thing. Good Luck!
    I'm going to update the firmware on the router today and see if that works.


    Sent from my Nexus 7 using Tapatalk 2
    12-28-2012 02:58 PM
  10. pdaniel219's Avatar
    I had the same problem with my RAZRM. It would only connect to my WiFi when i rest my router and hit connect in my phone as the router came back on. Until the phone went to sleep, then it would just keep cycling through the authorization process. I have 4 other devices that connect and stay connected with no problem. I went to Verizon and it connected to EVERYTHING in and around the store. I had to go in and set my router to WEP instead of WPA. Its less secure, and makes me a little nervous, but I'm not burning up my shared data anymore. I may have to look into a new router.

    Sent from my XT907 using Android Central Forums
    12-28-2012 03:06 PM
  11. Tim Liberty's Avatar
    So far the firmware update has worked for me. It has been working for 24hrs which is the best yet.

    Sent from my Nexus 7 using Tapatalk 2
    12-29-2012 10:52 AM
  12. Tim Liberty's Avatar
    So far the firmware update has worked for me. It has been working for 24hrs which is the best yet.

    Sent from my Nexus 7 using Tapatalk 2
    Still working great so I would say that it fixed it.

    Sent from my Nexus 7 using Tapatalk 2
    01-06-2013 12:09 PM
  13. mouseglider's Avatar
    Great! Now that it stays connected, you need a kickstand4u tm to prop it up so can enjoy viewing it! :-)

    Sent from my SPH-L710 using Tapatalk 2
    01-06-2013 12:24 PM

Similar Threads

  1. wifi tethering problem
    By Trail3n in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 10
    Last Post: 10-11-2010, 11:29 AM
  2. WiFi connection problems
    By yogibimbi in forum Other Sony Android Phones
    Replies: 1
    Last Post: 10-04-2010, 02:16 PM
  3. 3G and WiFi Reconnect Issue
    By dcreed in forum Motorola Droid
    Replies: 2
    Last Post: 08-19-2010, 01:22 PM
  4. Wifi streaming problems?
    By shaunm89 in forum Google / HTC Nexus One
    Replies: 3
    Last Post: 06-13-2010, 01:33 PM
  5. WIFI connection problems
    By Raija in forum HTC Desire
    Replies: 6
    Last Post: 05-20-2010, 05:24 AM
LINK TO POST COPIED TO CLIPBOARD