Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Wi-fi is connected but I have no internet connection

    Just got my new Nexus 7 Tablet for Christmas, I used it a lot at home but upon returning to my apartment I haven't used it much because I haven't set up a wireless access point yet, I only ever needed an Ethernet connection for my desktop. Now I'm at work and I'm connected to our wireless network but my tablet doesn't appear to have an internet connection.

    Any time I try to use any app that requires a connection it will instantly tell me that I don't have a connection. If I go to my settings > wireless, it shows that it is connected to our network and the signal strength is good.

    The wi-fi icon in the corner is sort of a pale grey color, although it still displays the signal strength as being strong (4 of the 5 lines are lit up/filled in).

    Anyone know what the problem could be?
  2. #2  
    GMJeff's Avatar

    Posts
    590 Posts
    Global Posts
    979 Global Posts

    Default Re: Wi-fi is connected but I have no internet connection

    Your IT department may not allow the nexus 7 to access the Internet without permission, that is, assuming that you work in a place with an IT department.

    If you do, sometimes special permissions need to be setup before a device can access the internet server for your business. The IT department needs to register your device and essentially tell the server that you have the ability to access the internet.

    If none of this applies, I would think that there is a setting that may not be set properly on the tablet.

    Sent from my SAMSUNG-SGH-I317 using Android Central Forums
  3. Thread Author  Thread Author    #3  

    Default Re: Wi-fi is connected but I have no internet connection

    Sorry I should have mentioned I don't only have this problem with my employers wi-fi, I have the same problem when I went to an internet cafe for lunch. Is there any settings I can look into that may cause this problem?
  4. #4  

    Default Re: Wi-fi is connected but I have no internet connection

    Quote Originally Posted by Atheismo View Post
    Sorry I should have mentioned I don't only have this problem with my employers wi-fi, I have the same problem when I went to an internet cafe for lunch. Is there any settings I can look into that may cause this problem?
    Perhaps at the internet café you need to open Chrome to log into the network.
  5. #5  
    GMJeff's Avatar

    Posts
    590 Posts
    Global Posts
    979 Global Posts

    Default Re: Wi-fi is connected but I have no internet connection

    That seems like a possibility. I just read a article that said exactly that.

    You may have to open your browser and accept the terms and conditions before you can browse the internet on their network. I have had to do this at a few local hotspots, or even a few hotels that we have stayed at in the past year or so.

    Other than that the article was saying that any other fixes were done by logging into the router and changing settings there, or even restarting the router. Things like WEP passwords, MAC address filtering and DNS servers.

    Sent from my GT-N8013 using Android Central Forums
  6. #6  

    Default Re: Wi-fi is connected but I have no internet connection

    Also check your Nexus 7 settings. Under Settings/data usage /three dots in upper corner. Restrictions here may cause trouble.

    Sent from my Nexus 7 using Android Central Forums

Similar Threads

  1. Ignore.
    By Atheismo in forum Google Nexus 7 (2012) Accessories
    Replies: 1
    Last Post: 12-31-2012, 01:58 PM
  2. my zio connects to my pc, but pc shows no internet connection.
    By kraqit in forum Misc. Android Phone Chat
    Replies: 0
    Last Post: 03-13-2012, 04:43 PM
  3. I want to root fascinate but I have no computer
    By BCarle in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 9
    Last Post: 01-19-2012, 09:52 PM
  4. Wi-fi is turned off when device starts..
    By kibblenbits in forum Barnes & Noble Nook Color
    Replies: 4
    Last Post: 06-01-2011, 05:50 PM
  5. 4G Says "Connected" but there's no data
    By zeravla531 in forum Sprint Epic 4G
    Replies: 2
    Last Post: 12-06-2010, 09:31 AM

Posting Permissions

B