Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 2 of 2 FirstFirst 12
Results 26 to 36 of 36
  1. #26  

    Default Re: Nexus 7 stuck on the "X" screen

    how does one go about doing this? ive had the same problem and ASUS has replaced my tablet twice already, so ive had 3 total and every single one of them has had this issue, ide like to fix this myself instead of paying for the shipping to send it to asus
    Any help is much appreciated! thanks!
  2. #27  

    Default Re: Nexus 7 stuck on the "X" screen

    I got my nexus tablet March 24 2013 and its stuck already on the date screen ... I cant even power it off .... any suggestions of what to do ???
  3. #28  

    Default Re: Nexus 7 stuck on the "X" screen

    let me know if you have any suggestions on a fix ... mine is 4 months old and is stuck too !!! cant even power it off
  4. #29  

    Default Re: Nexus 7 stuck on the "X" screen

    HELP! Stuck too after trying to update to 4.3.

    Is there anyway to save my files? Pictures?
  5. #30  

    Default Re: Nexus 7 stuck on the "X" screen

    ok guys I had this issue after trying to update to 4.3. I did every other suggestion from turning it off to wiping the data. But this is how i fixed mine,
    1) download nexus 7 V5.0 or newer toolkit (you need windows for this doesnt work on mac)
    2) after installing nexus 7 toolkit and running it press Y to check for update
    3) then pick the version of your nexus 7 (e.g. wifi or gms/hspa etc), I picked number 14 (because I have the 32gb wifi version and I pick android 4.2.1)
    4)After going to the next section, Press 1 (then enter)
    5) after the drivers are installed connect your nexus 7 to computer via usb cable then bring the tablet into fastboot mode (hold vol up, vol down and power buttons)
    6) then press 3 in nexus 7 toolkit to unlock the bootloader
    7) after entering the next section press 1 then enter to unlock the bootloader (a message will pop up on your device asking your permission to unlock the device, go ahead and accept it), then your device will reboot
    8) after your device is unlocked, enter bootloader (follow step 5)
    9) then press 9 and enter to download google stock rom
    10) then press 1 and enter to download google stock image of your choice (I picked number 14)
    11) after the download is completed go the same menu as step 9, then press 2 and enter to Flash google factory image
    12) then it will ask your permission to start the procedure, then press y
    13) The process will continue for a while and after it is done it will restart your tablet and it will be ready to use again
    Thanked by 2:
  6. #31  

    Default Re: Nexus 7 stuck on the "X" screen

    I have made a tutorial on how to fix the problem it is here:
    Thanked by:
  7. #32  

    Default Re: Nexus 7 stuck on the "X" screen

    People,,
    Just purchased a new Nexus 7 (2nd Gen). GPS problems from the word go. Had to reboot to get a lock? now the unit will not reboot as it stuck on the X screen.

    it sounds like i'm not the only one with these problems. Anybody advise on best course of action apart from a very large hammer?

    Many thanks

    Lee
  8. #33  

    Default Re: Nexus 7 stuck on the "X" screen

    Many thanks for that fix. all up n running without the need for a large hammer!

    Thanks again,

    Lee
  9. #34  

    Default Re: Nexus 7 stuck on the "X" screen

    Thank you for the ideas. However, I tried the reboot (twice) and it went back to the X screen.
    I plugged the tablet into my computer and it does not recognize it.
    Any other ideas??? Besides sending it back to Asus.
  10. #35  

    Default Re: Nexus 7 stuck on the "X" screen

    That's very helpful. But it doesn't inspire anyone to buy this tablet. I have just bought this tablet today, and it stuck on the X ...so what is the use of tablet...which does this? It's no good having to mess about pressing a series of buttons. It should either work properly or be withdrawn by the company for them to get it solved. This must kill the rave reviews this tablet is receiving. It's great resolution sure, but its reliability is seriously undermined by so many people having the same problem. It should be withdrawn from the market until they can assure people that it has both reliability and durability. It's pointless having to press buttons and mess with it...like this. Either it works or it doesn't. If it doesn't, the company should withdraw this tablet and go back to the drawing board.
  11. #36  

    Default Re: Nexus 7 stuck on the "X" screen

    this video worked like a charm ,my 2 kids both got nexus 7 tablets and so did one of their friends,their friends tablet got stuck on the x screen I did what the video said and it now works need less to say I bookmarked this video incase I need it again thanks
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Stuck on the emergency mode yellow screen HELP!!!!
    By chad.jordan93 in forum T-Mobile Optimus T
    Replies: 0
    Last Post: 10-01-2012, 10:19 PM
  2. Galaxy Nexus Reboot Issue: Stuck on the Google Screen
    By Marius Mitchell in forum Sprint Galaxy Nexus
    Replies: 4
    Last Post: 09-14-2012, 06:41 PM
  3. Stuck on the emergency call screen
    By mcll in forum Other Sony Android Phones
    Replies: 1
    Last Post: 06-09-2012, 09:00 AM
  4. Kindle Fire stuck on the splash screen.
    By charlibob in forum Amazon Kindle Fire
    Replies: 1
    Last Post: 12-14-2011, 10:17 AM
  5. Stuck on the Moto boot screen (Bats)
    By beloved1228 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 23
    Last Post: 07-25-2010, 12:35 PM

Posting Permissions