1. jblank's Avatar
    Hi guys, I have had my Nexus 7 for about a week and a half now, and while I enjoy it, I find it to be extremely slow to open web pages. My connection is 40Mbps down and 4Mbps up, a fairly speedy connection, and what is weird is that my phone, a Samsung Galaxy S3 by AT&T is faster, much faster, at opening web pages. I can do speed tests and the results are accurate, the signal is strong, and I can do things like stream You Tube videos through the app, in HD, with not a single issue, but just simple web browsing, is a chore....laborsome, and some pages, even like the Drudge Report, which is about the most simple webpage there is, sometimes takes 5-10 seconds to load. I did a recovery to factory defaults and nothing has changed. Any ideas?
    01-23-2013 09:47 AM
  2. mr_nobody's Avatar
    Try a different web browser?
    01-23-2013 11:10 AM
  3. jamie's Avatar
    Open your app drawer
    Open Google Currents
    Click the three dots in the top right corner of the app
    Tap Settings
    Uncheck Enable Background Sync
    Reboot your Nexus

    Try this and see if it helps. It worked for mine. Its a known problem.

    Sent from my Nexus 7 using Tapatalk HD
    jblank likes this.
    01-23-2013 11:12 AM
  4. jblank's Avatar
    Wow, so this is a known issue huh? I will definitely try that when I get home this evening. Is it a problem where that app is "hogging" the available bandwidth and processing power?
    01-23-2013 12:19 PM
  5. jblank's Avatar
    Well, can't say this helped much.....very frustrated with it at this point.
    01-25-2013 10:35 AM
  6. papasurf's Avatar
    I just tried the same website that you used on my stock Nexus 7 and I connected in about 2 seconds from my home wifi. but I do have issues with a site called the Verge which loads slow for me.
    01-25-2013 02:27 PM
  7. bigtroutz's Avatar
    Well, can't say this helped much.....very frustrated with it at this point.
    try a process closer, cache cleaner, adblocker and THEN your browser also try that process with a different browser
    eg:
    https://play.google.com/store/apps/d...Fza2tpbGxlciJd
    https://play.google.com/store/apps/d...ZmUuY2FjaGUiXQ..
    https://play.google.com/store/apps/d...y5hbmRyb2lkIl0.

    if this process DOES fix your problem, you have instaled something nasty. Manually uninstall the bad process by looking at which processes are hogging your cpu/bandwidth/whatever
    syrinxstar likes this.
    01-25-2013 05:38 PM
  8. requiemsallure's Avatar
    I had this problem with mine, recently too, i did many things in order to try to fix this, however the only thing that really worked was when i reviewed a list of default program that i had disabled because i would have rather used another type. the solution was enabling the default downloads program. I had originally disabled it in order to use a different download program. I didn't notice it right away but after that things started to run very very slowly.

    if you have similarly disabled some of your default programs, try to enable them one at a time and see what fixes the problem.
    04-23-2013 03:06 PM
  9. sparksd's Avatar
    What browser are you using? I have been playing with different browsers and have found Boat, Dolphin, and most recently, Puffin, to be better performers for me than anything else. Puffin in particular seems the snappiest (not just on my Nexus 7 but also on my Asus Transformer Prime and Galaxy S3) - give the free version a trial.

    Dave
    04-23-2013 03:50 PM

Similar Threads

  1. Slow web browsing
    By abcalvinchan in forum HTC EVO View 4G
    Replies: 13
    Last Post: 07-19-2011, 10:35 PM
  2. Replies: 14
    Last Post: 05-19-2011, 10:40 PM
  3. [WARNING] if you flash CWM on the Nexus S, you can't go back to stock just yet
    By Jerry Hildenbrand in forum T-Mobile Nexus S Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 04-08-2011, 09:02 AM
  4. Stock/Nexus One Launcher on Inc.
    By clabbin in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 06-05-2010, 05:07 PM
  5. "Nexus" Live Wallpaper on stock Droid 2.1
    By wh2332 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 14
    Last Post: 04-03-2010, 12:45 PM
LINK TO POST COPIED TO CLIPBOARD