1. Bronnyl's Avatar
    Hi Everyone,
    Hope someone can help me - I'm a relative newbie having just bought my Nexus 7 a month ago.

    My problem is that while I have imported my Google contacts successfully into the People app, I can't get it to sync with either the Email or Gmail apps. So when composing an email, when I type in a few letters of a recipient's name, nothing comes up. In the People app when I touch the email address, I only get a 'copy to clipboard' option.

    Any help would be appreciated - I think I've got all the settings right....

    Thanks
    Bron
    01-30-2013 05:39 PM
  2. still1's Avatar
    settings-google-[ur email]-uncheck and check contacts. make sure to have internet first

    open people app. reboot. open gmail. press refresh and try again
    Bronnyl likes this.
    01-30-2013 08:48 PM
  3. Bronnyl's Avatar
    Thanks for that - didn't work though, unfortunately.
    Just thinking - could this be because I have my ISP account in the Email app as well as my Gmail account?

    Bron
    01-30-2013 09:40 PM
  4. still1's Avatar
    Thanks for that - didn't work though, unfortunately.
    Just thinking - could this be because I have my ISP account in the Email app as well as my Gmail account?

    Bron
    gmail app uses gmail contacts!! Your ISP email uses the contacts it has! people app(although it is synced with Google contacts) has nothing to do with gmail/ISP email contacts.
    not showing contact is just weird. doesn't work that way.
    Bronnyl likes this.
    01-30-2013 09:45 PM
  5. B. Diddy's Avatar
    In the People app, check to see what account your contacts are linked with. In order for them to sync with Gmail, they need to be Google contacts. Select any contact and edit it. It should say at the top of the screen if it's a Google contact or not.

    If your contacts aren't associated with your Google account, I suggest reimporting your contacts into your Gmail account using the web version on your desktop. Then your contacts will sync with your phone, and hopefully your phone will recognize then when you start typing them.

    Sent from my DROID RAZR using Android Central Forums
    Bronnyl likes this.
    01-30-2013 09:50 PM
  6. Bronnyl's Avatar
    Yep they are associated with my Google account. I'll try reimporting them.
    Thanks for your help.
    01-30-2013 09:53 PM
  7. still1's Avatar
    also, go here and see if you can see all your contacts here(to verify) https://mail.google.com/mail/u/0/?tab=wm#contacts
    Bronnyl likes this.
    01-30-2013 10:03 PM
  8. Bronnyl's Avatar
    Yes they are all there.
    Reloaded them and it's still not working - looks like i might have to add them manually every time I email - that or just not use the tablet for composing new emails
    Thanks for help anyway, everyone.
    01-30-2013 10:50 PM
  9. B. Diddy's Avatar
    It ought to work. Have you tried rebooting your device?

    Sent from my Nexus 7 using Android Central Forums
    01-30-2013 11:09 PM
  10. Bronnyl's Avatar
    Yes, a couple of times....just notice that someone else had the same issue, she posted the question to a Google forum. Don't think she found a solution though.
    01-31-2013 12:05 AM
  11. B. Diddy's Avatar
    Go to Settings/Accounts-Google, then tap on your Google account, and see if "Contacts" is checked for syncing. On another forum, someone mentioned that Gmail wouldn't give contact suggestions until he made sure Contacts were syncing.

    Sent from my Nexus 7 using Android Central Forums
    01-31-2013 02:14 AM
  12. wunderbar's Avatar
    Someone else in another thread had a similar problem. what they did to fix it was export all the contacts out of gmail, delete the contacts, then re-import the contacts into gmail. Everything started working after that.
    01-31-2013 08:58 AM
  13. B. Diddy's Avatar
    Good idea, but instead of exporting the contacts, it's easier to try this, if all of your contacts are stored in your Google account:

    1. Go to Settings/Apps/All, select Contacts Storage.

    2. Clear data.

    3. Go to Settings/Accounts-Google, tap your Google account, then tap Contacts to resync your contacts from your Google account.

    4. Your Contacts should now be restored. Try again to see if the recipient field populates when you start typing.

    Sent from my Nexus 7 using Android Central Forums
    01-31-2013 12:36 PM
  14. Bronnyl's Avatar
    Hello all, sorry I haven't been back - my tablet was stolen in a house invasion two months ago. I've now got my replacement....
    I really hoped this would work on this new one - but it doesn't. Still have the same problem with syncing contacts to either Email or Gmail.
    I've tried all your suggestions - thanks for that.
    I'll just keep experimenting I guess - I must be doing something wrong. Thanks for all your help.
    03-28-2013 08:53 PM
  15. Bronnyl's Avatar
    Right - have worked out what it is. The fields didn't map properly when I exported them from Thunderbird (I have a Mac) into Google and then tried to sync with the Nexus email programs. I've tried to rename the fields on the vcf file but no go, so it's manual modification I have to do. But at least I know what it is now and can get it working. Thanks again.
    Ntchwaidumela likes this.
    03-29-2013 02:21 AM
  16. JohnPA2006's Avatar
    To B. Diddy.....

    THAT WORKED, THANK YOU SO MUCH.
    I LOVE YOU, BIG HUGS !!!!


    I bought a Verizon DROID MAXX and have my contacts syncing from Gmail, of ALLLL the contacts to not sync, it was my wife.
    The contact I talk to all the time.

    Phew... Im so happy now !!!
    B. Diddy likes this.
    04-24-2014 10:30 PM
  17. B. Diddy's Avatar
    LOL, always nice to see a year-old post is still helpful!
    04-24-2014 10:36 PM
  18. Carol Gallmeyer's Avatar
    This worked! THANK YOU! I was going crazy. All better now.
    B. Diddy likes this.
    10-03-2014 01:38 PM

Similar Threads

  1. Google Contacts won't sync
    By Ed Hughes in forum HTC Hero
    Replies: 40
    Last Post: 08-30-2016, 10:43 AM
  2. Neither Samsung Email or Gmail App picking up my Contacts info
    By Nicola Swinnerton in forum Samsung Galaxy Tab 2 10.1
    Replies: 0
    Last Post: 01-13-2013, 02:53 PM
  3. Replies: 0
    Last Post: 11-30-2011, 10:51 AM
  4. Google Contacts won't sync
    By blackberryconvert2011 in forum Verizon HTC Thunderbolt
    Replies: 8
    Last Post: 06-05-2011, 04:34 AM
  5. Contact won't sync from phone to gmail
    By bucsnnoles in forum HTC EVO 4G
    Replies: 17
    Last Post: 08-06-2010, 11:06 AM
LINK TO POST COPIED TO CLIPBOARD