11-28-2016 01:44 PM
77 1234
tools
  1. Denisse Perez's Avatar
    Go to device manager

    find your device...should be under the name with ADB included

    Right click the device under the drop down menu

    Click Update Drive Software...

    Click 'Browse my computer for driver software

    Click 'Let me pick from list of device...'

    Should give you either 2 or three options

    Click on 'MTP USB Device'

    Not sure if you ever fixed your problem, but I had this problem recently, and while trying everything that was suggested, I stumbled upon this solution. Hope it is still relevant to someone out there still struggling with this madness.
    01-05-2015 12:48 AM
  2. Michael Harchaoui's Avatar
    enable usb debugging in developer options. worked like a charm on my nexus 7 2013!
    01-07-2015 08:19 AM
  3. B. Diddy's Avatar
    Apply hard reset on the device and check drivers in device manager.
    Hard reset shouldn't be necessary.
    01-07-2015 05:52 PM
  4. owenscott's Avatar
    The following steps might different depending on your version of Windows and what driver your PC loaded for your device. But idea is to uninstall the driver your PC is using and disconnect your Nexus 7 and reconnect.

    Go into Devices and Printers on your windows PC >>> Right click your Nexus 7 >>> Properties >>> Hardware >>> Properties >>> Change settings >>> Driver >>> Uninstall. >>>>> Done >>>> Then unplug Nexus 7 and replug and Windows should load the correct driver and Nexus 7 should be recognized.
    This way worked for me ... thanks.
    When i was deep in there it said the driver was samsung. Id say conflict there between asus and samsung causes it to be an issue.
    jdbii likes this.
    01-08-2015 11:55 AM
  5. Florencio069's Avatar
    Hey, I am new to this site and I'd like to share you with some thoughts on your problem.
    I've been there once with my computer and I finally got it back to normal by getting a USB drivers right for my device from a website named Driversguru or something like that.
    The thing is, I've always get all my drivers updated from this site. There're always almost all kinds of latest drivers for you. And they seem to have a regular updating process, so you could always get the newest drivers once they're released.
    Hope this could help.
    Good luck.
    01-09-2015 02:40 AM
  6. Marty Scheetz's Avatar
    After updating to 5.0.2 on my N7 2012, my PC wouldn't recognize it. I tried numerous things and the tablet USB connection was set to (MTP). I decided to change that to Camera (PTP) and viola, it was recognized and I was at least able to work with photos and video. For the heck of it, I changed it back to (MTP) and it was instantly recognized, why, I have no idea, but starting with PTP and then switching to MTP seemed to kick start it and it fixed the problem.
    01-22-2015 03:27 PM
  7. Rick2814's Avatar
    I had the same USB issue after updating to Android v.5.0.2. I resolved the problem by: 1. Start tablet. 2. Swipe down on the opening page. 3. Tap the "Connected as a ........" window. 3. Select Camera (PTP) check box then select Media device (MTP) check box. That's it!
    01-23-2015 09:30 AM
  8. Peg Neal's Avatar
    Pretty much the same thing that I did. Wish I'd tried that sooner because I spent a few hours trying other things but nothing else was working for me. Live and learn!
    01-23-2015 10:09 AM
  9. enwiggen's Avatar
    Many thanks!! Easy solution. I really appreciated the fact that you posted this.
    01-31-2015 12:14 PM
  10. Darrenski's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    This fixed my problem. Thanks mate.
    02-18-2015 04:29 AM
  11. Mischiew's Avatar
    Using the procedure linked below worked here. It comes from a previous driver installed - in this case by a Galaxy device, which is not specific enough in its vendor and product ID. Sloppy practice from some vendors as Samsung and some others.

    www asus com/support/Knowledge-Detail/28/2/Nexus_7/D53452AE-143C-42F1-BDC1-7F168085F0D7/

    (unfortunately this poor site won't let me post an URL, so you'll have to copy / edit it)

    Have you tried to change the USB cable ?, it was the solution in my case
    That was already suggested just above and turned down, people just don't read do they?
    03-07-2015 08:13 AM
  12. Ratzazz's Avatar
    Thank you!!!!
    Wish I had seen your post first....
    03-13-2015 02:22 PM
  13. ReechWFC's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    this worked for me, thanks very much
    04-08-2015 06:03 PM
  14. flicker0x7's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    Thanks, this seems to do the trick.
    04-13-2015 11:18 AM
  15. AmbientApps's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    Thanks for this quick tutorial.
    04-14-2015 07:54 AM
  16. jayfdee's Avatar
    Yes that worked , thanks. I have had this problem before after an android update, but forgot how to fix. Thanks for taking the time to post the solution.
    04-24-2015 12:49 PM
  17. janolle's Avatar
    My Nexus 7 does not work with USB in MTP mode. Change the setting to PIP (camera) it works.

    In the device table (devices and printer) my Nexus show a picture locks like a power on/off AC device in MTP mode.
    In PIP mode a see a camera.
    I have tried to reinstall drivers but the PC says that latest driver already is installed.
    Please advice!
    04-28-2015 08:05 AM
  18. davo2's Avatar
    This worked for me - locate Acer Device ADB in Device Manager - properties uninstall device. Unplug, replug, allow it to reinstall.

    Thanks for this advice
    awesome wizard likes this.
    07-31-2015 05:18 PM
  19. MickeysChick's Avatar
    Go to This Pc you'll see Nexus. Right click on the Nexus Icon and select Transfer Picture and Video
    08-27-2015 03:59 PM
  20. ZKC's Avatar
    THANK YOU!!! This worked perfectly after trying all sorts! :-)

    Go to Acer Device ADB in Device Manager. Right click. Go to Properties. Uninstall. Unplug tablet. Plug tablet back in and there you should have it!! :-)
    09-06-2015 07:27 PM
  21. awesome wizard's Avatar
    Go to device Manager.
    When all devices are displayed, Plug in the Nexus 7.
    When You see the device Pop up in the list, right click it and Uninstall it.
    Reconnect device, wait for the drivers to auto detect and install then everything should be fine.
    Open up My Computer, reconnect Nexus and it should now appear in the devices and drives.
    I believe this May be a windows 10 issue but I'm not 100% on that.
    I hope this helps.
    Bye for now.
    01-17-2016 12:31 PM
  22. mkdrive2's Avatar
    Hello, I have the exact same problem. I also have the old Nexus 7 (2012). My problem is not dependent on the OS of my computer. I tried both with Windows 8.1 and Ubuntu 14.04.3 LTS.

    What I noticed, though, is that my Nexus 7 is recognized when I start up fastboot mode, but once I go to recovery mode or start up Android OS all my computers don't recognize Nexus 7 anymore. Please tell me what I can do to fix this!
    01-23-2016 09:04 AM
  23. Aakash Shah3's Avatar
    This worked. Thanks a lot!
    01-23-2016 11:41 PM
  24. WarningU2's Avatar
    I've been pulling my hair out on this one for several days. My Nexus 7 was working fine swiping it into MTP mode on Windows 10 x64 but then without any reason apparent to me, one morning said a malfunction had occurred and Windows 10 wouldn't recognize it. I tried all the steps that are listed here on this forum and many other forums with likely 1000's of people experiencing this issue.

    I thought I'd share my last effort that was successful.

    1) I tried removing the device from Windows 10 devices and printers, thinking it would reinstall. It failed on the same error.
    2) I found the entry in device manager under USB controllers and removed it.
    3) Failed again
    4) I downloaded USB drivers usb_driver_r06_windows.zip (can't post the link)
    5) Tried it again and it failed. ARRRHHHHGGGGHH!!
    6) From device manager I showed hidden items and uninstalled all failed installations ... there were lots. I rebooted Windows without issue.
    7) Then to avoid stressing out further I powered off my Nexus 7 and put it in a draw and forgot about it.
    8) I decided this morning to try again. I plugged it into the same port with the same cable that had failed. I then turned on the Nexus 7 ( it had been powered off 5 days). Within 10 seconds ... Windows 10 told me that it was installing a device ... this is new.
    9) Voila ... it was installed. No error. I swiped MTP for file transfer again and I am able to access my Nexus 7 again as per normal.

    I can only presume that the USB driver /installation somehow became corrupted but I think the actual cold start after waiting for a period of time with new USB drivers forced the install again or my cleaning up all the old USB installs got rid of the corruption. I have no idea. But I thought I would share my experience in the event it may help someone else. The key is to be patient and forget about it a while it would seem.
    01-31-2016 10:03 AM
  25. MidgeMum's Avatar
    I found this solution to the above problem. I too was perplexed with this USB connectivity issue with my Nexus 7 2...
    This method is so simple, but it seems very elusive:

    Check the USB settings on the Nexus 7
    - Open the Nexus Settings App
    - Select Storage (It should show space used by programs, media, etc)
    - Open the menu (the 3 dot icon - in upper right corner on my model)
    - Select USB Computer Connection
    - Make sure the Media Device (MTP) is check marked by touching the check box
    This makes the Nexus 7 look like a drive when connected via USB

    You can now try connecting the Nexus 7 to the computer via the USB cable.
    I was having the same problem. Windows 7 was showing error message for unknown device regardless of what I did and there wasn't an icon to interact with in Device Manager but your solution worked. Thank you, saved me hours of needlessly updating drivers, etc.
    07-03-2016 11:34 AM
77 1234

Similar Threads

  1. Will the nexus 5 get ota updates if my carrier is sprint
    By Deadly_Poison630 in forum Google Nexus 5
    Replies: 14
    Last Post: 02-19-2014, 11:50 AM
  2. App that blocks SMS but not calls?
    By Axic10 in forum Android Apps
    Replies: 3
    Last Post: 02-14-2014, 05:07 PM
LINK TO POST COPIED TO CLIPBOARD