Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. Thread Author  Thread Author    #1  

    Default WiFi stuck "turning on"

    I was charging my Nexus 7 and unplugged it. Started booting and it got stuck on the Nexus "X". Held down the power button and rebooted again, only now my WiFi is completely gone, even the symbol isn't there, nor the outline of the symbol when it's in off mode.

    I go into settings to toggle it on and the button is greyed out, I am not able to toggle it on and off. When I click on WiFi it just says "turning WiFi on" like it's stuck or something. I've tried going into the advanced settings to play around with WiFi optimization and the like but to no avail. I'm really trying to avoid doing a factory reset. Any help?



    Posted via Android Central App
    Attached Thumbnails Attached Thumbnails WiFi stuck "turning on"-20130818_165609.jpg   WiFi stuck "turning on"-20130818_165622.jpg   WiFi stuck "turning on"-20130818_165653.jpg   WiFi stuck "turning on"-20130818_165711.jpg  
    Last edited by ZephyrsDream; 08-18-2013 at 05:07 PM.
  2. #2  
    Ronnie2's Avatar

    Posts
    219 Posts
    ROM
    paranoidKangdroid

    Default

    Stupid double post

    Sent from my Nexus 7 using Tapatalk 4
    Always rooted.
  3. #3  
    Ronnie2's Avatar

    Posts
    219 Posts
    ROM
    paranoidKangdroid

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by Ronnie2 View Post
    You might try factory resetting the tablet. I know you probably don't want to do that but it eliminates any problem you may have software wise.

    Sent from my Nexus 7 using Tapatalk 4


    Sent from my Nexus 7 using Tapatalk 4
    Always rooted.
  4. Thread Author  Thread Author    #4  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by Ronnie2 View Post
    Sent from my Nexus 7 using Tapatalk 4
    Thanks, Ronnie. I ended up doing a factory reset even though I didn't want to. It was a really strange thing to happen. Made me think that when I powered it off from the boot loop and powered it back on, some data may have gotten corrupted.

    Sent from my SPH-L710 using Tapatalk 4
    Sprint Samsung Galaxy S3 - White 16GB - Nova Launcher, 4.4.2, Vintage Icon Pack
    Nexus 7 (2013) 32GB, 4.4.2, Nova Launcher, Axis Icon Pack
  5. #5  
    Asus_Fred's Avatar

    Posts
    48 Posts
    Global Posts
    51 Global Posts

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by ZephyrsDream View Post
    Thanks, Ronnie. I ended up doing a factory reset even though I didn't want to. It was a really strange thing to happen. Made me think that when I powered it off from the boot loop and powered it back on, some data may have gotten corrupted.

    Sent from my SPH-L710 using Tapatalk 4
    Did the reset resolve the issue? If it did not you can let me know directly and we can further troubleshoot it. (direct contact cl-fred@asus.com)
  6. Thread Author  Thread Author    #6  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by Asus_Fred View Post
    Did the reset resolve the issue? If it did not you can let me know directly and we can further troubleshoot it. (direct contact cl-fred@asus.com)
    Yes, it did. When I was charging it, it wasn't plugged into my laptop but to the wall. Probably doesn't make a difference but I guess any little thing will happen with gadgets nowadays.
    Sprint Samsung Galaxy S3 - White 16GB - Nova Launcher, 4.4.2, Vintage Icon Pack
    Nexus 7 (2013) 32GB, 4.4.2, Nova Launcher, Axis Icon Pack
  7. #7  
    HalizDad's Avatar
    Banned

    Posts
    1,099 Posts
    ROM
    Stock for once.

    Default Re: WiFi stuck "turning on"

    Did you by chance have a guest account set up?

    Sent from my Nexus 7 using AC Forums mobile app
  8. Thread Author  Thread Author    #8  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by HalizDad View Post
    Did you by chance have a guest account set up?

    Sent from my Nexus 7 using AC Forums mobile app
    No I did not have a guest account set up. It boots directly to my own account.

    Sent from my awesome Sprint Galaxy S3 using Tapatalk 4
    Sprint Samsung Galaxy S3 - White 16GB - Nova Launcher, 4.4.2, Vintage Icon Pack
    Nexus 7 (2013) 32GB, 4.4.2, Nova Launcher, Axis Icon Pack
  9. #9  

    Default Re: WiFi stuck "turning on"

    Are you using Nexus 7 2nd gen (2013)? I have the same problem but factory reset didnt help
    Should i reflash it?
    Thanks for any helps!
  10. Thread Author  Thread Author    #10  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by nctam View Post
    Are you using Nexus 7 2nd gen (2013)? I have the same problem but factory reset didnt help
    Should i reflash it?
    Thanks for any helps!
    Yes, I have a 2013 Nexus 7. And I did do a factory reset and it helped. I would suggest re-flashing it or exchanging for a new one.

    Sent from my Nexus 7 using Tapatalk 4
    Sprint Samsung Galaxy S3 - White 16GB - Nova Launcher, 4.4.2, Vintage Icon Pack
    Nexus 7 (2013) 32GB, 4.4.2, Nova Launcher, Axis Icon Pack
  11. #11  
    Goodeye's Avatar

    Posts
    181 Posts
    Global Posts
    299 Global Posts
    ROM
    KitKat 4.4 Stock Android

    Default Re: WiFi stuck "turning on"

    My mother had a similar issue with connecting via WiFi on her N7 2012. She is on the latest 4.3 update.

    This was fixed by going into the time settings and changing the "use network time" option. Sure enough it worked. Only thing I could think of is it was trying to poll for the time and/date as it was connecting and causing a problem. Sounds odd but it worked

    Sent from my Nexus 7 using Tapatalk 4
  12. #12  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by Goodeye View Post
    My mother had a similar issue with connecting via WiFi on her N7 2012. She is on the latest 4.3 update.

    This was fixed by going into the time settings and changing the "use network time" option. Sure enough it worked. Only thing I could think of is it was trying to poll for the time and/date as it was connecting and causing a problem. Sounds odd but it worked

    Sent from my Nexus 7 using Tapatalk 4
    I also changed the "use network time" option before the Wifi got problem. But I didn't try to toggle this option before doing the hard reset. Now my Nexus 7 2013 stuck in the "Turning on WiFi" screen.
    Thanked by:
  13. #13  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by nctam View Post
    I also changed the "use network time" option before the Wifi got problem. But I didn't try to toggle this option before doing the hard reset. Now my Nexus 7 2013 stuck in the "Turning on WiFi" screen.
    Did you get this problem fixed? Im having the same problem after a reset.
  14. #14  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by usmcfabian View Post
    Did you get this problem fixed? Im having the same problem after a reset.
    even i'm facing the same issue on galaxy nexus. factory resetted and it didn't work. i even flashed stock rom image and it hasn't worked as well.. it was running fine for over a year
    has anyone been able to get any workaround for this?
  15. #15  

    Default Re: WiFi stuck "turning on"

    my anderoid 4.1 jelly bean is not working at all. launcher has stopped working, gmail has stopped working, it wont pick up wifi, etc. i've tried resetting but nothing works. any help???
  16. #16  

    Default Re: WiFi stuck "turning on"

    can anyone asit please?
    Something strange started happening to my Tablet (AK28) yesterday, 9th Dec. Whenever I switch on the WiFi, it stays on, and displays "Turning Wi-Fi on...", but after a while, it returns to off position, while the display still shows "Turning Wi-Fi on...".




    I experience the same issue whenever I switch on the bluetooth. Factory reset could not solve the problem. Kindly advise me on what to do.
  17. #17  
    DEADF15H's Avatar

    Posts
    14 Posts
    Global Posts
    19 Global Posts

    Default Re: WiFi stuck "turning on"

    I'm having the same "Turning Wi-Fi On" hang issue with a Note 2 on ATT.
    ATT Note 2
  18. #18  

    Default Re: WiFi stuck "turning on"

    I also have the same problem on my L9 p760
    I have also tried factory reset , hard reset and reflash the lastest oficial version of JB and ... the problem still persist ..

    Could anyone help us with a viewpoint ?


    Thanks !
  19. #19  

    Default Re: WiFi stuck "turning on"

    My STAR N9389 running 4.2.1 started doing this. I removed the Micros SD card and everything went back to normal. WIfi turned on.

    I put the 16GB Micro SD back in the phone. Moved all apps to the internal storage.

    Made a backup copy of the card on my PC.

    Formatted the Micro SD. Copied my pictures, music, etc back to the Micro SD, put it back in the phone and everything is working normally again.

    I started moving the apps back to the Micro SD and the problems stated again. I assume it's a bad card.
  20. #20  

    Default Re: WiFi stuck "turning on"

    Quote Originally Posted by ZephyrsDream View Post
    I was charging my Nexus 7 and unplugged it. Started booting and it got stuck on the Nexus "X". Held down the power button and rebooted again, only now my WiFi is completely gone, even the symbol isn't there, nor the outline of the symbol when it's in off mode.

    I go into settings to toggle it on and the button is greyed out, I am not able to toggle it on and off. When I click on WiFi it just says "turning WiFi on" like it's stuck or something. I've tried going into the advanced settings to play around with WiFi optimization and the like but to no avail. I'm really trying to avoid doing a factory reset. Any help?

    https://www.dropbox.com/s/dd4cchckvn...818_165622.jpg

    Posted via Android Central App


    Hey all,
    After more than a week with NO WIFI, i have finally figured it out.
    Here are the detailed.
    ISSUE: After OTA update of 4.4.3 on new nexus 5, the phone was rebooted automatically and after reboot WIFI button was greyed out. It only showed "TURNING ON".
    FAILED SOLUTION ATTEMPTS: Following step DID NOT HELP
    1. Factory reset
    2. Battery drain and recharge after full drain
    3. Power off for few hours and restart
    4. Whacking the set on palm (yes, whacking, it was a recommended solution on a thread)
    5. Opened the handset and checked all the hardware link, every thing was fine
    6. Bootloader unlock, recovery installation (TWRP), downgrade to 4.4.2 (downloaded from google's web page)
    7. Downgrade to 4.4
    8. OTA update from down graded firmware
    9. Sideloading the 4.4.3 update on firmware 4.4.2
    10. Rooting, and installation of custom ROM (slimKat, Cynaogen mod)
    11. Installation of custom kernel (linaro)
    12. Flashing of 4.4.2 & 4.4 Radio/Boot images on stock rom of 4.4.3
    13. Clean install of 4.4.3 (removing everything from phone except recovery)
    14. *#*#4636#*#*, goto wifi and restart.
    15. *#*#4636#*#*, wifi state shown "UN-INITIALIZED"

    Actual Solution that worked
    ***** Install Paranoid Android ROM on rooted Nexus 5. The issue is with Kernel , which control the HW/OS communication. Apparently Kernel of this ROM removed the issue (but installation of SlimKat/CyanogenMod/Custom Kernel).
    I then restored the backup of stock 4.4.3 from recovery and did a factory reset. Wifi & every thing else works fine now *****
    Thanked by:
    GSDer 

Similar Threads

  1. Is There a Way to Get Mobile Hotspot on Boost?
    By jhern87 in forum Samsung Galaxy S3
    Replies: 6
    Last Post: 07-13-2014, 04:54 PM
  2. Replies: 6
    Last Post: 08-19-2013, 05:47 PM
  3. Replies: 0
    Last Post: 08-18-2013, 03:25 PM
  4. Replies: 0
    Last Post: 08-18-2013, 03:20 PM
  5. Auto Screen On - no longer working
    By SCjRqrQCnBQ19QoYCtdl in forum HTC One
    Replies: 0
    Last Post: 08-18-2013, 01:49 PM

Posting Permissions