Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Question T-Mobile - What am I doing wrong?

    I purchased my new Nexus 7 with the free for 30 days 2Gb T-Mobile plan. I activated and registered the Nexus with T-mobile. I then got a screen with instructions on how to activate the Nexus, #4 instruction saying I must purchase a data plan before I can use the device outside of the T-mobile.com website. Huh? In fact, I can use it on any web site. The problem is that my download and upload speed is 36Kbps. Yes, I said 36Kbps - dial-up speed, even on T-Mobile.com. The signal icon in the notification bar shows all bars lit, with a little "E" next to the icon. I don't know what that means.

    What is going on here? My phone is a DROID RAZR on Verizon, so I'm new to T-Mobile and newish to unbloated Android, and I can'f find any setting that might relate to this.

    BTW, my Build number is JLS36C, and checking for updates shows nothing new. I thought the latest update was different.

    Any help appreciated.
  2. #2  
    Aquila's Avatar

    Posts
    11,406 Posts
    Global Posts
    11,641 Global Posts
    Carrier
    Assassin 'Droid

    Default Re: T-Mobile - What am I doing wrong?

    Honestly the best bet would be to speak with T-Mobile's customer service about this and have them help get you on to their network. They can be reached at 1-877-746-0909.
  3. Thread Author  Thread Author    #3  

    Default Re: T-Mobile - What am I doing wrong?

    After leaving it off overnight, it's now working properly. T-Mobile customer service said I'm in an edge and HSPA area, and I am now getting about 12Mbps down and 2Mbps upload speeds according to the Speed Test app. Pings are horrible, though, at about 500-600ms.
  4. #4  

    Default Re: T-Mobile - What am I doing wrong?

    The "E" you saw means you were on the Edge network at the time. The download speed you saw is consistent with Edge performance.

Similar Threads

  1. Replies: 8
    Last Post: 09-28-2013, 07:24 PM
  2. what versio of android are you guys on?
    By lopey986 in forum AT&T HTC One
    Replies: 7
    Last Post: 09-24-2013, 11:21 PM
  3. Stupid question: how do I add more pages?
    By Shawn Cromotee in forum LG G2
    Replies: 5
    Last Post: 09-24-2013, 03:50 PM
  4. Which Battery do I get ?
    By emtae001 in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 09-24-2013, 01:43 PM
  5. What should the wallpaper resolution be?
    By maskedcarrot in forum Samsung Galaxy S4 Google Edition
    Replies: 0
    Last Post: 09-24-2013, 12:59 PM

Posting Permissions