1. larrygeary's Avatar
    I have a Nexus 7 with LTE, and my initial 30 days of free data with T-Mobile expired. I've been trying for 2-3 weeks to login to their website to put money for prepaid data onto my account. Every time I try, I get to a page where it tells me they are "busy upgrading their website" and direct me to login to their Mobile Management System (or whatever it's called) on another page. That page says I have no email on my account, but offers to use my existing email address. (Huh?) I enter that, and my password, but it also wants a PIN which I don't think was ever set. But I enter what I think my PIN would be, and the page indicates my password is invalid. I can understand their website being screwed up for a while, but 2-3 weeks? This is nuts. So I'm asking if anyone has gotten in recently, or is it just me?
    11-16-2013 08:55 PM
  2. ultravisitor's Avatar
    I certainly haven't. I have no idea what is going on with their website, but I hope it's fixed soon.
    11-16-2013 10:37 PM
  3. patruns's Avatar
    No problem here. I just logged in now after reading your post. Also logged in a couple of times last week without issue as I had to update my account.
    11-17-2013 11:26 AM
  4. howardv's Avatar
    I've been getting the same message about them upgrading their system for the past couple of weeks. You have to call them or go in a store to add money or check data usage. Have no idea when this will be fixed.
    11-17-2013 12:49 PM
  5. angry english's Avatar
    I have an iPad air and have the same issue, cannot verify my account, been on and off the phone with them for a week, they told me to just keep calling and they will put a data pass on my account, its the only way it gets data, royal pain in the buttocks

    Posted via Android Central App
    11-17-2013 05:25 PM
  6. larrygeary's Avatar
    I've been getting the same message about them upgrading their system for the past couple of weeks. You have to call them or go in a store to add money or check data usage. Have no idea when this will be fixed.
    This doesn't exactly fill me with confidence that joining T-Mobile will give me an enjoyable experience.
    11-17-2013 05:32 PM
  7. patruns's Avatar
    Are you using this URL? https://my.t-mobile.com/Login/
    11-18-2013 10:26 AM
  8. net62957's Avatar
    For me it's been hit or miss.......but seems to be getting better. I'm dropping by one of the stores tomorrow to add my new N7 to my account so I'll find out how the changes to the web site are going.
    11-18-2013 10:44 AM
  9. howardv's Avatar
    Are you using this URL? https://my.t-mobile.com/Login/
    Yup, but it takes me to a page saying:

    "Were busy upgrading our system to improve the way you purchase data, make payments and manage your account. The wait will be worth it!"

    I had the same problem as the OP. It was working good until I logged in and got a message that they have a new portal with many imporvements and I have to register and sign in through the new portal. I had to create a new PIN and give some other info. It was very confusing. I think anyone who registered is now locked out. It's possible that they removed that portal since it was having problems, so if you never registered, you can still access their old site. That could be why you are able to log-in. This is just my theory...not fact.
    11-18-2013 10:59 AM
  10. larrygeary's Avatar
    Are you using this URL? https://my.t-mobile.com/Login/
    When I turn on mobile data, I get a notification to "Sign in to the network". This takes me to https://my.t-mobile.com/Login/mytmobilelogin.aspx I login here, and it takes me to https://my.t-mobile.com/PrepaidMBBJump.aspx where it says:

    Thank you for using My T-Mobile!

    We're busy upgrading our system to improve the way you purchase data, make payments and manage your account. The wait will be worth it!

    Meanwhile, to apply funds to your account, please visit Mobile Internet Management, stop by your local T-Mobile retail store, or contact us.
    ...
    Mobile Internet Management is the page where it says I don't have an email address, requires a PIN I don't have, etc.
    11-18-2013 11:01 AM
  11. larrygeary's Avatar
    I had the same problem as the OP. It was working good until I logged in and got a message that they have a new portal with many imporvements and I have to register and sign in through the new portal. I had to create a new PIN and give some other info. It was very confusing. I think anyone who registered is now locked out. It's possible that they removed that portal since it was having problems, so if you never registered, you can still access their old site. That could be why you are able to log-in. This is just my theory...not fact.
    What is the URL of the NEW portal?
    11-18-2013 11:03 AM
  12. howardv's Avatar
    What is the URL of the NEW portal?
    I don't have the URL as it was a one time thing to register for the new portal. I did register and it was successful (created a new PIN). Now, I just go to the main t-mobile page and log-in, then it takes me directly to the message you posted where it says they are upgrading and it's not available.
    11-18-2013 11:37 AM
  13. patruns's Avatar
    Odd, I just signed in again without any problems. Did you folks try clearing all your related cookies?
    11-18-2013 02:29 PM
  14. howardv's Avatar
    Odd, I just signed in again without any problems. Did you folks try clearing all your related cookies?
    I just tried it again with my back-up laptop. Cleared cache, cookies, history, etc. Still got the same message about them being in the middle of an upgrade.
    11-18-2013 03:23 PM
  15. larrygeary's Avatar
    I just tried it again with my back-up laptop. Cleared cache, cookies, history, etc. Still got the same message about them being in the middle of an upgrade.
    Same here. Ridiculous. Maybe I should try AT&T?
    11-18-2013 07:50 PM
  16. patruns's Avatar
    I am not having any problems logging in. Where are you folks trying to log in from?
    11-19-2013 09:04 AM
  17. net62957's Avatar
    It's now easy to get on and off the site.........just can't conduct any business. At least I'm unable to do so. I did stop by T-Mobile this morning at 9AM to add my tablet to my account and inquire about the web site changes. The problem is they don't open til 10AM in Myrtle Beach. Dang.
    11-19-2013 10:01 AM
  18. howardv's Avatar
    I am not having any problems logging in. Where are you folks trying to log in from?
    From my desktop, laptop, and Nexus 7....none can log-in. I'm in Los Angeles.
    11-19-2013 10:10 AM
  19. larrygeary's Avatar
    From my desktop, laptop, and Nexus 7....none can log-in. I'm in Los Angeles.
    And I can't get in from New Jersey, either from my computer room or bedroom.

    Oh, maybe he meant the URL we're using? I don't want to retype the whole story. Please check my post a few comments up.
    11-19-2013 10:35 AM
  20. patruns's Avatar
    And I can't get in from New Jersey, either from my computer room or bedroom.

    Oh, maybe he meant the URL we're using? I don't want to retype the whole story. Please check my post a few comments up.
    No, I meant your physical location. I logged in fine from your link as well.
    11-19-2013 12:16 PM

Similar Threads

  1. Samsung Galaxy S4 - amoled display blue pixel burn in
    By Trolled123 in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 02-04-2014, 12:38 PM
  2. Note 2 to Nexus 5
    By bang_bang in forum Google Nexus 5
    Replies: 16
    Last Post: 01-08-2014, 06:31 PM
  3. Replies: 8
    Last Post: 11-18-2013, 02:18 PM
  4. How To Limit Apps
    By Don164 in forum HTC One M7
    Replies: 2
    Last Post: 11-17-2013, 06:15 PM
  5. How to turn off gmail notifications
    By Karmakop in forum Motorola Droid MAXX
    Replies: 4
    Last Post: 11-17-2013, 10:03 AM
LINK TO POST COPIED TO CLIPBOARD