1. jivif548's Avatar
    Hey, so I have a Samsung Galaxy S3, & just recently started having problems. When I try to sign in at the Google play store, I get a message saying 'Can't establish a reliable connection to the server. This could be a temporary problem or your android device may not be provisioned for data services.' At first I thought it was my internet connection but my internet works fine. So because I can't sign in, I can't download any apps or even look at any apps, the play store just doesn't work at all. I also can't sign in to my youtube account on the youtube app. Does anyone know how I can fix this, or why it's happening??
    02-24-2013 06:05 PM
  2. neil154's Avatar
    I would create a second gmail account and try logging in with that account. If that works then there is some problem with your password. Another thing to try is logging into play store from your PC.
    02-24-2013 06:48 PM
  3. jivif548's Avatar
    I tried logging in with a different account, but that didn't work either. Also, I could sign in to the play store on my computer with no problems, so it must be something wrong with my phone?
    02-25-2013 12:47 PM
  4. neil154's Avatar
    I tried logging in with a different account, but that didn't work either. Also, I could sign in to the play store on my computer with no problems, so it must be something wrong with my phone?
    So at this point I think you have to try a battery pull and then try logging in. If that does not fix it then settings>application manager(swipe to the all)>Google Play Store then clear data and clear cache.
    02-25-2013 01:38 PM
  5. jivif548's Avatar
    Nope, still not working I tried both things, it's not just the play store, it's all apps that need a google account
    02-25-2013 03:41 PM
  6. neil154's Avatar
    If your phone provider doesn't have any better suggestions then a factory restore would be what I would do (make sure you have a backup of all your data).
    02-25-2013 03:58 PM
  7. jivif548's Avatar
    I just did a factory reset, it didn't work... :/
    02-26-2013 07:46 PM
  8. gnr_2's Avatar
    I just did a factory reset, it didn't work... :/
    If you did a factory reset, did it make you go through phone set up where you could input your account information again? Try deleting the account in your phone settings and adding it back?

    Sent from my totally awesome Sprint Galaxy Nexus, even if I don't know all its secrets yet.
    02-26-2013 07:59 PM

Similar Threads

  1. Help! I'm Bricked and I don't know what to do!
    By deaver_92 in forum Virgin Mobile Optimus V
    Replies: 14
    Last Post: 03-25-2011, 03:31 PM
  2. Don't know what to do :(
    By joakyno in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 10
    Last Post: 03-05-2011, 08:21 AM
  3. I don't know what to do...
    By lauradenise in forum HTC Droid Eris
    Replies: 5
    Last Post: 01-04-2011, 01:33 PM
  4. I don't know what to do about the update
    By krisrock in forum HTC EVO 4G
    Replies: 19
    Last Post: 07-31-2010, 01:48 PM
LINK TO POST COPIED TO CLIPBOARD