Results 1 to 17 of 17
  1. Thread Author  Thread Author    #1  

    Default 4.1 OTA Update: Missing Stock Camera App

    So I upgraded to 4.1 after returning from holiday. Everything seems to be fine except that the stock camera app has disappeared. Tried rebooting and searching all apps but it's gone.

    Anyone know where I can get the apk from?
  2. Thread Author  Thread Author    #2  

    Default

    I have noticed that the stock gallery app is also missing.

    Sent from my Galaxy Nexus using Android Central Forums
  3. #3  

    Default

    Have you disabled the Gallery app? The Camera is now part of Gallery, rather than a separate app. So if you remove or edit the Gallery app it can cause Camera to go missing.

    Sent from my Galaxy Nexus using Android Central Forums
  4. Thread Author  Thread Author    #4  

    Default

    I havn't knowingly disabled it. The gallery app does not appear in my app drawer, however it does appear under system/app

    Is there any way to re-enable it? Or reinstall it?

    Sent from my Galaxy Nexus using Android Central Forums
  5. #5  

    Default Re: 4.1 OTA Update: Missing Stock Camera App

    Quote Originally Posted by Dtim56 View Post
    I havn't knowingly disabled it. The gallery app does not appear in my app drawer, however it does appear under system/app

    Is there any way to re-enable it? Or reinstall it?
    If you go into Settings > Apps > All, and scroll to the very bottom, is Gallery disabled/grayed out? You can re-enable it from there.
    LG Nexus 5 / LG Nexus 4 / HTC One / Sony Xperia ZL // T-Mobile / AT&T
  6. Thread Author  Thread Author    #6  

    Default

    No it's not on the list at all. However it does appear in system/app and it also appears in the app list if I use AppInstaller.

    If I try to reinstall it (either from system/app using Astro, or through AppInstaller) it gives the usual system app warning and then begins the install but fails every time.

    (My device isn't rooted incase that makes any difference)

    Sent from my Galaxy Nexus using Android Central Forums
  7. #7  
    yodatom10's Avatar

    Posts
    1,884 Posts
    Global Posts
    2,043 Global Posts
    ROM
    Stock

    Default

    I would try an factory reset. And then try to get in touch with google tech support

    Sent from my Jellybean powered GalaxyNexus
  8. Thread Author  Thread Author    #8  

    Default

    Will a factory reset take me back to ICS, or will it just reset Jelly Bean?

    I'm reluctant to do a hard reset but if that is the only solution then looks like I have no choice.

    Have also noticed that since the update my calendar is screwed, it's saying there is no calendar to sync but if I login via my computer's browser all the info is there.

    Is there a way to reset or redownload the OTA update? I have a feeling that the download might have been corrupted or interrupted maybe.

    Sent from my Galaxy Nexus using Android Central Forums
  9. #9  

    Default Re: 4.1 OTA Update: Missing Stock Camera App

    Quote Originally Posted by Dtim56 View Post
    Will a factory reset take me back to ICS, or will it just reset Jelly Bean?

    I'm reluctant to do a hard reset but if that is the only solution then looks like I have no choice.

    Have also noticed that since the update my calendar is screwed, it's saying there is no calendar to sync but if I login via my computer's browser all the info is there.

    Is there a way to reset or redownload the OTA update? I have a feeling that the download might have been corrupted or interrupted maybe.
    It won't send you back to ICS. It'll just put you back to factory settings of Jelly Bean. If you accepted an official OTA then I highly doubt there was a corrupt download. The OTA simply won't apply if its a bad download.

    I know you're not the only one having this issue (seen others post about it), but I'm not entirely sure how to fix it.
    LG Nexus 5 / LG Nexus 4 / HTC One / Sony Xperia ZL // T-Mobile / AT&T
  10. Thread Author  Thread Author    #10  

    Default

    OK, so assuming I hard reset and the OTA was sound it "should" resolve my problem then.

    Looks like that is my only option.

    I am curious as to what could have caused the issue then, assuming the download/install was fine. I guess I'll never know.

    Out of interest, is it possible to manually download the update and re-install it over my existing install? I doubt i'd be comfortable doing it without detailed instructions, but im just wondering if that is possible?

    Sent from my Galaxy Nexus using Android Central Forums
  11. #11  
    dbareis's Avatar

    Posts
    285 Posts
    Global Posts
    286 Global Posts

    Default

    Camera app has changed as shortcuts to it don't work until recreated. Someone else said they couldn't see it until they had UNhidden the gallery app.

    Sent from my Galaxy Nexus
  12. Thread Author  Thread Author    #12  

    Default

    Thanks. How do I unhide it? As far as I know I have never hidden it in the first place

    Sent from my Galaxy Nexus using Android Central Forums
  13. #13  

    Default Re: 4.1 OTA Update: Missing Stock Camera App

    Quote Originally Posted by Dtim56 View Post
    OK, so assuming I hard reset and the OTA was sound it "should" resolve my problem then.

    Looks like that is my only option.
    Can't say that it'll fix it for sure, but it can't hurt I suppose.

    I am curious as to what could have caused the issue then, assuming the download/install was fine. I guess I'll never know.

    Out of interest, is it possible to manually download the update and re-install it over my existing install? I doubt i'd be comfortable doing it without detailed instructions, but im just wondering if that is possible?
    There's no way that I'm aware of that you can download and flash over your current install. The only update packages that are available are for people who are currently on 4.0.4 and want to update to 4.1.1 for the first time.
    LG Nexus 5 / LG Nexus 4 / HTC One / Sony Xperia ZL // T-Mobile / AT&T
    Thanked by:
    Dtim56 
  14. Thread Author  Thread Author    #14  

    Default

    OK, thanks for all the help. I will backup my pics and some other bits and pieces tomorrow and try a hard reset. Fingers crossed that will resolve the issue.

    Sent from my Galaxy Nexus using Android Central Forums
  15. Thread Author  Thread Author    #15  

    Default

    So I bit the bullet and did a hard reset and everything is now working fine!

    Thanks for all the help.

    Sent from my Galaxy Nexus using Android Central Forums
  16. #16  

    Default Re: 4.1 OTA Update: Missing Stock Camera App

    Quote Originally Posted by Dtim56 View Post
    So I bit the bullet and did a hard reset and everything is now working fine!

    Thanks for all the help.
    Well glad it worked.
    LG Nexus 5 / LG Nexus 4 / HTC One / Sony Xperia ZL // T-Mobile / AT&T
  17. #17  

    Default Missing Stock Camera App

    My Fiance dropped his phone in a minimal amount of water and most everything is working again except he lost the camera app...I did a hard reset...the phone was rooted or still is not sure...The camera stopped working and my fiance fooled around with the phone and lost the camera app...anyway to fix this with out a hard reset?

Posting Permissions

B