1. Signewton's Avatar
    Hello forum,

    Sometime today I starting getting a notification saying I had a text from a hidden sender. I noticed this only shows up when i'm using Go sms or another third party text message app. The error doesn't show when using the stock messaging app. I've tried clearing data, cache and reinstalling go sms and still the problem happens. When I actually click on the notification it'll take me into Go sms but there is not text from the hidden sender. Not sure what's causing this.

    I'm running my Nexus stock and unrooted.

    Sent from my Xoom using Android Central Forums
    07-28-2012 12:55 PM
  2. 1088933's Avatar
    I've heard that this is an MMS issue that happens sometimes. Have you tried going through the settings, disabling auto retrieve MMS? Once you've done that, try and send yourself and MMS and see if it happens again.
    07-28-2012 01:18 PM
  3. Signewton's Avatar
    Just tried that and it still shows up. I'll mess around with some settings after work and see if I can get rid of it. Thanks for the help!

    Sent from my Xoom using Android Central Forums
    07-28-2012 01:27 PM
  4. 1088933's Avatar
    No problem. And it might just be a bug with the apps themselves. Let me know if you find a resolution!
    Signewton likes this.
    07-28-2012 01:33 PM
  5. Signewton's Avatar
    Somehow I found a fix. I got a text from the person who sent me a message right before the error started. That might have helped since it could put a number with the hidden sender. It could've been sheer luck with me messing with the auto download and clearing data. Whatever it was I'm glad it's working.

    Sent from my Galaxy Nexus using Android Central Forums
    07-28-2012 03:03 PM
  6. 1088933's Avatar
    Huh, that is weird. And he was in your contacts the whole time?
    07-28-2012 03:30 PM
  7. Signewton's Avatar
    As far as I can tell I had the contact the whole time. I know when I got the mms message I lost signal while the pic was downloading. Maybe that triggered the bug. I have no clue what made the notification pop up or really want the exact cause was.

    Sent from my Xoom using Android Central Forums
    07-28-2012 04:40 PM
  8. fender7217's Avatar
    Found this thread with a google search. I'm really struggling with this.

    I'm in the same position as OP. It seems the bug first started happening following receving a picture message. Now every time a new text comes in, I get a "hidden sender" notification too, that is nothing.

    It only happens in GoSMS, Handscent. The stock SMS app doesn't do this.

    I'm unbelievably frustrated with this right now. I've tried clearing cache, data, even uninstalling the entire app. Nothing has fixed it.

    Other google searches show this is a widespread issue that has happened on many different devices. It's not a carrier issue, but an Android bug issue. There are several claimed "fixed" to the problem that involved enabling/disabling auto-retrieval of MMS in various apps but nothing has fixed it yet.

    Any help would be greatly appreciated.
    08-09-2012 10:10 PM
  9. fender7217's Avatar
    Oh. My. God.

    It was as simple as using the "mark all as read" option to clear this mysteriously hidden message. Even though I deleted EVERYTHING, there was something somewhere still unread.

    That did it. I had yet to see that suggestion as a solution from all my google searching. Hopefully someone finds this and tries this option.
    08-09-2012 10:51 PM
  10. Signewton's Avatar
    The fix that worked for me was to go to the inbox folder in go sms. For whatever reason I had two messages in there. Deleted those and the problem went away.

    Sent from my Xoom using Android Central Forums
    08-10-2012 01:29 AM
  11. asuyaa12's Avatar
    i have a samsung galaxy s and im having THE EXACT same issue and it happened after i recieved a picture message and i went to go find the mark all as read button and cant seem to find it...someone please help me!
    09-18-2012 08:52 PM
  12. jenni4stewart's Avatar
    This is the only answer that I have found that worked for my phone. Thank you so much for sharing this fender7217!!!
    Aviram Freidenberg likes this.
    01-06-2013 12:06 AM
  13. Steve Harris3's Avatar
    How do u find the mobile number in a hidden sender on your galaxy
    04-03-2013 03:40 AM
  14. rod b's Avatar
    i have the same problem what did you do to fix it i cant find "mark all as read" on my samsung galaxy s so what was the outcome ?
    This is the only answer that I have found that worked for my phone. Thank you so much for sharing this fender7217!!!
    04-17-2013 04:02 AM
  15. Signewton's Avatar
    When I had this problem gosms was the culprit. Gosms has an inbox folder so I went in there and deleted everything. That seemed to fix the problem

    Sent from my Nexus 10 using Android Central Forums
    04-17-2013 02:10 PM
  16. Mattis Asp's Avatar
    Same issue with Samsung S3 internal message system.

    This is my stupid fix, it should work at least for other Samsung S3 devices, and probably all.
    1. Backup all your sms with "SMS Backup & Restore".
    2. Delete all sms including mms on your mobile.
    3. Restore all sms with "SMS Backup & Restore".

    Takes about 5 -10 minutes to fix. But feels great afterwards!
    08-14-2014 07:20 AM
  17. Irelandvixen's Avatar
    Im having this problem now i keep gettimg hidden sender address and when i click on it it takes me to the new message screen. I try to delete it and it wont let me delete it. Also i tried to delete all my txt in mass form it just stayed at zero percent then my txt app gosms wouldnt work. I can delete my text one at a time but still cant delete the hidden sender message it has blank where name should be and looks like there is a pic in there but nothings there. Someone said to go to the inbox and delete everything i cant find an inbox. I tried the mark all as read that didnt work neither did the back up and restore. Help its driving me nuts
    04-18-2015 06:31 PM
  18. Trevar Williams's Avatar
    Im having this problem now i keep gettimg hidden sender address and when i click on it it takes me to the new message screen. I try to delete it and it wont let me delete it. Also i tried to delete all my txt in mass form it just stayed at zero percent then my txt app gosms wouldnt work. I can delete my text one at a time but still cant delete the hidden sender message it has blank where name should be and looks like there is a pic in there but nothings there. Someone said to go to the inbox and delete everything i cant find an inbox. I tried the mark all as read that didnt work neither did the back up and restore. Help its driving me nuts
    Try marking all your messages read. This worked for me, and I haven't had that issue yet. If you go to the default click the 3 dots on the top right and click mark all read. If you dont see that option send yourself a text message and close the messaging app before you read it. Or ask someone to send you a text so the it appears as a new message. After you have a new message go and mark all read and the notifications should go away. At least that's what I did and it worked.
    08-24-2015 12:50 AM
  19. Ramana Miriyala's Avatar
    Hello... just enable hangouts in your messages settings, open the messages (SMS) through hangouts where you can see the unread messages. Open them, delete them and come out. You may disable the hangouts selection after you finish this activity if you don't want to continue with hangouts.
    05-03-2016 07:00 AM
LINK TO POST COPIED TO CLIPBOARD