Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  
    dbareis's Avatar

    Posts
    285 Posts
    Global Posts
    286 Global Posts

    Default GNEX Chooses Poorer WiFi Connection to Conect to :-(

    I have two wifi routers, one at the FRONT and another at the BACK of the house.

    The BACK router is the one I connect to most of the time as its close to where I am most of the time. Actually that may not be 100% true as when I go to sleep it should be trying to connect to the front (I do have a tasker task to toggle wifi to ensure that should happen). I have "keep wifi on during sleep" set to "Always". I want to start the day with the phone synced.

    When I'm close to the the FRONT router and its signal strength is excellent and the BACK's is poor, if I toggle WI-FI off then on (simple way to reproduce the issue) then it will still generally (but not always) connect to the BACK! Often I have to click on the FRONT ssid to connect which it will then happily do.

    I have tried "Avoid poor connections" both ticked and unticked.

    I'm on Android 4.1.1 (JB). How does it decide which to connect to and does it consider the possibly different security settings on the routers (both running Tomato firmware)?

    Any Ideas?
  2. #2  
    project.in.process's Avatar

    Posts
    1,223 Posts
    ROM
    Bamf Paradigm

    Default Re: GNEX Chooses Poorer WiFi Connection to Conect to :-(

    create a QR code with your wifi info for each router.
    place at different areas of the house (Front/back)

    scan the qr code when you're in either area.

    or, setup a tasker profile so that, given cell location (assuming adequate distance between both points), tasker will auto-connect only to one wifi signal/router.
  3. Thread Author  Thread Author    #3  
    dbareis's Avatar

    Posts
    285 Posts
    Global Posts
    286 Global Posts

    Default Re: GNEX Chooses Poorer WiFi Connection to Connect to :-(

    I might try that if I have to thanks, I'm trying something else for now as I've done some more testing.

    I think the issue is a JB (at least) bug, I managed to reproduce the issue the opposite way where it always wanted to go to the FRONT, it seems like if its had a "recent" (whatever that turns out to mean) connection to a router it will try to reconnect to that router even if its a poor connection.

    I can see why it might want to do that however, I think its a bug if that caching survives turning WIFI off then on.

    Anyway my Tasker solution which when manually invoked works MOST of the time is for it to:

    * Turn off WI-FI
    * Wait 1 minute
    * Turn on WI-FI

    When its doing this I know it should be going to the FRONT router so it will try doing this every 90 minutes when not connected to it.
    Last edited by dbareis; 08-16-2012 at 09:08 PM.
  4. #4  
    Wicket's Avatar

    Posts
    195 Posts
    Global Posts
    217 Global Posts

    Default Re: GNEX Chooses Poorer WiFi Connection to Conect to :-(

    my phone does this to me at work, I'll walk to a different part of the building where it'll switch to that wifi but when I go back to my desk instead of connecting to the router right behind me it'll still try to hold onto the one at the front of the office.. annoying cause I always have to click the SSID of the closer one to get it to connect to it again.. I am trying to remember if it did this to me pre JB.. keep us updated if you find anything.
  5. #5  

    Default Re: GNEX Chooses Poorer WiFi Connection to Conect to :-(

    You could try putting a couple of NFC tags in strategic places and programming them to connect to a particular WiFi connection.
  6. #6  

    Default Re: GNEX Chooses Poorer WiFi Connection to Conect to :-(

    Try with the same SSID on both routers. I have this configuration in my office and it works. The security configuration must be equal too.
  7. #7  

    Default Re: GNEX Chooses Poorer WiFi Connection to Connect to :-(

    Quote Originally Posted by dbareis View Post
    I managed to reproduce the issue the opposite way where it always wanted to go to the FRONT, it seems like if its had a "recent" (whatever that turns out to mean) connection to a router it will try to reconnect to that router even if its a poor connection.

    .
    This is probably the correct protocol for WiFi -- the signal from your last connection is still in range and sufficiently strong to allow the phone to re-associate with it. Re-association takes less steps and is faster than a creating a new connection to a different AP.
  8. Thread Author  Thread Author    #8  
    dbareis's Avatar

    Posts
    285 Posts
    Global Posts
    286 Global Posts

    Default Re: GNEX Chooses Poorer WiFi Connection to Connect to :-(

    Quote Originally Posted by SteveMW View Post
    This is probably the correct protocol for WiFi -- the signal from your last connection is still in range and sufficiently strong to allow the phone to re-associate with it. Re-association takes less steps and is faster than a creating a new connection to a different AP.
    I'm guessing that also but no way its not a bug that it still does that after wifi has been toggled off then on.
  9. #9  

    Default Re: GNEX Chooses Poorer WiFi Connection to Conect to :-(

    As Steve said, that is how wifi works. It will keep a hold of the signal as long as possible. I have two AP's in my house with the same SSID. What I did to make the stronger AP the preferred one was make its channel number lower than the other. Say 2 and 11. The radios seem to prefer to connect to lower channels first.

Posting Permissions

B