Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. Thread Author  Thread Author    #1  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Camera not working since 4.1.2 Update

    The camera is not working in any camera app, native or not.

    Native app flashes "Unfortunately Gallery has stopped" (so reporting dies also). Another app says "Camera could not be opened!"

    Rebooted multiple times. Any ideas?
  2. Thread Author  Thread Author    #2  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    Found this in the logs:

    Code:
    10-22 17:27:57.598 E/CameraHAL(  132): Couldn't get camera properties
    10-22 17:27:57.598 W/dalvikvm( 5422): threadid=10: thread exiting with uncaught exception (group=0x40e2e300)
    10-22 17:27:57.598 E/AndroidRuntime( 5422): FATAL EXCEPTION: Thread-658
    10-22 17:27:57.598 E/AndroidRuntime( 5422): java.lang.RuntimeException: Fail to get camera info
    10-22 17:27:57.598 E/AndroidRuntime( 5422): 	at android.hardware.Camera.getCameraInfo(Native Method)
    10-22 17:27:57.598 E/AndroidRuntime( 5422): 	at com.android.camera.CameraHolder.<init>(CameraHolder.java:117)
    10-22 17:27:57.598 E/AndroidRuntime( 5422): 	at com.android.camera.CameraHolder.instance(CameraHolder.java:71)
    10-22 17:27:57.598 E/AndroidRuntime( 5422): 	at com.android.camera.Util.openCamera(Util.java:252)
    10-22 17:27:57.598 E/AndroidRuntime( 5422): 	at com.android.camera.Camera$CameraStartUpThread.run(Camera.java:280)
    10-22 17:27:57.606 W/ActivityManager(  311):   Force finishing activity com.google.android.gallery3d/com.android.camera.CameraLauncher
  3. #3  

    Default Re: Camera not working since 4.1.2 Update

    Short of a factory reset, try clearing your cache in the gallery app and any camera apps that you have.
    Pat

    Galaxy Nexus 10 - stock KitKat 4.4.4
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.4
    Chromecast
    Nexus 5 - stock KitKat 4.4.4
  4. Thread Author  Thread Author    #4  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    Thanks for the reply but clearing didn't help, I'll wait for the 2.6 update and if that doesn't fix it wait until I get my next phone, I can't be bothered setting up everything again. Wish Google would fix it so app settings are backed up (better).
  5. #5  

    Default Re: Camera not working since 4.1.2 Update

    Wish Google would fix it so app settings are backed up (better).
    Google makes that available but it is up to the app developer to use it. By default most of your stuff should have been automatically backed up. You can check by going to settings, personal, backup and reset and make sure all is checked.
    Pat

    Galaxy Nexus 10 - stock KitKat 4.4.4
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.4
    Chromecast
    Nexus 5 - stock KitKat 4.4.4
  6. Thread Author  Thread Author    #6  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    Quote Originally Posted by patruns View Post
    Google makes that available but it is up to the app developer to use it. By default most of your stuff should have been automatically backed up. You can check by going to settings, personal, backup and reset and make sure all is checked.
    Google Shouldn't leave it up to the developer, Google should make it possible to make secure backups of your mobile device, my suggestion of the day is that the device to be backed up needs to be configured by the user to have a backup key and backups are encrypted with this key, this would overcome any worries about personal data being accessed via backups which is the main reason I suspect its not possible now. Ideally it would allow you to make local copies as well as store them (versioned) in the cloud, either way allowing the complete state of the phone to be restored to a point in time (or selectively restoreing to that point). I';d then be doing my factory reset and if it didn't fix it I'd do a complete restore and if it did I'd try selectively restoring bits.

    Anyway out of the approx 250 apps I have installed I have 6 backing up to the cloud, to see how many do this: On Web, Google Account->Profile and Privacy->Sign in to Dashboard->Android devices->[YourDevice]->More data stored about this device
  7. #7  

    Default Re: Camera not working since 4.1.2 Update

    Had the same issue until I deleted "Smart Stay" app, rebooted. So far no issues with camera.
  8. Thread Author  Thread Author    #8  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    Interesting, unfortunately I don't have that app or anything similar. I may uninstall all other camera apps and see what happens.
  9. Thread Author  Thread Author    #9  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    Oh well worth a try but it didn't work
  10. #10  

    Default Re: Camera not working since 4.1.2 Update

    I'm having issues on my Gnex too. Based on a quick Google search, seems like a pretty common problem w/ Gnex's since the JB update. When I open my camera, I get a black screen w/ the software keys at the bottom but I can't see anything. Typically the widget won't even open the app. I usually have to go through the gallery, which still works oddly enough. Once I'm in the app, I can push the picture button & it does absolutely nothing. If I switch to video recording or panorama, it locks up and FC's. Mine isn't rooted or anything... I was considering rooting it & throwing on another ROM... but others have done this & it doesn't seem to help. I posted something on Google's message board... but I don't expect much to be done.
  11. Thread Author  Thread Author    #11  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    A factory reset didn't fix it so I had it repaired, the main board was replaced.
  12. #12  

    Default Re: Camera not working since 4.1.2 Update

    Hey,

    How much did it cost to repair? I'm having the same problem and it's really frustrating.
    Is it better to just purchase a new phone?
  13. Thread Author  Thread Author    #13  
    dbareis's Avatar

    Posts
    295 Posts
    Global Posts
    296 Global Posts

    Default Re: Camera not working since 4.1.2 Update

    My phone was repaired under warrantee, my guess is it will be cheaper (or at least better) to upgrade to the Nexus 4 :-)

Similar Threads

  1. Amaze Camera not working since ICS update
    By VickMackey#AC in forum HTC EVO 3D
    Replies: 4
    Last Post: 08-12-2012, 11:51 PM
  2. Evo 4g Camera not working after OTA update
    By jack31484 in forum HTC EVO 4G
    Replies: 3
    Last Post: 06-20-2011, 12:25 PM
  3. Camera not working after leaked HTC Froyo update
    By limitproof in forum HTC EVO 4G
    Replies: 15
    Last Post: 12-05-2010, 04:34 PM
  4. App update notifications not working since 2.2
    By slinky317 in forum Verizon Droid Incredible
    Replies: 2
    Last Post: 10-07-2010, 01:11 PM
  5. *#*#4636#*#* Not working since update
    By jakewoodblues in forum HTC EVO 4G
    Replies: 4
    Last Post: 08-04-2010, 12:34 AM

Posting Permissions