1. circleinsideabox's Avatar
    Is it just me? and my phone is charging SUPER SLOWLY. Also, the same thing is happening with my Nexus 7.....
    I hope I am not alone in this matter......
    11-15-2012 11:22 AM
  2. Carlos Thomas's Avatar
    Is it just me? and my phone is charging SUPER SLOWLY. Also, the same thing is happening with my Nexus 7.....
    I hope I am not alone in this matter......
    It seems normal to me.
    11-15-2012 12:10 PM
  3. droidatl's Avatar
    I am having serious battery drain issues. Mine is coming from "Exchange Services". Called Google Play tech support this morning and they know about the issue but don't have a solution as of yet.

    Sent from my Nexus 7 using Android Central Forums
    slosh74 likes this.
    11-15-2012 03:23 PM
  4. circleinsideabox's Avatar
    I am having serious battery drain issues. Mine is coming from "Exchange Services". Called Google Play tech support this morning and they know about the issue but don't have a solution as of yet.

    Sent from my Nexus 7 using Android Central Forums
    thank you for responding and
    thanks for the update from Google ( I wanted to call but I didn't have the time today)
    janesa13 likes this.
    11-15-2012 05:02 PM
  5. circleinsideabox's Avatar
    I can confirm that I was able to resolve my issue by performing a factory reset of my phone. Microsoft Exchange no longer
    drains my battery. Everything is normal now!
    11-15-2012 09:07 PM
  6. mglacey's Avatar
    Same issue on my end. Google support also said to reset the device, but interestingly also said that would roll back the device to 4.1.2 and not 4.2 At that point I lost all confidence. Nice to see you have it working. I'll test it this weekend.
    11-15-2012 09:15 PM
  7. KlineAJ's Avatar
    That will not roll you back to 4.1.2... not sure why they would say that.
    Seems like the solution of choice is to do a factory reset.
    If anything else comes up perhaps check in here to see.
    http://forums.androidcentral.com/goo...eshooting.html
    11-16-2012 12:22 AM
  8. gevo12321's Avatar
    I got the Galaxy Nexus HSPA+ version. just got the OTA update to 4.2 about 6 hours ago. Since then, by battery has drained two times already. Haven't really done anything with the phone. Anyone else have this problem?
    11-16-2012 12:52 AM
  9. KlineAJ's Avatar
    Some others have reported that. The solution so far it seems has been to just factory reset the device.
    11-16-2012 12:56 AM
  10. Anand Raman's Avatar
    Alternatively I deleted the account and then recreated the account. This has resolved the problem as well.

    I suspect that the issue is caused because of the "security administrator" configuration. Before I deleted my exchange account and recreated it I could actually add widgets to the lock screen. However after the account was recreated the additional lock screen panels were quickly disabled. I suspect this had something to do with the additional battery drain. This issue may only surface if your exchange administrator has pushed additional security admin configurations

    thanks
    anand
    11-16-2012 07:03 AM
  11. emmib's Avatar
    I got the Galaxy Nexus HSPA+ version. just got the OTA update to 4.2 about 6 hours ago. Since then, by battery has drained two times already. Haven't really done anything with the phone. Anyone else have this problem?
    I had to factory restore (that's how I got 4.2) and right after the update my battery life was sh*t. Now, 3 days later, it's improving with every charge cycle.
    11-16-2012 07:33 AM
  12. Brenden West's Avatar
    Same here. I did the factory reset and this seems to have resolved the battery drain.
    11-16-2012 08:38 PM
  13. AltoonaHusker's Avatar
    I had the same issue, but not immediately after the JB update (haven't received 4.2 update yet through US Cellular). Exchange was working overtime and seemed to be continually draining my battery over the past 2-3 days. I researched and couldn't find a solution. I tried to remove and restore the Exchange account and that worked for a while. I'm rooted and tried to freeze some programs via TB and see if that helped but to no avail. Finally I picked up on a post that mentioned attachments potentially being a problem. Immediately I remembered I had an email with a 14mb attachment that I hadn't deleted. There was also another email with 7 attachments of 1+ mb each. I removed both of those emails from my inbox and filed them and that seems to have solved the problem. Since I did that the battery life is back to normal. I hope this helps.
    01-04-2013 09:53 AM
  14. Complex Pants's Avatar
    I have been getting a lot of battery drain as well, I am at about 8-10hrs of basically standby time per full charge. This all started around December from what I remember. I have noticed that a lot of battery drain came from Google Plus, Google Maps and occasionally Facebook. I have the GSM unlocked nexus and I am very frustrated by it at the moment, because it feels like I can't really use the phone without it being completely drained in a few hours. I have done some testing and it seems related to my phones radios. In airplane mode I get 20+ hrs of battery life, which still seems a bit low, but even with wifi I get this significant battery drain. I am using AT&T for my provider.

    If I do a factory reset I lose all of my data stored in my apps correct? Also you think this will help?
    01-05-2013 01:15 PM
  15. tube517's Avatar
    I turned off GPS/location and get better battery life. From 7-8 hours to about 15-16. I love Google Now but it's a serious battery drainer.
    01-06-2013 10:45 AM
  16. ggnexus's Avatar
    I had the same problem - after upgrading, the phone stayed really warm, batter drained every 3 hours without doing much at all.

    Thanks for the info everyone provided here. Did not want to reset the device. So I tried by un-installing Outlook Email and re-installed it back. The problem is resolved. Now the phone temporary is back to normal, battery time is back to prior upgrade as well.
    pontiac005 likes this.
    02-07-2013 01:10 PM

Similar Threads

  1. Major Battery Drain After Latest Google Maps Update?
    By jephanie in forum Verizon Galaxy Nexus
    Replies: 8
    Last Post: 08-26-2012, 10:28 AM
  2. Battery drain after update
    By jc924 in forum ASUS EeePad Transformer
    Replies: 2
    Last Post: 11-22-2011, 09:04 AM
  3. Excessive battery drain after latest update
    By silinthar in forum Verizon HTC Thunderbolt
    Replies: 15
    Last Post: 11-04-2011, 08:00 PM
  4. Running Apps & Battery Drain After Froyo Update
    By jess.hickey in forum AT&T Captivate
    Replies: 1
    Last Post: 02-25-2011, 09:54 AM
  5. BATTERY DRAIN after UPDATE - READINGS, ANY IDEAS
    By nmoreman in forum Sprint Epic 4G
    Replies: 9
    Last Post: 09-28-2010, 05:36 PM
LINK TO POST COPIED TO CLIPBOARD