Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  
    Jezz_X's Avatar

    Posts
    33 Posts
    ROM
    cm10 mostly

    Default help me turn off 4.2 volume wake

    Since I upgraded to 4.2 on my nexus (stock but rooted) I have noticed something quite annoying that while playing music if you adjust the volume the screen wakes. I know lots of people call this a feature but for me its mega annoying because I like to just adjust the volume in my pocket without actually pulling the phone out (or some times pushing the buttons through my actual pants). The problem is now if I try to do it I end up bringing up the emergency dialer all the time because my leg contacts the screen :\ (I have a lock pattern)

    I have looked through settings but can't seem to find any settings options to change this as it only happens while music is playing (in any app not just Google Play music) so anyone got any ideas if its even possible ?
  2. #2  

    Default Re: help me turn off 4.2 volume wake

    Question retracted.
    Last edited by knightfall; 11-21-2012 at 04:04 PM.
    @PegCityNerd
  3. Thread Author  Thread Author    #3  
    Jezz_X's Avatar

    Posts
    33 Posts
    ROM
    cm10 mostly

    Default Re: help me turn off 4.2 volume wake

    I did say twice that it only happens when playing music
  4. #4  
    arathkone's Avatar

    Posts
    53 Posts
    ROM
    Stock 4.2

    Default Re: help me turn off 4.2 volume wake

    I'm using a pattern lock; I just tried to do this and adjusting the volume, with headphones in, with the screen off didn't wake the phone. I have noticed I can adjust volume without unlocking the phone though but it's inconsistent and it doesn't wake the phone, it only happens if the phone is already awake.
  5. Thread Author  Thread Author    #5  
    Jezz_X's Avatar

    Posts
    33 Posts
    ROM
    cm10 mostly

    Default Re: help me turn off 4.2 volume wake

    hrmm that's weird happens for me 100% of the time no matter what using stock kernel radio and rom all it is is rooted

    BTW I should also mention that I did a complete wipe of my phone before installing the rom so its not left overs
  6. #6  
    arathkone's Avatar

    Posts
    53 Posts
    ROM
    Stock 4.2

    Default Re: help me turn off 4.2 volume wake

    My test was with the stock music player, are you using a 3rd party app?
  7. Thread Author  Thread Author    #7  
    Jezz_X's Avatar

    Posts
    33 Posts
    ROM
    cm10 mostly

    Default Re: help me turn off 4.2 volume wake

    I was using the stock player but it turns out that it was a fault of an app I was using called I also had an issue that when the widget refreshed it used to turn on the screen so I put 2 and 2 together and uninstalled the app and now its just fine the screen does not wake on volume

    Thanks for the help anyway
  8. #8  
    arathkone's Avatar

    Posts
    53 Posts
    ROM
    Stock 4.2

    Default Re: help me turn off 4.2 volume wake

    Glad it has been resolved! Nice work.
  9. #9  

    Default Re: help me turn off 4.2 volume wake

    Mine's the exact same issue and is not resolved. It's on Google Play Music. Raising or lowering the volume while Play Music is playing a track with the screen off now turns the screen on... Very irritating. :-(

    Someone please let me know if you know of a fix.

    Edit: no headphones, just when plugged into the AUX port, or when playing through speakerphone, again no headphones.
    Sent from my Galaxy Nexus using Android Central Forums
  10. #10  

    Default Re: help me turn off 4.2 volume wake

    I don't like how the screen turns on when I change the volume for music in my pocket, so here's a workaround "ganja_guru" found:

    - Use Root explorer (or similar) and browse to /system/usr/keylayout/
    - Mount system as R/W
    - Long press ffa-keypad.kl and open with text editor. (i didnt had that file, i just opened any file that looked curious, like
    qwery.kl, pm8058-keypad.kl)
    - Remove the words "WAKE_DROPPED" next to key (it said "Wake" on my files)

    115 VOLUME_UP
    114 VOLUME_DOWN

    Only remove the "WAKE_DROPPED" ("wake" on mine) words and save the file. Restart your phone and wake on volume button press should be disabled.
    thx go ganja and me for posting here


    Keywords:
    volume key keys locker lock unlock disable

Similar Threads

  1. Need Help! I turned off my mobile data somehow
    By Malchore in forum Droid RAZR HD
    Replies: 8
    Last Post: 01-25-2014, 12:47 PM
  2. help please ( turning off display notification)
    By codeda in forum Sprint Galaxy S3
    Replies: 8
    Last Post: 07-11-2012, 09:46 PM
  3. Please help me get off my couch and sleeping in my bed again...
    By IP IHI II IL in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 33
    Last Post: 08-04-2011, 07:28 PM
  4. My Evo won't let me turn off sense anymore?!?!
    By yophone986 in forum HTC EVO 4G
    Replies: 8
    Last Post: 01-24-2011, 04:30 PM
  5. Airplane mode turns OFF Wifi. Please check for me.
    By benvfr in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 04-30-2010, 09:55 AM

Posting Permissions

B