Keep 4.1.2 or upgrade to 4.2.1

Printable View

B