12-23-2012 01:59 PM
79 123 ...
tools
  1. jondevere's Avatar
    [INFO]REQUIRES TEMP ROOT / ROOT ACCESS ! ! !

    This version of wifi tether is experimental but DOES work.


    1. Download the APK file at the bottom of this post

    2. Install the APK

    3. Launch the wifi tether app

    4. Go to settings and click " MSSG Clamping and Routing Fix ".

    5. Click to start tethering and your golden.

    [/INFO]

    [NOTE]I have tried a bunch of other apps and this one DOES work. I downloaded this version back when I had my OG EVO and it worked as well....

    The addition of the MSS Clamping resolves the 3g tether issue with only showing google. There are other versions of the WiFi tether. I tested a few and all work for 3g as long as MSS Clamping is enabled. Much better than using Barnacle as a fix. Enjoy!

    P.S. I did NOT create this app just passing on the knowledge

    ENJOY!

    [/NOTE]


    07-26-2011 05:48 PM
  2. drewwalton19216801's Avatar
    Dang, nice one Jon! I don't have an EVO 3D (obviously) but good find!
    07-26-2011 05:51 PM
  3. grantheppes's Avatar
    This works for 4G on The Nexus S 4G with Cyanogen Mod. Device "Google NexusOne" (yes, nexus one). 3.5 downspeed.
    07-26-2011 06:28 PM
  4. jondevere's Avatar
    This works for 4G on The Nexus S 4G with Cyanogen Mod. Device "Google NexusOne" (yes, nexus one). 3.5 downspeed.
    Good stuff! Glad to see it worked for you as well!
    07-26-2011 09:48 PM
  5. daikon's Avatar
    will try when I get back to th USA, thanks!
    07-26-2011 10:33 PM
  6. bobodobo's Avatar
    Good stuff! Glad to see it worked for you as well!
    Doesn't work for me. I've tried this version of WiFi Tether and a hundred others, plus Barnacle Tether, none of them work. Many of them will connect the laptop to the EVO but none will allow data to flow. I've checked and unchecked and rechecked the "routing fix" and every other setting. No joy.

    And YES I'm certain that I'm rooted.

    And YES I had WiFi Tether working fine on my EVO 4G.

    EDIT: well after testing and testing and testing and nothing working, I wrote this post and submitted it. However, I didn't notice that I hadn't switched back to my home WiFi, I was still "connected" to the Android tether. Guess what? It posted! Actually I've had this happen before, once in a while I would get WiFi tethering to work for a short time and then fail, never to work again without uninstalling, resetting, restarting and re-installing everything. We'll see if that's the case here or not.

    EDIT #2: seems to work only on 4G data, not 3G.

    EDIT #3: It doesn't matter if I check the "Routing fix" or not, nor does it matter if I choose under "Change Device-Profile" either "Auto" or "HTC EVO 4G" - all 4 combinations yield exactly the same results: it works perfectly on 4G and not at all on 3G. (And yes 3G data works fine in all other applications.)
    07-27-2011 01:42 AM
  7. jondevere's Avatar
    strange... glad its working now tho. Mine is working on both 3g and 4g. At least u have the 4g working cuz its faster! LOL

    Mine works like a champ and I have set this up on a few phones now.
    dangerwit and argaknot like this.
    07-27-2011 01:57 AM
  8. faithofgod's Avatar
    Thanks! Works perfectly!
    07-27-2011 07:13 AM
  9. jondevere's Avatar
    Your welcome
    07-27-2011 08:16 PM
  10. ashton4life's Avatar
    Doesn't work for me. I've tried this version of WiFi Tether and a hundred others, plus Barnacle Tether, none of them work. Many of them will connect the laptop to the EVO but none will allow data to flow. I've checked and unchecked and rechecked the "routing fix" and every other setting. No joy.

    And YES I'm certain that I'm rooted.

    And YES I had WiFi Tether working fine on my EVO 4G.

    EDIT: well after testing and testing and testing and nothing working, I wrote this post and submitted it. However, I didn't notice that I hadn't switched back to my home WiFi, I was still "connected" to the Android tether. Guess what? It posted! Actually I've had this happen before, once in a while I would get WiFi tethering to work for a short time and then fail, never to work again without uninstalling, resetting, restarting and re-installing everything. We'll see if that's the case here or not.

    EDIT #2: seems to work only on 4G data, not 3G.

    EDIT #3: It doesn't matter if I check the "Routing fix" or not, nor does it matter if I choose under "Change Device-Profile" either "Auto" or "HTC EVO 4G" - all 4 combinations yield exactly the same results: it works perfectly on 4G and not at all on 3G. (And yes 3G data works fine in all other applications.)
    He's right. For me I use barnical for 3G and WiFi tether for 4G. So far its ok.
    07-28-2011 10:08 PM
  11. htabbach's Avatar
    [INFO]REQUIRES TEMP ROOT / ROOT ACCESS ! ! !

    This version of wifi tether is experimental but DOES work.


    1. Download the APK file at the bottom of this post

    2. Install the APK

    3. Launch the wifi tether app

    4. Go to settings and click " Routing Fix ".

    5. Click to start tethering and your golden.

    [/INFO]

    [NOTE]I have tried a bunch of other apps and this one DOES work. I downloaded this version back when I had my OG EVO and it worked as well....

    P.S. I did NOT create this app just passing on the knowledge

    ENJOY!

    [/NOTE]


    Only opens Google site on 3G, does not work for anything else. I do not have 4G to test it with.
    07-29-2011 02:21 PM
  12. bobodobo's Avatar
    He's right. For me I use barnical for 3G and WiFi tether for 4G. So far its ok.
    Barnacle has never worked for me at all, and I've tried all kinds of settings. BTW today I applied the permanent root and got the same results.

    Only opens Google site on 3G, does not work for anything else. I do not have 4G to test it with.
    Whoa, same here! Now WHY would it work for any site on 4G, but only Google on 3G???
    07-30-2011 01:05 AM
  13. clove007's Avatar
    Hi John,
    I've done the perma-temp root for Evo 3d. Many rooted apps are working, however; I can't seem to geth the wifi tether app to work. When I install and first open the app you have linked, it says "not root" "kernal does not support netfiltering."

    Have you done something in addition to rooting your phone and installing the wifi tether app?
    I'd like some help because my rooted evo 4g worked like a champ, evo 3d is needing some help.

    Thanks!
    07-30-2011 02:13 PM
  14. jondevere's Avatar
    I didnt do anything but install the app and click the HTC fix within the settings of wifi tether. I also know some have been having issues with the routing on 3G. I have seen some people say that they choose TBolt profile to get their stuff working on 3G, as well as many saying to choose HTC Hero CDMA profile. Mine worked right away on Auto profile. Once again with this YMMV
    07-30-2011 04:12 PM
  15. NxTech3's Avatar
    mine works both 3g and 4g, appreciate the find!!!
    08-01-2011 08:02 AM
  16. CarrieK's Avatar
    For the record it works great for me...thanks for the tip! Very fast.
    08-01-2011 02:58 PM
  17. cliffhanger's Avatar
    For the record it works great for me...thanks for the tip! Very fast.
    There is some sort of problem with the routing in WiFi Tether. If you start Barnacle first and then close it, and then open WiFi Tether and have the HTC routing option turned on, it will work on all web pages. Barnacle somehow sets up the routing properly. If you reboot the phone and just run WiFi Tether, it will only bring up Google web sites.

    I hope this helps somebody.
    bobodobo, CarrieK and bosjoe like this.
    08-02-2011 09:55 PM
  18. bobodobo's Avatar
    There is some sort of problem with the routing in WiFi Tether. If you start Barnacle first and then close it, and then open WiFi Tether and have the HTC routing option turned on, it will work on all web pages. Barnacle somehow sets up the routing properly. If you reboot the phone and just run WiFi Tether, it will only bring up Google web sites.
    Holy ----, you're right! I get exactly the same results!

    Posted via Wireless Tether on 3G using "Cliffhanger Routing"...

    EDIT: It works fine on 3G. It works fine on 4G. It works fine going from 3G to 4G. It fails going from 4G back to 3G.
    08-02-2011 11:16 PM
  19. CarrieK's Avatar
    There is some sort of problem with the routing in WiFi Tether. If you start Barnacle first and then close it, and then open WiFi Tether and have the HTC routing option turned on, it will work on all web pages. Barnacle somehow sets up the routing properly. If you reboot the phone and just run WiFi Tether, it will only bring up Google web sites.

    I hope this helps somebody.
    Thank you. I tried it with with the link jon provided and it worked great on my netbook. I navigated to several sites. I don't have Barnacle. I admit I only tried it that initial time the day before yesterday so I will try again today and see what happens. If I run into a problem I will know what to do!
    08-03-2011 05:50 AM
  20. CarrieK's Avatar
    OK just to update. I am logged onto this site and posting from my netbook using Wifi Tether. Confirming that at least for now that jon's instructions work for me.
    08-03-2011 07:22 AM
  21. Gents's Avatar
    It worked for me too. Used barnacle first then went back and both 3g and 4G worked fine.
    08-03-2011 01:29 PM
  22. Cashrules's Avatar
    [INFO]REQUIRES TEMP ROOT / ROOT ACCESS ! ! !

    This version of wifi tether is experimental but DOES work.


    1. Download the APK file at the bottom of this post

    2. Install the APK

    3. Launch the wifi tether app

    4. Go to settings and click " Routing Fix ".

    5. Click to start tethering and your golden.

    [/INFO]

    [NOTE]I have tried a bunch of other apps and this one DOES work. I downloaded this version back when I had my OG EVO and it worked as well....

    P.S. I did NOT create this app just passing on the knowledge

    ENJOY!

    [/NOTE]


    perfect
    dsims6465 likes this.
    08-03-2011 06:38 PM
  23. bosjoe's Avatar
    There is some sort of problem with the routing in WiFi Tether. If you start Barnacle first and then close it, and then open WiFi Tether and have the HTC routing option turned on, it will work on all web pages. Barnacle somehow sets up the routing properly. If you reboot the phone and just run WiFi Tether, it will only bring up Google web sites.

    I hope this helps somebody.
    Thank you..

    It worked for me now I can play with my Galaxy Tab 10 on the road.
    08-03-2011 06:56 PM
  24. eovnu87435ds's Avatar
    worked for me! this was done with 1 bar of 4G.

    08-08-2011 02:55 PM
  25. HTCaesar's Avatar
    Worked for me had to go with barnacle wifi tether wouldn't work
    08-08-2011 05:15 PM
79 123 ...
LINK TO POST COPIED TO CLIPBOARD