1. kcodya's Avatar
    For rooted users, try these tweaks on for size. These really seemed to speed things up!
    Use Root Explorer or a similar app to browse and do a Nandroid first just in case.

    1. Browse to /system/ect and edit the adreno_config.txt
    2. Under the Binning section, change "binning=sw" to "binning=hw'
    3. Under th 2D Settings section, change "2D.HwBlt=0" to "2D.HwBlt=1"
    4. Save changes.
    5. Now browse to /system and edit build.prop
    6. Add "debug.sf.hw=1" (no quotes) to the end of the file.
    7. Save changes.
    8. Reboot

    You should get a bit of a speedup in some apps, and scrolling should be much smoother.

    Source: xda-developers
    scrosler, bdGDL08 and vergo40 like this.
    08-03-2011 03:11 PM
  2. scrosler's Avatar
    For rooted users, try these tweaks on for size. These really seemed to speed things up!
    Use Root Explorer or a similar app to browse and do a Nandroid first just in case.

    1. Browse to /system/ect and edit the adreno_config.txt
    2. Under the Binning section, change "binning=sw" to "binning=hw'
    3. Under th 2D Settings section, change "2D.HwBlt=0" to "2D.HwBlt=1"
    4. Save changes.
    5. Now browse to /system and edit build.prop
    6. Add "debug.sf.hw=1" (no quotes) to the end of the file.
    7. Save changes.
    8. Reboot

    You should get a bit of a speedup in some apps, and scrolling should be much smoother.

    Source: xda-developers
    Nice Dude!
    08-03-2011 04:44 PM
  3. murphdsurf's Avatar
    Sorry if this sounds like a stupid question,
    But can you edit these settings from the phone itself or does it need to be connected to a pc.

    First time fooling around with these settings.

    Thx in advance,
    Tom
    08-04-2011 08:07 AM
  4. murphdsurf's Avatar
    Figured it out, (Gota switch to decaf!)
    08-04-2011 09:03 AM
  5. bdGDL08's Avatar
    OP, can you give any short explanation of what exactly these tweaks are doing? I'm just curious, not doubting you. I swear.

    ~Drew
    08-06-2011 09:15 PM
  6. scrosler's Avatar
    OP, can you give any short explanation of what exactly these tweaks are doing? I'm just curious, not doubting you. I swear.

    ~Drew
    They are putting the GPU (grpahics processor unit) to hardware mode instead of software mode. This makes anything screen related faster... And what is not screen related? lol I made two of the three tweaks on Senseless ROM 1.1 and benchmark wise it is about a 25% performance gain. Now that is in a simple synthetic benchmark. Real world results can be diff.

    -Scott
    08-06-2011 10:41 PM
  7. anarchist9027's Avatar
    Sorry if this sounds like a stupid question,
    But can you edit these settings from the phone itself or does it need to be connected to a pc.

    First time fooling around with these settings.

    Thx in advance,
    Tom
    You can use ES File Explorer
    08-07-2011 01:55 PM
  8. bdGDL08's Avatar
    They are putting the GPU (grpahics processor unit) to hardware mode instead of software mode. This makes anything screen related faster... And what is not screen related? lol I made two of the three tweaks on Senseless ROM 1.1 and benchmark wise it is about a 25% performance gain. Now that is in a simple synthetic benchmark. Real world results can be diff.

    -Scott
    Thank you very much.

    ~Drew
    08-07-2011 02:56 PM
  9. uh60james's Avatar
    Those of you using this tweak have you noticed a decrease in battery life?
    08-09-2011 01:16 PM
  10. scrosler's Avatar
    Those of you using this tweak have you noticed a decrease in battery life?
    You should not see a decease due to the fact it enables hardware functions verse emulating them in software. But that just my educated guess. I never have a rom on device long enough to ever test battery, lol.
    08-09-2011 01:55 PM
  11. anon283326's Avatar
    Sorry to be resurrecting an old thread, but I have a serious issue it seems....

    I have an HTC EVO 3D with HBOOT 1.5, no S-OFF. I'm running ViperROM RC2 and I used Root Explorer to edit the adreno_config.txt and build.prop files in my system folder. I'm 100% positive I did it correctly. I backed up the files and attempted a reboot. At first, the phone was doing ok. It powered off and the white and green "htc" splash image loaded.....but that was it. Every time I try to boot up, it does that. I went into recovery and fixed permissions, wiped cache and dalvik, all of that.....I had to adb pull the files, return them to normal, adb push them back into /system, and reboot to fix the problem and actually get the phone to boot up again.

    Anyone know what I did wrong??
    03-07-2012 02:13 PM
  12. dimebagdan65's Avatar
    Sorry to be resurrecting an old thread, but I have a serious issue it seems....

    I have an HTC EVO 3D with HBOOT 1.5, no S-OFF. I'm running ViperROM RC2 and I used Root Explorer to edit the adreno_config.txt and build.prop files in my system folder. I'm 100% positive I did it correctly. I backed up the files and attempted a reboot. At first, the phone was doing ok. It powered off and the white and green "htc" splash image loaded.....but that was it. Every time I try to boot up, it does that. I went into recovery and fixed permissions, wiped cache and dalvik, all of that.....I had to adb pull the files, return them to normal, adb push them back into /system, and reboot to fix the problem and actually get the phone to boot up again.

    Anyone know what I did wrong??
    Keep me posted, running same ROM as you and I wanna get this working! Gonna post over in viperboy's thread and see what he and vinchenzo can come up with

    Sent from my PG86100 using Tapatalk
    03-07-2012 04:16 PM
  13. benny3's Avatar
    what tweaks did you add to the build prop? some may not work on the 3d
    what base is the rom built from? if its the new 2.17 some tweaks wont work

    Sorry to be resurrecting an old thread, but I have a serious issue it seems....

    I have an HTC EVO 3D with HBOOT 1.5, no S-OFF. I'm running ViperROM RC2 and I used Root Explorer to edit the adreno_config.txt and build.prop files in my system folder. I'm 100% positive I did it correctly. I backed up the files and attempted a reboot. At first, the phone was doing ok. It powered off and the white and green "htc" splash image loaded.....but that was it. Every time I try to boot up, it does that. I went into recovery and fixed permissions, wiped cache and dalvik, all of that.....I had to adb pull the files, return them to normal, adb push them back into /system, and reboot to fix the problem and actually get the phone to boot up again.

    Anyone know what I did wrong??
    03-07-2012 08:01 PM
  14. pergerson6's Avatar
    ViperRom is built from the newest update.

    Sent from my PG86100
    03-07-2012 09:42 PM
  15. benny3's Avatar
    here are the tweaks that i found so far that works on the new base



    # Tweaks
    windowsmgr.max_events_per_sec=300
    debug.performance.tuning=1
    video.accelerate.hw=1
    ro.HOME_APP_ADJ=1
    ro.telephony.call_ring.delay=0
    pm.sleep_mode=1
    ro.ril.disable.power.collapse=0
    persist.adb.notify=0
    ro.media.enc.jpeg.quality=100
    ro.media.dec.jpeg.memcap=8000000
    ro.media.enc.hprof.vid.bps=8000000
    windowsmgr.support_rotation_270=true

    media.stagefright.enable-player=true
    media.stagefright.enable-meta=true
    media.stagefright.enable-scan=true
    media.stagefright.enable-http=true

    # NetSpeed tweaks
    net.tcp.buffersize.default=4096,87380,256960,4096, 16384,256960
    net.tcp.buffersize.wifi=4096,87380,256960,4096,163 84,256960
    net.tcp.buffersize.umts=4096,87380,256960,4096,163 84,256960
    net.tcp.buffersize.gprs=4096,87380,256960,4096,163 84,256960
    net.tcp.buffersize.edge=4096,87380,256960,4096,163 84,256960
    03-08-2012 09:16 PM
LINK TO POST COPIED TO CLIPBOARD