Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  
    PhishShticks's Avatar

    Posts
    29 Posts
    Global Posts
    67 Global Posts
    ROM
    Stock

    Question Google Voice w/Sprint - Texts showing up twice

    Hey folks I have my Sprint number integrated with Google Voice.

    With a little help from Customer Service, I was able to fix my texts from ONLY coming into Google Voice instead of the built in messaging app, but now, they are coming into BOTH. Extremely annoying.

    I used to have T-Mobile and it worked flawlessly on my G2X without a problem, but I'm not that savvy with the integration Sprint offers.

    Is there anyway I can just have my voicemails come through to GV and not texts too?

    Please help!

    Thanks!
    "I would love to change the world, but they won't give me the source code."
  2. #2  
    backlund's Avatar

    Posts
    30 Posts
    Global Posts
    150 Global Posts

    Default Re: Google Voice w/Sprint - Texts showing up twice

    They technically should come in to both, but what you want to do is go into the google voice app and turn off the notifications. That way you will only see notifications from the normal messaging app.
  3. Thread Author  Thread Author    #3  
    PhishShticks's Avatar

    Posts
    29 Posts
    Global Posts
    67 Global Posts
    ROM
    Stock

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by backlund View Post
    They technically should come in to both, but what you want to do is go into the google voice app and turn off the notifications. That way you will only see notifications from the normal messaging app.
    Turn off text notifications?
    "I would love to change the world, but they won't give me the source code."
  4. #4  
    enthuz's Avatar

    Posts
    614 Posts
    Global Posts
    843 Global Posts

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by backlund View Post
    They technically should come in to both, but what you want to do is go into the google voice app and turn off the notifications. That way you will only see notifications from the normal messaging app.
    I thought it was stated that you would lose your visual voicemail if you do this?
    Android Ninja in Training
    EVO 3D
    TF201 64GB
  5. #5  
    craigdts's Avatar

    Posts
    28 Posts
    Global Posts
    713 Global Posts

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Clunky, but you can turn off text messaging and turn on email notification for voicemail. About the only way I've figured out.
  6. Thread Author  Thread Author    #6  
    PhishShticks's Avatar

    Posts
    29 Posts
    Global Posts
    67 Global Posts
    ROM
    Stock

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by newdroid View Post
    Clunky, but you can turn off text messaging and turn on email notification for voicemail. About the only way I've figured out.
    I tried what backlund said, but then I stopped getting text in the messaging app and only in GV. Had to edit the settings on the website to "Receive texts" etc. What I tried must have turned it off.

    Is there an actual fix for this? GV is nice, but I don't want it handling my texts nor do I want 2 copies to come in to the messaging app and GV at the same time.

    Customer Care doesn't have much to say about it either other that what I could find on Google which doesn't help much.

    My GV number used to be a different number (when I used it with my T-Mobile phone) and I assume the "Lite" version is what was doing the voicemail, but since integrating with my EVO 3D on Sprint, it seems to be "taking over" everything.

    Thanks for any and all help you can provide!
    "I would love to change the world, but they won't give me the source code."
  7. #7  

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by PhishShticks View Post
    I tried what backlund said, but then I stopped getting text in the messaging app and only in GV. Had to edit the settings on the website to "Receive texts" etc. What I tried must have turned it off.

    Is there an actual fix for this? GV is nice, but I don't want it handling my texts nor do I want 2 copies to come in to the messaging app and GV at the same time.
    There is no "fix" for this, it's behaving as it should. Only that's not what a lot of people want.

    The Sprint Integration with Google Voice allows Google Voice to take over all of your phones communication. Technically, you aren't receiving the texts twice, Google Voice is receiving them and then forwarding them to your actual cell phone number. But yeah, it appears as if you're getting them twice.

    I'm assuming you want to use Google Voice strictly for voicemail and want it to leave everything else alone. What you want to do is go to your GV settings and disable Sprint on your account. This will put it back where Sprint will forward your voicemails to GV. Just don't disable Google voicemail after you do that.

    Hope that's what you're looking for.
  8. #8  
    backlund's Avatar

    Posts
    30 Posts
    Global Posts
    150 Global Posts

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by PhishShticks View Post
    I tried what backlund said, but then I stopped getting text in the messaging app and only in GV. Had to edit the settings on the website to "Receive texts" etc. What I tried must have turned it off.

    Is there an actual fix for this? GV is nice, but I don't want it handling my texts nor do I want 2 copies to come in to the messaging app and GV at the same time.

    Customer Care doesn't have much to say about it either other that what I could find on Google which doesn't help much.

    My GV number used to be a different number (when I used it with my T-Mobile phone) and I assume the "Lite" version is what was doing the voicemail, but since integrating with my EVO 3D on Sprint, it seems to be "taking over" everything.

    Thanks for any and all help you can provide!
    I think I misunderstood what you are trying to do. You want voicemails on the GV app, texts on the default messaging app. It's doable, but a bit flaky because when you integrate Google Voice, the idea is that it's a replacement for the default messaging app and sprint's voicemail. There are also caveats to doing this. It is a bit convoluted, so I'll give you the steps:

    -Go into the google voice app on the phone. On the main Google Voice screen click your Menu button, then the *** More icon and choose Settings.

    -Click the "Sync and Notifications" option.

    -Leave the Text messages notification on. If you uncheck this, you will no longer get texts on your phone in the default app, and will only get them in the GV app.

    -Now you have to decide what you want to do next:
    *Option 1 is to uncheck the inbox notifications, which will keep you from getting the duplicate notifications when texts are received. The app may even complain to you about getting duplicates. Ignore it and click OK. The caveat to this is that you won't receive any notification of a voicemail from the GV app or the phone voicemail app, when you get one. The only thing you can do is make sure that GV sends you a text notifying you of a new text message. Make sure you check out your settings on the GV website under Voicemail & Text, and have it set to send you a text (SMS) when a voicemail is received. Also hit the last option to transcribe the voicemail so you still have the visual voicemail capability. Basically, you'll have to manually click into the GV app to listen to the message if choose to do so, because your only voicemail notification will be a text message that will take you to the default messaging app when you click on it.

    *Option 2 is to leave the inbox notifications on, which will give you a notification of both new text messages and voicemails when received. Then go into the default messaging app, click the menu button and choose settings, and then notifications. Uncheck the "received" notification. Again, this will keep you from getting duplicate notifications on your text messages, but the caveat to this option is that if you click on the notification, it will take you to the GV app to read your text message. You will still get the message in the default messaging app as well, but you will have to manually click that app to read or reply to it. I'm guessing since you want to avoid the GV app for texts, this option probably isn't as good for you.

    As stated originally, the GV app is meant as a free replacement for your text and voicemail service provided by sprint. No matter what, there's going to be issues with what you are trying to do, because you are basically trying to use GV for voicemail, and Sprint for text, but the service is designed as a singular replacement for both. If you aren't receiving voice mails left and right all day long, I'd use option 1. The only real downside to option 1 is manually launching the GV app to retrieve your voicemail.

    Hope this helps!
  9. #9  
    backlund's Avatar

    Posts
    30 Posts
    Global Posts
    150 Global Posts

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by Darth Mo View Post
    There is no "fix" for this, it's behaving as it should. Only that's not what a lot of people want.

    The Sprint Integration with Google Voice allows Google Voice to take over all of your phones communication. Technically, you aren't receiving the texts twice, Google Voice is receiving them and then forwarding them to your actual cell phone number. But yeah, it appears as if you're getting them twice.

    I'm assuming you want to use Google Voice strictly for voicemail and want it to leave everything else alone. What you want to do is go to your GV settings and disable Sprint on your account. This will put it back where Sprint will forward your voicemails to GV. Just don't disable Google voicemail after you do that.

    Hope that's what you're looking for.
    This is also a good option, but you lose the capability to have your texts available on multiple devices if you use the service like that. Technically you can still get them by having them forwarded, but your replies will come from a separate GV phone number, rather than your sprint number. I use the GV plugin on chrome, as well as the GV app on my WIFI tablet, so having all of my texting available on different devices is what attracted me to the service.
  10. #10  

    Default Re: Google Voice w/Sprint - Texts showing up twice

    Quote Originally Posted by backlund View Post
    This is also a good option, but you lose the capability to have your texts available on multiple devices if you use the service like that. Technically you can still get them by having them forwarded, but your replies will come from a separate GV phone number, rather than your sprint number. I use the GV plugin on chrome, as well as the GV app on my WIFI tablet, so having all of my texting available on different devices is what attracted me to the service.
    All I was saying that what the OP was describing is not possible the way Sprint/Google has implemented this "integration."

    The options are: receive voicemail notifications and two text notifications, or receive one text notification and no voicemail notification. It's just stupid. If you don't want to be annoyed and get voicemail updates you're forced to use the Voice app for texts which is crap.

    All Google has to do is to give an option to not have GV produce a notification when the forward to mobile option is checked (Like they do with every other notification service on their own operating system). It's like Google is trying to take over SMS...

Tags for this Thread

Posting Permissions

B