1. blaidan's Avatar
    My GPS location accurately displays my location. However, the weather widget shows my location in a city that's nearly an hour and a half away. What gives? Anyone else having this issue?

    I should add that this just started occurring over the last day and a half. Prior to that my weather widget properly identified my location.
    07-12-2011 06:30 PM
  2. tkemack's Avatar
    Were you recently in that city? The weather only updates as often as you set it, so that could be it. For instance, mine is set for every hour refresh I think, so in that hour I can be pretty far away from the place I just left

    sent to you in three dimensions
    07-12-2011 07:37 PM
  3. blaidan's Avatar
    I've never been in that city. Like I said, the city is about 1.5 hours from my home. Very odd... and annoying.
    07-12-2011 08:41 PM
  4. tkemack's Avatar
    Couldn't you just set it to the city you're in instead of using the location function?
    07-12-2011 08:52 PM
  5. blaidan's Avatar
    I could but then that kind of defeats the purpose of having the "current" weather available to you wherever you happen to be. For instance, knowing the weather conditions in my hometown does me no good when I'm at work 40 minutes away.

    And, as I mentioned, this was finding me just fine at home bfore about a day and a half ago.
    07-12-2011 09:07 PM
  6. Buckeyes's Avatar
    This constantly happens to me, also! Very annoying. I live near Tampa, yet will show me in Savannah or other areas. This was a constant issue on my original EVO too. I have mine set to update upon opening. One of my few complaints about this phone.
    07-13-2011 05:45 AM
  7. Bigfire's Avatar
    Mine is showing the generic 'current location' on the home widget and when going into the weather app, with a little bubble error message about cannot find location. This seems to happen from time to time.
    07-13-2011 07:06 AM
  8. fstop's Avatar
    That happened on my friend's OG EVO from time to time. A reboot always fixed it. Does it fix yours?
    07-13-2011 08:13 AM
  9. Bigfire's Avatar
    Didn't reboot, correct city now showing. Weather app hiccup I guess.
    07-13-2011 08:39 AM
  10. blaidan's Avatar
    Reboot doesn't work for me.

    I thought that perhaps it might be an issue with my home network and the Airave that I have from Sprint. So, I shut off the router completely just to take it and the Airave out of the equation completely. Then I rebooted the phone so that it only picked up a 3G signal. Same issue remains. Annoying. Especially since it was working just the other day.

    Now, the odd thing is that when I go to work and start traveling the weather will accurately show the cities that I am traveling through. Additionally, it accurately shows my location all day while I'm at work. Only seems to be an issue at my home which is why I thought to try taking the home network/Airave out of the equation.

    I can't even manually add my home city because it does not show up in the search if I type it in (smaller city). Frustrating.

    However, this is really the only issue that I am having with the phone.
    07-13-2011 09:09 AM
  11. Ronko308's Avatar
    Reboot doesn't work for me.

    I thought that perhaps it might be an issue with my home network and the Airave that I have from Sprint. So, I shut off the router completely just to take it and the Airave out of the equation completely. Then I rebooted the phone so that it only picked up a 3G signal. Same issue remains. Annoying. Especially since it was working just the other day.

    Now, the odd thing is that when I go to work and start traveling the weather will accurately show the cities that I am traveling through. Additionally, it accurately shows my location all day while I'm at work. Only seems to be an issue at my home which is why I thought to try taking the home network/Airave out of the equation.

    I can't even manually add my home city because it does not show up in the search if I type it in (smaller city). Frustrating.

    However, this is really the only issue that I am having with the phone.
    Wow Blaidan,
    If I had to describe my environment and what is happening to me and my Evo3D, I could not do it better than you did with yours. I have the exact same scenario down to the Airrave at home and the cities being wrong only at home. About the only difference is that the city it is using is not 1.5 hours away but only about 45 minutes. Otherwise, ditto!
    07-13-2011 11:33 AM
  12. blaidan's Avatar
    Wow Blaidan,
    If I had to describe my environment and what is happening to me and my Evo3D, I could not do it better than you did with yours. I have the exact same scenario down to the Airrave at home and the cities being wrong only at home. About the only difference is that the city it is using is not 1.5 hours away but only about 45 minutes. Otherwise, ditto!
    Well, at least I know I'm not alone. So weird though because like I said it was working just fine up until 2 days ago.
    07-13-2011 01:13 PM
LINK TO POST COPIED TO CLIPBOARD