1. taque's Avatar
    Got my EVO 3D the day it came out. It's been pretty solid, but I have had one consistent problem. After being on WiFi for 30-60 min, network connectivity drops out. It still shows connected to wifi but no network items work - Exchange, gmail, internet, google talk etc. It acts like it loses connectivity or an IP or something. But since it is still technically "connected" to wifi, it doesn't switch back to 3G. I have to turn it off and use 3G or switch it off and back on quickly and re-establish connection to wifi, then it works fine for 30-60 min.

    I have tried this on 3 different wifi networks with three different access points: comcast stock, watchguard and linksys/cisco. Same thing no matter what. I'm about to call Sprint, but thought I'd post and see if anyone had thoughts on the issue.

    Thanks.
    07-15-2011 10:08 AM
  2. Moose24's Avatar
    Go under the network setting on the phone, and find the sleep policy and set to never. That should help.
    07-15-2011 10:28 AM
  3. taque's Avatar
    Go under the network setting on the phone, and find the sleep policy and set to never. That should help.
    hmm, I feel dumb, but I can't find that setting anywhere in wireless or power settings. Can you help me out?
    07-17-2011 10:52 PM
  4. Wiley_11's Avatar
    hmm, I feel dumb, but I can't find that setting anywhere in wireless or power settings. Can you help me out?
    Go to Settings>Wireless&Networks>Wifi Settings>Menu>Advanced>Wifi Sleep Policy>Never.
    AngryCPA, Corrosive and a dumb cat like this.
    07-17-2011 11:29 PM
  5. Moose24's Avatar
    Thanks Wiley, you got it before I got back to it.
    07-18-2011 07:47 AM
  6. taque's Avatar
    Go to Settings>Wireless&Networks>Wifi Settings>Menu>Advanced>Wifi Sleep Policy>Never.
    Awesome! Thanks! I have to get used to all the extra "hidden" menus.
    07-18-2011 09:15 AM
  7. preViously's Avatar
    I have this issue too but I lose the connectivity I the middle of browsing so I don't think it's the sleep setting.
    07-18-2011 02:31 PM
  8. taque's Avatar
    Thanks, both of you! No problems since turning off sleep!
    07-19-2011 10:55 PM
  9. Wiley_11's Avatar
    Thanks, both of you! No problems since turning off sleep!

    You can thank me by helping someone out when they need it.
    07-19-2011 11:10 PM
  10. brooksman9's Avatar
    mine is set to never but still have the same problem.
    08-02-2011 05:56 PM
  11. a dumb cat's Avatar
    mine is set to never but still have the same problem.
    I have the same issue. I knew of this setting and enabled when I first got the phone last month. Everything was running okay until a few days ago when it would mysteriously just drop a connection in the middle of browsing. It happens about 1-2 times a day now. Turning on/off the connection is an okay work around, but WHY is this happening in the first place? And HOW do you fix it?

    Thanks, all!
    08-02-2011 07:27 PM
LINK TO POST COPIED TO CLIPBOARD