1. wizof103's Avatar
    I just received my new HTC MLH to HDMI adapter for my EVO 3d, and out of the package, I get putts, nothing, notta. Is this just a issue with the new cable. Thank in advance.
    07-30-2011 08:32 AM
  2. Jackietreehorn's Avatar
    Do you have your phone charger plugged into the MHL adapter while you're trying to use it? It has to be powered...unfortunately, doesn't appear that you can get away with using it without a charger.
    07-30-2011 10:00 AM
  3. wizof103's Avatar
    The EVO 3d uses the same port for both charging and the adapter cable.
    07-30-2011 11:13 AM
  4. enthuz's Avatar
    The EVO 3d uses the same port for both charging and the adapter cable.
    Yes, which is why you must have both the MHL and wall power plugged in.

    07-30-2011 03:00 PM
  5. Pyro_android's Avatar
    Yes you HAVE to have both plugged in charge and hdmi
    07-30-2011 04:45 PM
  6. garrettfarnum's Avatar
    The EVO 3d uses the same port for both charging and the adapter cable.
    There should be a plug on the MHL cable.
    07-30-2011 08:12 PM
  7. perfectazn's Avatar
    Also, it cannot be from a usb cable plugged into a computer. It has to be plugged into an outlet. It should be charging your phone when you plug in the MHL adapter.

    I just picked one up from a Tmobile store today and it works.
    07-30-2011 11:22 PM
  8. wizof103's Avatar
    Thanks to all. I just didn't see the port for power. Works great, Thanks to everyone.
    07-31-2011 04:50 PM
LINK TO POST COPIED TO CLIPBOARD