Page 1 of 2 12 LastLast
Results 1 to 25 of 26
Like Tree1Likes
  1. Thread Author  Thread Author    #1  

    Default Automatically going to the mobile network if wi-fi dead?

    Hey guys, is it possible to make the phone automatically go to using the mobile network when wi-fi is on but not working for whatever reason? Makes no sense to keep disabling the wi-fi just so the 3/4G can be activated to complete a task.
  2. #2  

    Default

    Yeah, this has bothered me as well, if the wifi network is borked for some reason, either network or the phone's issue, I don't get any errors or notifications, it just doesn't sync anymore and doesn't tell you why.

    Sent from my PG86100 using Tapatalk
  3. #3  
    santos's Avatar

    Posts
    45 Posts
    Global Posts
    627 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Define not working for whatever reason. Do you mean connected to a hot spot but you have no net access?
  4. Thread Author  Thread Author    #4  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Every so often, either my wi-fi connection goes down, or it'll be up but for whatever reason the phone won't load data on Twitter/FB/whatever. I'll have to turn off the wi-fi band then turn it right back on to get it to work.

    Either way, if for whatever reason it doesn't work, it doesnt make much sense that it doesnt go to using the mobile network automatically.
  5. #5  
    santos's Avatar

    Posts
    45 Posts
    Global Posts
    627 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    The only time I see the phone auto switch to the mobile network is when it's out of range of the WiFi hotspot. The phones I have had for the past 5 years that include WiFi were the same way. What you're asking for is some sort of connection check handling that I don't think exists.

    Maybe there is something wrong with your WiFi radio in your EVO 3d or maybe something is wrong with your wireless router.
    Last edited by santos; 08-08-2011 at 02:53 PM.
  6. Thread Author  Thread Author    #6  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Might be the router but even if I'm not having trouble on the computer, I've noticed a couple instances where it was weird with the phone. Particularly when I first use the phone after a night of sleep.
  7. #7  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I'm experiencing the same thing you are actually.

    Start off on 3G, switch to Wifi works great. Then after a few minutes or a few hours, no longer detects WiFi for whatever reason. Other computers/devices connected to the same network are still working fine. I'll go in, turn off Wifi, then turn on 3g/4g and my data works again. Annoying.
  8. #8  
    Deutch's Avatar

    Posts
    25 Posts
    Global Posts
    26 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I just started to have this problem for the last couple days. My phone will show full wifi signal and connected to my home network but after the phone sits for a couple hours I'll have to toggle the wifi off then on again to get it to work again. All other devices connected to the same work do not have any connection issue.

    This might be a good excuse to root my phone and toss a new ROM on it and see if that fixes the issue.
  9. #9  
    acstewart82's Avatar
    Android Lover

    Posts
    186 Posts
    ROM
    Stock

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I leave my wifi on at work but if I don't touch my phone for a while when I come back to my phone to find the wifi off but after a few seconds the wifi comes back on but half the time it works and the other half I have to turn the wifi off and then back on again to get it to work.
    GSM Galaxy Nexus Takhju
    Asus Nexus 7
    Loving my Nexus devices. Do believe I will remain a nexus owner for quite some time.
  10. #10  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    The problem I have is with MMS messages. I thought the 3g/2g radio would take prescience over wifi but it dosent, it just its there sending....sending....sending....until I turn WiFi off then it send the message....


    Drives me nuts!
    My Wallpaper Collection!!! Updated 7/12/2011 (some NSFW)
    http://picasaweb.google.com/102508753250975172853/Wallpaper#
  11. #11  
    ernier's Avatar

    Posts
    6 Posts
    Global Posts
    28 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I'm glad I'm not the only one having this issue. I could be home and I'm five feet away from the access point but when I wake the phone from sleep, it is connected to the 3g network instead of the wifi. It takes a solid 5 seconds to connect to the wifi network. Sometimes I even get on the left side of the notification bar a wifi signal with an exclamation point saying it can't connect to the network, but it connects anyway. Besides this problem, the phone has been a little quirky with some other software issues so I'm going to the sprint store to get a replacement, the phone is just a little over than a month old, it shouldn't be having issues.
  12. #12  
    viddywell's Avatar

    Posts
    9 Posts
    Global Posts
    41 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I too had the same problem. I started using Connection Checker Pro and it's been a godsend.



    It checks for actual internet access via WIFI and if none is available, disables the connection for some period of time, then tries the wifi connection again. This way, you never end up stuck on a "dead" network.

    This proved especially frustrating for me as I was using a SIP client for phone at home and missing calls as a result.
  13. Thread Author  Thread Author    #13  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Quote Originally Posted by kellyrx8 View Post
    The problem I have is with MMS messages. I thought the 3g/2g radio would take prescience over wifi but it dosent, it just its there sending....sending....sending....until I turn WiFi off then it send the message....


    Drives me nuts!
    this happens to me while using GoSMS Pro. If I take a picture and send it straight from the gallery, it will hang like that. I have to attach it manually in the message to get it to send.

    I guess I'll try that connection app.
  14. #14  
    zdez50's Avatar

    Posts
    7 Posts
    Global Posts
    8 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    MEEH TOO. While on wifi, I will let it idol and do my thing for awhile, I will then try to refresh my HTC News widget and it won't refresh, it will stay stuck on yesterday's update or the last time I refreshed it. I either have to turn off wifi or have to go into application settings and force stop and clear data. I only clear data is when I will be on 3g and it still won't update. I have the same app problem with friend stream or facebook, although I have not had to clear data while on 3g for facebook; only friend stream.
  15. #15  
    SirRob94's Avatar

    Posts
    41 Posts
    Global Posts
    143 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    I too have been having the WiFi problem.

    I don't know what the issue is, but known good Wifi spots seem to just stop working. Then I have to shut down WiFi and use 3G connection. HTC needs to address whatever the issue is in the next update.
  16. #16  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Quote Originally Posted by ernier View Post
    I'm glad I'm not the only one having this issue. I could be home and I'm five feet away from the access point but when I wake the phone from sleep, it is connected to the 3g network instead of the wifi. It takes a solid 5 seconds to connect to the wifi network. Sometimes I even get on the left side of the notification bar a wifi signal with an exclamation point saying it can't connect to the network, but it connects anyway. Besides this problem, the phone has been a little quirky with some other software issues so I'm going to the sprint store to get a replacement, the phone is just a little over than a month old, it shouldn't be having issues.
    I have this same experience.
  17. #17  
    titanoman's Avatar
    Banned

    Posts
    178 Posts
    ROM
    2.2(?)(stock?)

    Default

    Quote Originally Posted by acstewart82 View Post
    I leave my wifi on at work but if I don't touch my phone for a while when I come back to my phone to find the wifi off but after a few seconds the wifi comes back on but half the time it works and the other half I have to turn the wifi off and then back on again to get it to work.
    I think you need to go wi-fi advanced settings and select "never sleep". It is probably on "sleep when display (back light) turns off". I'm a newbie, but I had to resolve the same issue. Good luck to you.
    TenshiNo likes this.
  18. #18  
    TenshiNo's Avatar

    Posts
    162 Posts
    Global Posts
    178 Global Posts
    ROM
    Stock (Rooted) Jelly Bean

    Default Re: Automatically going to the mobile network if wi-fi dead?

    @titanoman is on the right track here. The EVO 3D seems to have issues with latency getting the WiFi radio reconnected after it goes to sleep, which (I think) is the problem you guys are seeing.

    By default, Android sets the WiFi to sleep whenever the screen turns off, which sounds like a good idea, but doesn't actually get you the extra battery you would think. This is because the phone *wants* an internet connection so, as soon as the WiFi cuts out, the 3G tries to come back on.

    This is generally a good setting to change on any phone if you spend most of your day around WiFi access points, since the WiFi radio uses significantly less juice than the 3G radio. Here's how you do it:

    1. From the home screen, press the "Menu" softkey and select "Settings" from the popup menu.
    2. Select "Wireless & Networks" from your settings screen.
    3. Turn on WiFi (if it isn't already) and then click "Wi-Fi Settings".
    4. Now, hit the "Menu" softkey again and you'll get a popup menu with an "Advanced" button.
    5. After hitting "Advanced" you'll go to the screen were you can see your current WiFi IP address and connection info. At the top is an option called "Wi-Fi Sleep Policy". Click that.
    6. The options are as follows:
      1. After 15 min: WiFi shuts down after you haven't been transmitting or receiving data for 15 minutes.
      2. Never when plugged in: WiFi will always stay on if the phone is plugged in, otherwise the 15 minute policy applies.
      3. Never: Exactly how it sounds. WiFi will never sleep and will always remain connected.
    7. There's also an option here called "Best Wi-Fi Performance", but the phone warns that it could drain the battery faster. I honestly don't know exactly what that one does.


    It's important to note, that this could have a negative impact on your battery depending on your use. I strongly recommend going to the basic WiFi settings screen and disabling the "Network notification" option, since this will cause your phone to constantly scan for an open WiFi when you're not connected. And, since we've just set your WiFi radio to never go to sleep, that could be very bad

    Also, I would recommend turning off the WiFi radio when you know you're not going to be around WiFi for a while. There's a ton of widgets out there that make this super easy, even if you don't like the ones included with Sense. Personally, I use the Power Control Plus widget, cause I like being able to configure it with exactly with options I want.



    Good luck, guys. I hope this helps.
    Thanked by 2:
  19. #19  
    SirRob94's Avatar

    Posts
    41 Posts
    Global Posts
    143 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Quote Originally Posted by TenshiNo View Post
    @titanoman is on the right track here. The EVO 3D seems to have issues with latency getting the WiFi radio reconnected after it goes to sleep, which (I think) is the problem you guys are seeing.

    By default, Android sets the WiFi to sleep whenever the screen turns off, which sounds like a good idea, but doesn't actually get you the extra battery you would think. This is because the phone *wants* an internet connection so, as soon as the WiFi cuts out, the 3G tries to come back on.

    This is generally a good setting to change on any phone if you spend most of your day around WiFi access points, since the WiFi radio uses significantly less juice than the 3G radio. Here's how you do it:

    1. From the home screen, press the "Menu" softkey and select "Settings" from the popup menu.
    2. Select "Wireless & Networks" from your settings screen.
    3. Turn on WiFi (if it isn't already) and then click "Wi-Fi Settings".
    4. Now, hit the "Menu" softkey again and you'll get a popup menu with an "Advanced" button.
    5. After hitting "Advanced" you'll go to the screen were you can see your current WiFi IP address and connection info. At the top is an option called "Wi-Fi Sleep Policy". Click that.
    6. The options are as follows:
      1. After 15 min: WiFi shuts down after you haven't been transmitting or receiving data for 15 minutes.
      2. Never when plugged in: WiFi will always stay on if the phone is plugged in, otherwise the 15 minute policy applies.
      3. Never: Exactly how it sounds. WiFi will never sleep and will always remain connected.
    7. There's also an option here called "Best Wi-Fi Performance", but the phone warns that it could drain the battery faster. I honestly don't know exactly what that one does.


    It's important to note, that this could have a negative impact on your battery depending on your use. I strongly recommend going to the basic WiFi settings screen and disabling the "Network notification" option, since this will cause your phone to constantly scan for an open WiFi when you're not connected. And, since we've just set your WiFi radio to never go to sleep, that could be very bad

    Also, I would recommend turning off the WiFi radio when you know you're not going to be around WiFi for a while. There's a ton of widgets out there that make this super easy, even if you don't like the ones included with Sense. Personally, I use the Power Control Plus widget, cause I like being able to configure it with exactly with options I want.



    Good luck, guys. I hope this helps.
    Thanks for the writeup TenshiNo, but mine was defaulted to "Never" and I suspect that most might be.
    I don't know that it is related to the phone sleeping.

    Here is the scenario:
    I will be surfing on WiFi fine for a while.
    -Suddenly I will attempt to load a page that should work and it won't load. Progress bar sticks 1/4 of the way across.
    -So I try to reconnecting to SSID by turning WIFI off/on. Phone says obtaining IP addres and reconnects, but page still wont load, even if I hit refresh.

    -I turn off WiFi and leave it off and 3G kicks in then page loads.

    Any other suggestions?

    Like I wrote before, I think it might be an issue that HTC needs to address since others are having a similar problem.
  20. #20  
    TenshiNo's Avatar

    Posts
    162 Posts
    Global Posts
    178 Global Posts
    ROM
    Stock (Rooted) Jelly Bean

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Quote Originally Posted by sirrob View Post
    Thanks for the writeup TenshiNo, but mine was defaulted to "Never" and I suspect that most might be.
    I don't know that it is related to the phone sleeping.

    Here is the scenario:
    I will be surfing on WiFi fine for a while.
    -Suddenly I will attempt to load a page that should work and it won't load. Progress bar sticks 1/4 of the way across.
    -So I try to reconnecting to SSID by turning WIFI off/on. Phone says obtaining IP addres and reconnects, but page still wont load, even if I hit refresh.

    -I turn off WiFi and leave it off and 3G kicks in then page loads.

    Any other suggestions?

    Like I wrote before, I think it might be an issue that HTC needs to address since others are having a similar problem.
    My suggestion here would be to grab WiFi analyzer from the Android market. It's free and it can help you determine if maybe there's a lot of interference on your WiFi channel for your area. I've run into this problem before. Someone said that other computers on the network continue to work fine, but they might have more powerful radios/larger antennas that help them deal with the issue.

    Grab it here:



    Fire it up, hit the "Menu" softkey, then select "Set My AP" and select which wireless network you use. Then hit "Menu" again and select the "View" option. That will give you a menu with 5 or so items. Select "Channel Rating" and it will give you a list of all 14 WiFi channels with a rating of how "clear" they are.

    I've run into problems similar to this in the past and it ended up that I was using a channel with only a 1 star rating. Changed the channel on the router and the performance went way up. This can be very common in an apartment or neighborhood where there are lots of wireless networks around you.

    Good Luck! Let us know what you find
  21. #21  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Quote Originally Posted by TenshiNo View Post
    @titanoman is on the right track here. The EVO 3D seems to have issues with latency getting the WiFi radio reconnected after it goes to sleep, which (I think) is the problem you guys are seeing.

    By default, Android sets the WiFi to sleep whenever the screen turns off, which sounds like a good idea, but doesn't actually get you the extra battery you would think. This is because the phone *wants* an internet connection so, as soon as the WiFi cuts out, the 3G tries to come back on.

    This is generally a good setting to change on any phone if you spend most of your day around WiFi access points, since the WiFi radio uses significantly less juice than the 3G radio. Here's how you do it:

    1. From the home screen, press the "Menu" softkey and select "Settings" from the popup menu.
    2. Select "Wireless & Networks" from your settings screen.
    3. Turn on WiFi (if it isn't already) and then click "Wi-Fi Settings".
    4. Now, hit the "Menu" softkey again and you'll get a popup menu with an "Advanced" button.
    5. After hitting "Advanced" you'll go to the screen were you can see your current WiFi IP address and connection info. At the top is an option called "Wi-Fi Sleep Policy". Click that.
    6. The options are as follows:
      1. After 15 min: WiFi shuts down after you haven't been transmitting or receiving data for 15 minutes.
      2. Never when plugged in: WiFi will always stay on if the phone is plugged in, otherwise the 15 minute policy applies.
      3. Never: Exactly how it sounds. WiFi will never sleep and will always remain connected.
    7. There's also an option here called "Best Wi-Fi Performance", but the phone warns that it could drain the battery faster. I honestly don't know exactly what that one does.


    It's important to note, that this could have a negative impact on your battery depending on your use. I strongly recommend going to the basic WiFi settings screen and disabling the "Network notification" option, since this will cause your phone to constantly scan for an open WiFi when you're not connected. And, since we've just set your WiFi radio to never go to sleep, that could be very bad

    Also, I would recommend turning off the WiFi radio when you know you're not going to be around WiFi for a while. There's a ton of widgets out there that make this super easy, even if you don't like the ones included with Sense. Personally, I use the Power Control Plus widget, cause I like being able to configure it with exactly with options I want.



    Good luck, guys. I hope this helps.
    Mine was set to sleep after 15 min. I have changed it and will see how it goes. Thanks.
  22. #22  
    mastrK13's Avatar

    Posts
    81 Posts
    Global Posts
    105 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    To help with the original question, I do not believe there is a way to auto-enable wifi to turn off and use the mobile network if your internet goes sour. It's not the phone's fault, just that sometimes internet goes down and you can still be connected to the wireless router. This would be a cool feature though because I've definitely had this happen to me before, and it would be nice if it gave you a little message like Windows 7 where it says you don't have a connection to the internet even though you're connected to a network.

    Also, I noticed that if you have selected "enable power efficiency" under settings/power that could actually be causing the wifi to turn off regardless if you select it to never sleep. And enabling "best wifi performance" just gives a boost to your wifi antenna if you have a weak connection. That's why it will eat away at the battery faster.
  23. #23  
    ernier's Avatar

    Posts
    6 Posts
    Global Posts
    28 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    @Sirrob
    I'm having the same issue you have, I would go to the browser and try to load a page and it would only get as far as the http:// and stay there loading, so I have to switch wifi off and then6 turn it back on again, which is very annoying. I also have to do this for any app that needs internet access but can't get to the internet for the same issue.

    Also I'm having similar issues with the 3G when playing Pandora, I would be listening to Pandora with perfect 3G signal, and all of the sudden it stops playing, so I turn the screen on and there is no 3G connection but almost immediately it connects and starts streaming music again, which is very weird.
  24. Thread Author  Thread Author    #24  

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Pretty nonsensical for it not to switch to the next available connection.

    Oh well, I'll live with it.
  25. #25  
    Gantry's Avatar

    Posts
    6 Posts
    Global Posts
    35 Global Posts

    Default Re: Automatically going to the mobile network if wi-fi dead?

    Just want to confirm that I have the same issue at home - the WiFi just stops working after a relatively short period of time. No errors, stays connected but all Internet stops working. Only turning off WiFi and turning back on helps.

    My WiFi sleep policy is set to "Never" so that isn't the issue. Anyone come up with a fix? Drives me nuts...
Page 1 of 2 12 LastLast

Posting Permissions

B