1. darkborne's Avatar
    Just upgraded from Evo to Evo3d.

    Visual voicemail app isn't recieving my voicemails, instead I get a text message from //ANDROID with a call in number every time someone leaves a message.

    Any ideas guys?
    06-27-2011 09:27 AM
  2. MannyZ28's Avatar
    I had the same problem, in my case it was handcent and its new exclusive mode that disables the phones own sms and mms messaging, you need to disable that mode and then your visual voicemail will work just fine.
    Sambo41 likes this.
    06-27-2011 09:39 AM
  3. darkborne's Avatar
    That took care of it.

    Thanks
    06-27-2011 09:42 AM
  4. MannyZ28's Avatar
    No problem!
    06-27-2011 10:33 AM
  5. Corrosive's Avatar
    How do you disable it? Is it the disable option (First) or is it the both mms/sms option (last). I had it on the bottom one and I was having issues sending MMS picture mail... I am now setting it to the top option (disable) and will try.
    06-27-2011 10:40 AM
  6. fraz's Avatar
    I had the same problem, in my case it was handcent and its new exclusive mode that disables the phones own sms and mms messaging, you need to disable that mode and then your visual voicemail will work just fine.
    Cant seem to find out how to disable the exclusive mode. Anyway you can point me in the right direction in Handcent? Thanks!
    06-27-2011 10:44 AM
  7. MannyZ28's Avatar
    In handcent when you are on the main screen showing all your previous texting conversations, hit the android menu button, then click on settings, now pick application settings, from there click on "default messaging application" and choose disable.

    While I had this function enabled for both mms and sms, I noticed that the stock messaging application was still receiving the same messages so the option seems pretty useless. I keep it on disabled, tell the stock messaging app to not notify me for anything and have no problems with either sms or mms messages.

    Hope this helps.
    06-27-2011 02:39 PM
  8. Corrosive's Avatar
    Ok. I had it backwards. I thought disable was to disable that feature and I thought both was to have both working... I set it to disable, hopefully this means that I can now send picture mail without having to open the stock app. Thanks!
    06-27-2011 04:13 PM
  9. nelise2's Avatar
    I have the same problem but with Go SMS Pro, can anyone help me with that? Thanks!
    TheFranchise216 likes this.
    07-03-2011 11:08 AM
  10. charlesmvaron's Avatar
    I am also having problems with visual voicemail. However, when I went into application settings and under "default messaging application" I had it set to all(sms and mms) and just changed to to disable. However, now I am getting notifications with both messaging applications (handcent and stock messaging application). Not sure if it enabled visual voicemail now but how do I disable the stock messaging application now?

    Ok I went into stock messaging app and unchecked notifications. I also was having problems sending picture mail (I kept getting the little circle thing to the left of the picture spinning as it was processing sending the picture. It would literally take forever to send the picture or it wouldn't send and I had to cancel the message and retry). I hope this fixes both the visual voicemail and the picture mail issues.
    07-04-2011 12:54 AM
  11. charlesmvaron's Avatar
    I am also having problems with visual voicemail. However, when I went into application settings and under "default messaging application" I had it set to all(sms and mms) and just changed to to disable. However, now I am getting notifications with both messaging applications (handcent and stock messaging application). Not sure if it enabled visual voicemail now but how do I disable the stock messaging application now?

    Ok I went into stock messaging app and unchecked notifications. I also was having problems sending picture mail (I kept getting the little circle thing to the left of the picture spinning as it was processing sending the picture. It would literally take forever to send the picture or it wouldn't send and I had to cancel the message and retry). I hope this fixes both the visual voicemail and the picture mail issues.
    Ok, so by unchecking "received notification" I don't get a notification in the status bar. But if you look under all apps and see the stock messaging app it will have a little green number to show how many unread messages you have. Is there a way to turn that notification off as well? Thanks.
    07-04-2011 01:15 AM
  12. TheFranchise216's Avatar
    I have the same problem but with Go SMS Pro, can anyone help me with that? Thanks!
    I am as well. I've had this issue before but I don't remember how I fixed it.
    07-06-2011 10:32 AM
  13. codylainsworth#AC's Avatar
    I have the same problem. I have done everything to remedy it to no avail. Any help would be great.

    Sent from my PG06100 using Tapatalk
    07-06-2011 01:07 PM
  14. sambao21's Avatar
    does visual voicemail work with google voice?
    07-06-2011 01:44 PM
  15. androidtechrep's Avatar
    If you guys are getting the text message saying something about "call this number to check your voicemail....." then the fix I am aware of is either one of two methods if it has been determined that the problem is not caused by an app and the internet on the phone is working. #1 Go to the Visual Voicemail app and tap Menu > Compose > Record (record for about 15 seconds) > Stop > Send. You will send to activate@vvm.sprint.com. And that is (v v m not wm). You may have to powercycle after this. If that doesn't work #2 Hard reset your phone and perform #1 afterward. Hope this helps
    07-08-2011 02:54 AM
  16. fbird18's Avatar
    I'm having this issue as well. It started with my Evo 4G around the time i got Go SMS Pro. Dealt with the problem then by using Youmail. But now with my Evo 3D and using the stock messaging app, the visual voicemail still isn't working. I've tried the sending a voicemail to that link and still not working. Any ideas? I haven't downloaded any launchers or SMS apps on my 3D yet.
    07-08-2011 06:27 AM
  17. androidtechrep's Avatar
    I'm having this issue as well. It started with my Evo 4G around the time i got Go SMS Pro. Dealt with the problem then by using Youmail. But now with my Evo 3D and using the stock messaging app, the visual voicemail still isn't working. I've tried the sending a voicemail to that link and still not working. Any ideas? I haven't downloaded any launchers or SMS apps on my 3D yet.
    You have to hard reset your phone and then send the activation message. This should, and I stress should, work. I know this isnt going to hold much water but I do Android tech support for Sprint and this is the only known fix at this time, until a software upgrade is released to fix it permanently. But that is in the hands of HTC and Google.
    07-08-2011 02:24 PM
  18. pprichar's Avatar
    So if I use my Google voice number for all my calls and not my sprint number is it possible to use the vvm app? Right now I got texts going to the messaging app and voicemails I have to check in the Google voice app. Would love to use just the vvm app!
    07-08-2011 05:49 PM
  19. androidtechrep's Avatar
    In all honesty Google Voice is causing so many problems because people don't know how to configure the settings correctly (eg. I am not getting any calls or text messages). If when you get a voicemail, and your visual voicemail is working, you have to go to the Google Voice App to check them I would have to say no. However, I will test it tomorrow on some work phones and get back with you. Ok I just combed Google voice and it says that if you are using GVoice "... will replace your Sprint voicemail with Google voicemail. Any voicemail messages currently on your Sprint phone will be deleted". So based on this I still say you will have to check vm through the GVoice app but again I will test it tomorrow.
    07-09-2011 02:30 AM
  20. androidtechrep's Avatar
    Sorry it took so long to get back with you but my previous assumption was correct. If you have google voice activated you cannot use Sprint VisualVoiceMail. The voicemails are routed through GoogleVoice so they never make it to the Sprint VisualVoiceMail system.
    07-15-2011 09:39 PM
  21. Exxar1's Avatar
    I have an HTC EVO, bought it in January of 2011. Not rooted. I've never had any issue with Visual Voicemail until now. After a friend of mine said that she had left a voicemail, yet I had never received a notification from VVM, I dialed 1 and lo, I had 6 unheard messages, dating back two weeks! I discovered that my VVM is not giving me any notifications. After scouring online forums like this one, I tried all the recommendations but nothing has fixed this issue. I uninstalled my Handcent SMS app, I sent a recording to the activate@vvm.sprint.com, I cleared out the data in the "Manage Applications" menu for VVM, and I rebooted my phone at least a dozen times. Nothing has worked. I am SO FRUSTRATED by this issue, and it doesn't appear from the other posts on these forums that calling Sprint tech support will do any good.

    How do I fix this??????
    04-17-2012 01:31 PM
LINK TO POST COPIED TO CLIPBOARD