Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  
    w5cyc's Avatar

    Posts
    144 Posts
    Global Posts
    166 Global Posts

    Default superSU problems

    I rooted last night using RegawMOD, which went pretty well. That process installed superSU, but when I try to use Titanium Backup, it says the device isn't rooted. The SU app itself says it needs to update binaries, but each time, the installation fails. So far, I have tried a fresh install from the market, clearing data and preferences, etc. I've even downloaded the .zip from XDA, but when I reboot into TWRP, I can't seem to find the superSU file to flash from recovery. Anyone have any ideas for how to get this to work?
  2. #2  
    benny3's Avatar
    Flashoholic!!

    Posts
    1,541 Posts
    ROM
    Bad Boyz Rom

    Default Re: superSU problems

    Quote Originally Posted by w5cyc View Post
    I rooted last night using RegawMOD, which went pretty well. That process installed superSU, but when I try to use Titanium Backup, it says the device isn't rooted. The SU app itself says it needs to update binaries, but each time, the installation fails. So far, I have tried a fresh install from the market, clearing data and preferences, etc. I've even downloaded the .zip from XDA, but when I reboot into TWRP, I can't seem to find the superSU file to flash from recovery. Anyone have any ideas for how to get this to work?
    Have you checked both external and internal sdcards in recovery ?
    Another option is to flash a stock rooted rom
    Last edited by benny3; 01-24-2013 at 03:00 PM.



  3. Thread Author  Thread Author    #3  
    w5cyc's Avatar

    Posts
    144 Posts
    Global Posts
    166 Global Posts

    Default Re: superSU problems

    Well, eventually TWRP was able to find the zip file. Unfortunately, flashing it didn't solve the problem. So I tried the second option, which was to flash Cyanogen10, which I planned to do anyway. The zip installed just fine, or so said the phone. But on reboot, all I could get to was the boot-up blue Cyanogen circle and the rom wouldn't boot even after 15 minutes of grinding at startup. Tried it twice.

    So I have this rooted phone, except I can't run root apps on it or flash custom roms. Other than that.....
  4. Thread Author  Thread Author    #4  
    w5cyc's Avatar

    Posts
    144 Posts
    Global Posts
    166 Global Posts

    Default Re: superSU problems

    Happy dance? Just for grins, I decided to try to flast MeanBean. And it worked! So I have a custom rom. And My Backup Pro asked for root access and got it, and is now restoring my apps and stuff. When that's done, I'll see if the other root apps work. Crossing my phalanges!
  5. #5  
    benny3's Avatar
    Flashoholic!!

    Posts
    1,541 Posts
    ROM
    Bad Boyz Rom

    Default Re: superSU problems

    Quote Originally Posted by w5cyc View Post
    Happy dance? Just for grins, I decided to try to flast MeanBean. And it worked! So I have a custom rom. And My Backup Pro asked for root access and got it, and is now restoring my apps and stuff. When that's done, I'll see if the other root apps work. Crossing my phalanges!
    Great! glad you got it. Any custom rom will have superuser and busybox baked in so as long as you stay with a custom or a stock rooted rom you should not have to worry about root.
    When you flash a rom for the first time go to the superuser app and open it cuz sometimes it will come up with a box and say it needs to install the binary and if you dont it may act as if you dont have root.



  6. #6  
    mstrblueskys's Avatar

    Posts
    449 Posts
    Global Posts
    623 Global Posts
    ROM
    MeanROM

    Default Re: superSU problems

    I know what happened to me was that SuperSU needed to update its scripts. Make sure you open SuperSU to do this before expecting to grant anything root access.

    MeanBean JUST updated SuperSU - MikyXDA does a great job with updates.
  7. #7  

    Default Re: superSU problems

    I know this is a old thread but I just resolved (or better stated bypassed) a issue with a Swype keyboard app not retaining default status after a restart by uninstalling Swype and then using Titanium to restore it. It seems that android play store paid apps install in a special area that is not accessible at boot with Android 4.1.2. This is to be fixed with 4.2 the best date I've heard is October-November timeframe. My thought is maybe SuperSu is maybe subject to the same bug? Any expert opinion on this?

Similar Threads

  1. Text messaging problem with wifi on
    By Anubis in forum HTC Hero
    Replies: 8
    Last Post: 07-10-2013, 04:25 PM
  2. problems with camera and battery
    By piper09 in forum HTC Hero
    Replies: 11
    Last Post: 06-26-2013, 10:02 AM
  3. Sprint Hero has text messaging problem!
    By maxfire05#ac in forum HTC Hero
    Replies: 10
    Last Post: 10-10-2009, 10:49 AM
  4. FreeRunner cupcake... teething problems
    By Thorney in forum General Help and How To
    Replies: 1
    Last Post: 09-05-2009, 12:41 AM
  5. problem with google sign in: password not valid
    By sonali in forum T-Mobile G1
    Replies: 2
    Last Post: 06-20-2009, 10:39 AM

Posting Permissions

B