Results 1 to 22 of 22
Like Tree3Likes
  • 1 Post By Nasko
  • 2 Post By Anthonicia
  1. Thread Author  Thread Author    #1  

    Default Wi-Fi dropping solution found

    I think i found what causes wifi to drop and reconnect all the time. As most of you know turning on best wifi kills the battery. But if you leave it off, and choose one of the frequencies 2.5ghz or 5ghz, wifi is super stable and also no dropping. I figured this out about an hour ago and don't have an app to test batrery, but i can already tell its better than having best wifi turned on. Hope this helps. 5ghz is faster but with shorter range. 2.5ghz is the oposite.
    Thanked by 3:
    crxssi likes this.
  2. #2  

    Default Re: Wi-Fi dropping solution found

    I did the same thing. Switched to 5 and it has not dropped once. Good stuff.
  3. #3  

    Default

    +1 thanks for info, I also changed setting to see if I notice anything, even though I had not experienced any multi taking issue for the first week of using the Evo4GLTE.

    sent from my Evo4LTE
  4. Thread Author  Thread Author    #4  

    Default Re: Wi-Fi dropping solution found

    No problem. I wish htc chose one frequency by default. I am sure some people returned their phones due to this setting.I know i was thinking about it.
  5. #5  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    I tried changing to both 2.5 and 5 last night at work. It stopped dropping in and out for a few minutes but then started dropping in and out again.

    And it's not something silly like being too far away.

    Sent from OG EVO LTE with Android Central Forums
    Sailing the Amazon river with Jacques Cousteau looking for my EVO LTE.
  6. #6  
    darkfire's Avatar

    Posts
    13 Posts
    Global Posts
    31 Global Posts

    Default Re: Wi-Fi dropping solution found

    Switching to 2.5GHz solved for me - thank you!
  7. #7  
    Enderend's Avatar

    Posts
    29 Posts
    Global Posts
    41 Global Posts

    Default

    Switched to 2.4. No change yet. Glad to hear that this is a known issue. I was about to send the phone out for repairs. Hopefully HTC puts out a fix soon. They are pretty good about that. (Are you listening, Samsung?)

    Sent from my EVO LTE
  8. #8  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    I'm thinking it has something to do with the way routers switch frequencies whether password protected or not. Going to try and troubleshoot this issue more tonight at work.

    Apps like WiFi manager give u some more advanced controls and monitoring interfaces. Hopefully come up with a fix for myself and others that switching to 2.5 doesn't work for.

    Sent from OG EVO LTE with Android Central Forums
    Sailing the Amazon river with Jacques Cousteau looking for my EVO LTE.
  9. Thread Author  Thread Author    #9  

    Default Re: Wi-Fi dropping solution found

    I want to confirn that 2.5ghz is scetchy for me too. Doesnt drop as often, but it does. On 5ghz i am really good.
  10. #10  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    Ok, I found another fix or 2. This has seemed to fix my WiFi dropping issue.

    First, it doesn't matter if set on auto or 2.4 GHz. I didn't try 5 GHz since I don't use it. I downloaded WiFi manager from google play store and connected via that app. WiFi isn't dropping at all now.

    There's something about these stock WiFi radios or software on HTC for me. They don't seem to scan correctly. Had problems on my old EVO that wouldn't see my network. WiFi manager did though.

    Try that first because it seems to have done the trick for me. If you are still having issues with WiFi it could possibly be interference from other networks. I also downloaded WiFi analyzer which is a very good app u should get regardless. It has a tool that checks your network and reccomends the best channel to use related to the other traffic in your vicinity. You could change your router settings based on their reccomendations to hopefully alleviate congestion issues.

    Sorry for the long post, but I hope this helps everyone else that's still having problems with WiFi dropping.

    Sent from OG EVO LTE with Android Central Forums
    Sailing the Amazon river with Jacques Cousteau looking for my EVO LTE.
    Thanked by 2:
    bc2khankbear 
    hankbear and Jackson Galaxy like this.
  11. #11  
    mawilson82's Avatar

    Posts
    47 Posts
    Global Posts
    48 Global Posts
    ROM
    Stock

    Default Re: Wi-Fi dropping solution found

    Quote Originally Posted by Anthonicia View Post
    Ok, I found another fix or 2. This has seemed to fix my WiFi dropping issue.

    First, it doesn't matter if set on auto or 2.4 GHz. I didn't try 5 GHz since I don't use it. I downloaded WiFi manager from google play store and connected via that app. WiFi isn't dropping at all now.

    There's something about these stock WiFi radios or software on HTC for me. They don't seem to scan correctly. Had problems on my old EVO that wouldn't see my network. WiFi manager did though.

    Try that first because it seems to have done the trick for me. If you are still having issues with WiFi it could possibly be interference from other networks. I also downloaded WiFi analyzer which is a very good app u should get regardless. It has a tool that checks your network and reccomends the best channel to use related to the other traffic in your vicinity. You could change your router settings based on their reccomendations to hopefully alleviate congestion issues.

    Sorry for the long post, but I hope this helps everyone else that's still having problems with WiFi dropping.

    Sent from OG EVO LTE with Android Central Forums
    Had the same issue here. It drained my battery significantly (under Android OS) because it kept switching from WiFi to 3g all night long. I used WiFi Analyzer and found another network using the same channel. I switched channels and have not noticed it dropping anymore.
    Thanked by:
  12. #12  

    Default Re: Wi-Fi dropping solution found

    Since I have started using wifi manager per your suggestion this morning, I have not dropped at all. I hope that the real problem is fixed with an update, but this is the best solution so far. Thanks for the heads up.
  13. #13  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    Glad I could help you guys by helping myself. Don't know why the other person that tried it is getting the thanks, but to each their own I guess.

    Sent from OG EVO LTE with Android Central Forums
    Thanked by 2:
    dyphxerrbin 
  14. #14  
    errbin's Avatar

    Posts
    195 Posts
    Global Posts
    451 Global Posts

    Default

    Downloaded the WiFi manager and switch to 2.4ghz worked great thanks guys

    sent from a EVO that survived a Apple attack... thug life
  15. #15  

    Default

    How you change the 2.5 to 5
  16. #16  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    Quote Originally Posted by luisdea76 View Post
    How you change the 2.5 to 5
    Go to settings-WiFi-menu-advanced-change frequency settings

    Sent from OG EVO LTE with Android Central Forums
  17. #17  
    errbin's Avatar

    Posts
    195 Posts
    Global Posts
    451 Global Posts

    Default

    Quote Originally Posted by luisdea76 View Post
    How you change the 2.5 to 5
    settings
    WiFi
    Menu
    Advanced
    WiFi frequency

    sent from a EVO that survived a Apple attack... thug life
  18. #18  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    Beat u by a few seconds, lol

    Sent from OG EVO LTE with Android Central Forums
  19. #19  
    errbin's Avatar

    Posts
    195 Posts
    Global Posts
    451 Global Posts

    Default

    : p



    sent from a EVO that survived a Apple attack... thug life
  20. #20  

    Default

    Quote Originally Posted by Anthonicia View Post
    Go to settings-WiFi-menu-advanced-change frequency settings

    Sent from OG EVO LTE with Android Central Forums
    My Android version is 2.3.5
    It dosen't show those settings
  21. #21  
    Anthonicia's Avatar

    Posts
    189 Posts
    ROM
    tommytomato evo classic

    Default

    Quote Originally Posted by luisdea76 View Post
    My Android version is 2.3.5
    It dosen't show those settings
    This is a EVO 4G LTE thread. Do u have a regular EVO 4g? Something else maybe? The option may not be available on your phone. Unless u rooted your phone and went to version 2.3.5, idk what u did. Don't think they have many roms up let alone that one.

    I can try and help u but u might be better off finding your phone and posting in that section.

    Sent from OG EVO LTE with Android Central Forums
  22. #22  

    Default Re: Wi-Fi dropping solution found

    Yes, this is good. WiFi Manager is very good.
    So is WiFi Analyzer.

    I found that on ICS 4.0.3 it only search for channels with 2.4 GHz. Yet, on Jelly Bean 4.1.1 it searches both 2.4 and 5 GHz.
    If you have wi fi dropping issue on your smart phone, please read below.

    Hi, Mine is Galaxy Note 2 i317 with Jelly Bean 4.1.1. I did have similar issue. I took two smart phones to Target, one is ICS 4.0.3 and the Note 2 is 4.1.1.
    The 4.0.3 never has any issues with wi fi connection. But the Note 2 keeps on dropping the connection. I ran an application wifi analyzer to check the available networks. It turns out that Target has so many routers that are using the same ssid, i.e. "Target Guest Wi-Fi". There are channel 1, 6, 11, etc, as well as many 5Gs. I did an alias for every available connection. Then I pick one of the stronger signal strength 5G and connected to it.
    After that no connection was dropped.

    The point is that you should try to connect to the strongest signal SSID so that the Note 2 won't keep on dropping the weak connection.

    I have no idea why the ICS 4.0.3 can handle better than the 4.1.1 Jelly Bean as far as wifi is concerned.

Posting Permissions

B