Page 2 of 4 FirstFirst 1234 LastLast
Results 26 to 50 of 90
Like Tree15Likes
  1. #26  

    Default

    I thought I saw a fix for wifi sleeping over on XDA the other day. I'll go look for it and post it up when I find it. brb

    EDIT: Here's the thread I was referring to:
    Requires root, and read the whole thing before flashing. It's kinda confusing.

    Anyone want to be a guinea pig and try this out?

    Sent from my EVO using Android Central Forums
    Last edited by kbp08tls; 06-15-2012 at 05:51 PM.
    Thanked by:
    crxssi 
  2. Thread Author  Thread Author    #27  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by kbp08tls View Post
    I thought I saw a fix for wifi sleeping over on XDA the other day. I'll go look for it and post it up when I find it. brb

    EDIT: Here's the thread I was referring to:
    Requires root, and read the whole thing before flashing. It's kinda confusing.

    Anyone want to be a guinea pig and try this out?
    Not me Sounds a bit too scary.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  3. #28  
    rfs830's Avatar

    Posts
    87 Posts
    Global Posts
    109 Global Posts

    Default Re: WiFi disconnects in sleep

    i know on my photon it would do that. I had to change the battery setting to not use power save mode so that the wifi would stay connected.
  4. Thread Author  Thread Author    #29  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by rfs830 View Post
    i know on my photon it would do that. I had to change the battery setting to not use power save mode so that the wifi would stay connected.
    That is quite possible- a friend at work with a Motorola said the same thing. There is no such option (that I can find) on the HTC phones. But none of the other HTC phones have ever acted like this (well, at least not the other two I have had).
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  5. #30  

    Default

    Did you go into settings you can change wifi not sleep on charge.

    Sent from my EVO using Android Central Forums
  6. #31  

    Default

    I got my EVO LTE yesterday and I have not have my WiFi discenect at all

    Sent from my EVO using Tapatalk 2
    Thanked by:
  7. Thread Author  Thread Author    #32  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by sandman132 View Post
    Did you go into settings you can change wifi not sleep on charge
    I am not aware of any such option. There is an option under Display called "Stay awake: screen will never sleep while charging." But that is not the problem reported in this thread, we are talking about WiFi disconnecting during sleep, not during awake. I have no problems with WiFi staying connected when the phone is awake (screen on) or even for short ( minutes to perhaps up to an hour) sleep periods.
    Last edited by crxssi; 06-16-2012 at 08:05 AM.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  8. Thread Author  Thread Author    #33  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by usguyver View Post
    I got my EVO LTE yesterday and I have not have my WiFi disconnect at all
    Not sure I believe you... You are saying that you left the phone asleep for hours, and when you turned it on and immediately looked at the top of the screen, you showed a WiFi icon that was on, solid?
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  9. #34  

    Default

    Go to settings, wifi, menu, advanced settings. Here is your wifi settings for when device is asleep.

    Sent from my EVO using Android Central Forums
  10. Thread Author  Thread Author    #35  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by sandman132 View Post
    Go to settings, wifi, menu, advanced settings. Here is your wifi settings for when device is asleep.
    Please go back and reread the first posting. Especially the part that says:

    * The default setting of "Keep W-iFi on during sleep" is active (set to "always") and I have never changed it.
    * All WiFi settings are set to stock/defaults.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
    Zookeeper63 likes this.
  11. #36  

    Default

    Quote Originally Posted by crxssi View Post
    Please go back and reread the first posting. Especially the part that says:

    * The default setting of "Keep W-iFi on during sleep" is active (set to "always") and I have never changed it.
    * All WiFi settings are set to stock/defaults.
    Yep, I see the same behavior. Somehow either that setting is not setting what it is supposed to be or it is being ignored. Either way it is a bug.
  12. #37  

    Default

    Try factory reset your device maybe and see if it fixes it. I've never had any issues with mine.

    Sent from my EVO using Android Central Forums
  13. #38  
    Uncle Louie's Avatar

    Posts
    1,023 Posts
    Global Posts
    1,031 Global Posts
    ROM
    SwampMonster V1.0!!!!!

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by usguyver View Post
    I got my EVO LTE yesterday and I have not have my WiFi discenect at all
    It reconnects so quickly that you might not be able to see it.

    How I found out that mine was doing it was at work; every two hours or when you disconnect from my employers wifi, you need to sign in to reconnect. Every time I woke up my EVO, I was having to sign in again.
  14. #39  

    Default

    Could that be your employer security settings?

    Sent from my EVO using Android Central Forums
  15. #40  

    Default

    Yea it was still solild and I think some of you may have a bad WiFi radio

    Sent from my EVO using Tapatalk 2
  16. #41  

    Default

    Quote Originally Posted by Uncle Louie View Post
    It reconnects so quickly that you might not be able to see it.

    How I found out that mine was doing it was at work; every two hours or when you disconnect from my employers wifi, you need to sign in to reconnect. Every time I woke up my EVO, I was having to sign in again.
    That could be the security setting of the WiFi I do not have to reconet to my WiFi that is how I know it is not disconnecting

    Sent from my EVO using Tapatalk 2
  17. #42  
    gmtom1's Avatar

    Posts
    159 Posts
    Global Posts
    163 Global Posts

    Default Re: WiFi disconnects in sleep

    I was having all the same problems reported in the earlier threads with the Wifi disconnecting when the phone would sleep, but I think I found a solution that works for me, which was to change the wifi band/frequency selection under the Advanced Wifi menu from "Auto" to 2.4 Ghz only. Now my phone never disconnects during sleep, based on downloading podcasts & Play store updates (which would be interrupted before once I put the phone down)

    I currently have a dual-band router at home (airport extreme) with both bands (2.4 & 5 Ghz) running, and my office uses an older single-band G router on 2.4 Ghz. I noticed that the disconnecting would only occur at home, and not at my office, so my guess was that the phone was disconnecting somehow when it switched between frequencies at home.
    A software bug is somehow preventing it from re-establishing the connection properly if it switches frequencies until the phone "wakes" again.

    Not sure if this is the real solution, or just unique to me & my setup, but for those of you with dual-band routers, give it a try. Just pick one of the frequencies after considering all the locations you use wifi, since you will not be able to connect if you pick 5 Ghz and you go someplace that only has an older 2.4 Ghz router.

    I still think this is a bug though, since the phone should be able to automatically switch between frequencies and re-establish connections even during sleep.
  18. #43  
    digmys's Avatar

    Posts
    391 Posts
    Global Posts
    400 Global Posts
    ROM
    Stock/CyanogenMod7

    Default Re: WiFi disconnects in sleep

    This fixes the issue.

  19. #44  

    Default

    Quote Originally Posted by modplan View Post
    This fixes the issue.

    Awesome find.

    Sent from my EVO using Android Central Forums
  20. #45  
    Uncle Louie's Avatar

    Posts
    1,023 Posts
    Global Posts
    1,031 Global Posts
    ROM
    SwampMonster V1.0!!!!!

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by usguyver View Post
    That could be the security setting of the WiFi I do not have to reconet to my WiFi that is how I know it is not disconnecting

    Sent from my EVO using Tapatalk 2
    No, as every other phone that I have used at work (as well as fellow employees) does not have this problem. I have used an OG EVO, Epic 4g, Epic Touch. A coworker had a Thunderbolt, and recently upgraded to a Razr Maxx, and doesn't have this issue.

    It does it to me at home too, I just wasn't looking for the signs of it until the issues at work. I don't really do a lot of heavy downloading with my phone; but I know that my battery life, while not horrible, would be quite a bit better if wifi wouldn't disconnect why sleeping since my cell signal isn't that great at home.
  21. #46  
    Uncle Louie's Avatar

    Posts
    1,023 Posts
    Global Posts
    1,031 Global Posts
    ROM
    SwampMonster V1.0!!!!!

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by modplan View Post
    This fixes the issue.

    Nice find!
  22. Thread Author  Thread Author    #47  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by usguyver View Post
    Yea it was still solild and I think some of you may have a bad WiFi radio
    I doubt my radio is bad. When it is on, it works great. Besides, there would be many people with bad radios if this were the case, because lots of people have confirmed this behavior now.

    Quote Originally Posted by usguyver View Post
    That could be the security setting of the WiFi I do not have to reconet to my WiFi that is how I know it is not disconnecting
    ? I use security at home (WEP128) and no security at work. It behaves exactly the same on both- it will disconnect after long sleep periods and reconnect in a few to several seconds on either when woken up.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  23. Thread Author  Thread Author    #48  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by gmtom1 View Post
    I was having all the same problems reported in the earlier threads with the Wifi disconnecting when the phone would sleep, but I think I found a solution that works for me, which was to change the wifi band/frequency selection under the Advanced Wifi menu from "Auto" to 2.4 Ghz only. Now my phone never disconnects during sleep, based on downloading podcasts & Play store updates (which would be interrupted before once I put the phone down)

    I currently have a dual-band router at home (airport extreme) with both bands (2.4 & 5 Ghz) running, and my office uses an older single-band G router on 2.4 Ghz.
    I don't think this is it either. I have a single band router and work and at home.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  24. Thread Author  Thread Author    #49  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: WiFi disconnects in sleep

    Quote Originally Posted by modplan View Post
    This fixes the issue.

    Wow I think you might have just hit something interesting!

    * How the hell did you find this?
    * If this is so well known that there is even an app for it, why did the HTC support staff and "engineering" not say anything?
    * What is so "Smart" about "Smartsync?"
    * What troubles me the most is that the description does NOT match what the phone does. Mine does not disconnect just between 00:00 and 07:00am.

    I will try it and see what happens. Here is an xda link:
    Last edited by crxssi; 06-16-2012 at 04:18 PM.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  25. #50  

    Default Re: WiFi disconnects in sleep

    You have to go to the Power Saver settings.
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

B