Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 51
  1. Thread Author  Thread Author    #1  

    Default "Maps" Using 20% Battery? No matter what!?!

    After 2 weeks with my EVOLTE, I've noticed "Maps" is using roughly 20% of my battery on a daily basis. "Screen" is obviously using the most battery, but everyday, "Maps" is ALWAYS number 2 at around 20% unless I go out of my way to get a game or video to use up more battery. I've gone days, where I've not even opened up google maps and it's still there. I've gone days where I've had the GPS off and it's still there using up that roughly 20% of my battery. Anyone else have this? Is it normal or is there something I could try?

    I'm not complaining about the battery life. I've found it to be amazing. If I could be getting more out of the battery though because the "Maps" app is not behaving correctly or something, I certainly want to do that.
  2. #2  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Hm. You say you've gone days without using Maps? Have you reset your battery stats?
  3. #3  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Funny you mention this... just noticed the same thing on my phone yesterday when the battery dropped more than normal. I haven't even used maps that I can recall.
  4. #4  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    I think Maps gets listed as used if an app uses GPS or location services. (determining location via wifi) I would look for apps that constantly try to monitor your location if usage is that high and you are trying to improve battery life.
  5. #5  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    I use an app that uses location services every 2 days when I go biking. My battery usage shows that app but not "maps" at all.
  6. #6  
    Shadnic's Avatar

    Posts
    340 Posts
    Global Posts
    480 Global Posts
    ROM
    MeanROM

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    If your GPS is on then it'll show Maps in your battery drainage I'm pretty sure. GPS will eat that much battery life.
  7. #7  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    My GPS is on all the time I use cardio trainer, and maps doesn't show up at all in my battery drainage.
  8. Thread Author  Thread Author    #8  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by Shadnic View Post
    If your GPS is on then it'll show Maps in your battery drainage I'm pretty sure. GPS will eat that much battery life.

    No, this happens with GPS on and with it off as well. I'm going to have to look through the processes and see which ones are running under the "maps" title.
  9. #9  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by flyhighx View Post
    After 2 weeks with my EVOLTE, I've noticed "Maps" is using roughly 20% of my battery on a daily basis. "Screen" is obviously using the most battery, but everyday, "Maps" is ALWAYS number 2 at around 20% unless I go out of my way to get a game or video to use up more battery. I've gone days, where I've not even opened up google maps and it's still there. I've gone days where I've had the GPS off and it's still there using up that roughly 20% of my battery. Anyone else have this? Is it normal or is there something I could try?

    I'm not complaining about the battery life. I've found it to be amazing. If I could be getting more out of the battery though because the "Maps" app is not behaving correctly or something, I certainly want to do that.
    I hate to sound like Captain Obvious... but have you rebooted yet? If not, turn off "Fastboot" option and try a full reboot. Who knows, it could be something hung/stuck/freaky. Always a good first thing to try before other troubleshooting.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
  10. Thread Author  Thread Author    #10  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Thanks. Hey, you never know. I do have fastboot off, and I did do a reset. Still having the "maps" using up big portions of my battery. GPS is off but google location service using wifi/mobile network is on. I understand that I'm allowing my phone to use "maps" to determine a location for various apps and that uses battery. I'm just surprised that having that service active is using around 20% of my battery to run in the background for location services. Again, it's not like I'm actively using google maps or using lattitude to update my position. I'm not using any social media where it's checking me in. To the best of my knowledge, I don't have any apps running that would require a location. Even weather is set to manually update.

    I'm going to experiment and turn ALL location services off, reboot, and report back tomorrow. If "maps" is still using 20% battery without having any location services running, I'll be a bit more worried.
  11. #11  
    doomstang's Avatar

    Posts
    222 Posts
    ROM
    Viper ROM

    Default

    I have seen Maps in there way too often too. I removed the Sense flip clock and went with a Beautiful Widget that allowed me to remove auto location (tried and tried and couldn't get sense flip clock to disable the Auto locate regardless of disabling that setting). I thought that helped but I'm seeing maps again. I keep disabling more and more options in various apps trying to pinpoint it but I haven't had any real luck yet.

    Sent from my Evo 4G LTE using Tapatalk
  12. #12  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    My maps usage was out of control when I had Beautiful Widgets and didn't realize the default weather setting was set to 15 minutes. Changed it to 1 hour and Maps dropped quite a bit.
  13. Thread Author  Thread Author    #13  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Update:

    After spending a whole day yesterday with all location services turned off, and not opening up google maps at all, "Maps" finally did not show up as using any battery. Today, I re-enabled location services and GPS and low and behold, "Maps" is using battery, but more in line with what should be expected for a background service. I'm showing 2%, a far cry from the 20% from earlier. I can only recommend that anyone with this issue turn off GPS, and Google Location Service, re-boot, and then re-enable those services.
  14. #14  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    I noticed my battery attributed a higher usage to maps yesterday when I didn't actually use the Maps app at all. I did mess around with the Weather Channel app (radar) a lot so I'm thinking that was the culprit for me.
  15. #15  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    After going through the same problem for quite some time, I believe I've finally tracked the cause of the problem to the new Google Now that is using location services to target the "cards" to your notifications such as traffic alerts. In Settings --> Location Service, try toggling off the Google search location services and see if this fixes the issue. This would explain why I didn't have the same issue before the Jelly Bean update.
  16. #16  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by Anthony Atkinson View Post
    After going through the same problem for quite some time, I believe I've finally tracked the cause of the problem to the new Google Now that is using location services to target the "cards" to your notifications such as traffic alerts. In Settings --> Location Service, try toggling off the Google search location services and see if this fixes the issue. This would explain why I didn't have the same issue before the Jelly Bean update.
    Several people have already reported this as a possible fix (that it worked for them). My solution is that I never turned on Google [Spy] Now
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
  17. #17  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    it's true, Google now uses a lot and so does groupon app if you have it.
  18. #18  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    I had the same issue, its not Google now, its caused by "location History" in Google maps settings, uncheck it, your battery life should improve...

    Sent from my EVO using Android Central Forums
  19. #19  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by FaisDogg View Post
    I had the same issue, its not Google now, its caused by "location History" in Google maps settings, uncheck it, your battery life should improve...
    I am guessing that option only appears if you have Google [spy] Now activated. I have it completely off and have no such option in Google maps.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
  20. #20  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    I had Google now turned off and I still had location history as a map option. It is now off. We'll see what happens.
  21. #21  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by Saneless View Post
    I had Google now turned off and I still had location history as a map option. It is now off. We'll see what happens.
    I just checked for a THIRD time. When I go into google maps and then the settings, there is an option called "Location settings". When I choose that it takes a while to load and then says "Latitude. Location sharing is not turned on". There is nothing anywhere about "Location history". So I searched elsewhere, even on the main settings for the phone. Still could find nothing labeled "Location history" anywhere.

    I would love to know what you/others are referring to, exactly...
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
  22. #22  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    It's right there, near the bottom...

    Sent from my EVO using Android Central Forums
    Attached Thumbnails Attached Thumbnails "Maps" Using 20% Battery? No matter what!?!-uploadfromtaptalk1356671306193.jpg  
  23. #23  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by Mikey47 View Post
    It's right there, near the bottom...
    That doesn't completely address the issue. What app? What menu?
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
  24. #24  

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by crxssi View Post
    That doesn't completely address the issue. What app? What menu?
    Sorry. This is Google Maps - Settings - Location settings.

    If your Google Maps is taking you somewhere else with that menu that sounds like that might indicate the problem.

    Sent from my EVO using Android Central Forums
  25. #25  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,144 Posts
    Global Posts
    2,463 Global Posts

    Default Re: "Maps" Using 20% Battery? No matter what!?!

    Quote Originally Posted by Mikey47 View Post
    Sorry. This is Google Maps - Settings - Location settings.

    If your Google Maps is taking you somewhere else with that menu that sounds like that might indicate the problem.
    So I am not crazy afterall! When I select "settings" in Google Maps, then choose "Location settings", there are two consecutive popups saying "Loading...." and after a few seconds I get the following screen (see attachment) and there is nothing I can do on that screen, menu does nothing, there is nothing clickable at all. (Note, I removed my name from the screenshot)

    FREAKY????
    Attached Thumbnails Attached Thumbnails "Maps" Using 20% Battery? No matter what!?!-2012-12-28_10-41-20.png  
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5 (T-Mobile), Nexus 10, Evo LTE, Evo 3D, Evo 4G
Page 1 of 3 123 LastLast

Posting Permissions