03-02-2014 12:29 PM
150 ... 23456
tools
  1. Topgonzo's Avatar
    Google navigation works beautifully for me now. Used it a few times with no problems in fact everything seems more stable.

    Sent from my EVO 4G LTE
    02-01-2013 05:34 PM
  2. ay's Avatar
    A workaround was posted on another discussion thread, it worked for me... just switch to 2D mode by clicking on the compass symbol. Good luck!
    I much more prefer the 3D mode than the 2D mode, but this worked for me! Thanks!
    02-03-2013 02:29 PM
  3. marksr's Avatar
    Finally got a chance to use nav for first time since last week's update- strangely enough "maps" crashes, but Nav still runs, i.e. the program closes with a "maps has stopped running" error report, but voice turn by turn still continues as if nothing happened.
    By the way, I also have an S3 on Verizon running JB- google nav works fine (as does Waze, Telenav etc on my Evo4GLTE. makes no sense to this layman).
    Mark

    Oh BTW, workaround mentioned above doesn't help me, I'm already in 2D.
    02-04-2013 10:54 AM
  4. Cattails_r_Edible's Avatar
    Work around didn't work for me either! I've disabled maps and I'm using telenav now, it works perfectly!

    Remember what the doormouse said, feed your head!
    02-05-2013 12:16 AM
  5. jljlj's Avatar
    Switch from 3d to 2d worked for me...Strange that it varies so much from phone to phone.

    Thanks for the help.
    02-08-2013 06:42 AM
  6. zqual's Avatar
    NEW UPDATE TO GOOGLE MAPS!! Grab it today before its GONE! keep your fingers crossed that its a fix! Sound off results.
    ay likes this.
    02-20-2013 04:38 PM
  7. Cattails_r_Edible's Avatar
    Someone on the market review page said it fixed their problem!

    Remember what the doormouse said, feed your head!
    02-20-2013 04:47 PM
  8. boo5ted's Avatar
    the update didn't fix jack for me.

    TonyLibations and zqual like this.
    02-20-2013 05:04 PM
  9. Jaggrey's Avatar
    Yup, same here.

    Sent from my EVO 4G LTE
    02-20-2013 05:45 PM
  10. Mike Lentsch's Avatar
    Seems to be working after a restart...
    02-20-2013 06:00 PM
  11. ay's Avatar
    Seems to be working after a restart...
    It didn't work for me, but I didn't try restarting. I'll try restarting and report back again tomorrow after driving some more. Thanks for the suggestion of restarting.
    02-20-2013 08:44 PM
  12. ufergus's Avatar
    Didn't fix it for me either

    Sent from my EVO using Tapatalk 2
    02-20-2013 10:29 PM
  13. captain_dl's Avatar
    No luck with the Google update for me either. I was thrilled when I saw there was an update, but bummed when I still got the maps crash.
    02-20-2013 10:43 PM
  14. zqual's Avatar
    Worked fine after update, then got a crash , restarted then seemed to work. Idk man. Lol boo5ted I felt the same way.
    02-21-2013 12:51 AM
  15. boo5ted's Avatar
    I've restarted they phone since the update, been browsing maps and it has not stopped yet. Haven't used nav yet, will update tomorrow with some testing.
    02-21-2013 01:04 AM
  16. ay's Avatar
    I've restarted they phone since the update, been browsing maps and it has not stopped yet. Haven't used nav yet, will update tomorrow with some testing.
    Maps without "navigating" I've never had a problem with. Navigation in 3D is what has been crashing for me (since the update update to JellyBean). I rebooted last night, and tried Navigation again today a couple of times. Each time, Navigation froze up/crashed in 3D, but continues to work in 2D. The update didn't improve anything for me, but at least 2D works. Stinks that I got my hopes up with the update....I guess the wait continues.....
    02-21-2013 03:15 PM
  17. ginglish's Avatar
    Navigation froze up/crashed in 3D, but continues to work in 2D.
    Same here after accepting update to Maps Vs 6.14.3 yesterday. 3D NAV still an issue.
    02-21-2013 04:27 PM
  18. DavidJ726's Avatar
    I actually had my phone swapped out which fixed one problem, but then another problem crept in (mic wouldn't work with speaker phone on) so after a total of 3 or 4 replacement phones over the past 14+ months, the carrier let me swap to a Samsung Galaxy 3. Personally I think the Evo had a better build quality to it, but right now all I want is to stop dealing with hardware/software issues every several months. Hopefully they fare better with the HTC One, but only time will tell.
    02-21-2013 06:14 PM
  19. ginglish's Avatar
    I've been thinking that my 3G is reception is getting weak and have started droping a few calls where I did not use to, so am considering an insurance swap.
    ANYONE have luck with a new phone or refurb not having this Naviagtion Crash problem? If there's a chance, it might tip me over to the swap.
    02-21-2013 07:48 PM
  20. Mike Lentsch's Avatar
    Yep - maps crashed again with nav. Threw me off as it worked for a while after restarting after updating. Damn!!
    02-21-2013 08:26 PM
  21. boo5ted's Avatar
    Yep, using Nav it crashes everytime but not with maps.
    02-21-2013 11:39 PM
  22. pjrake's Avatar
    So still no fix? Mine keeps crashing. Using TeleNav but hate it. At least it's reliable.
    03-06-2013 06:06 PM
  23. Jaggrey's Avatar
    Oddly enough, the 2D trick works fine for me since the last update. It didn't before then. 3D still doesn't tho.

    Sent from my Touchpad Android
    03-06-2013 06:35 PM
  24. Cattails_r_Edible's Avatar
    Since the last maps update the 2d trick works for me too!

    Remember what the doormouse said, feed your head!
    03-07-2013 01:17 PM
  25. k2ldc10's Avatar
    What is the trick for putting navigation into 2d mode? Is this a function only available with JB? I haven't upgraded yet but use navigation a lot and to try it out to see if that would bug me. I didn't see how to go into 2d mode while navigating.
    03-08-2013 07:11 AM
150 ... 23456

Similar Threads

  1. Contacts app crashes after JB update
    By bayou bandit in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 10-02-2012, 08:51 AM
  2. Instant upload not working since JB update
    By dqdude in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 09-27-2012, 10:00 AM
  3. Light Flow working since JB Update?
    By pounder001 in forum Google / Samsung Galaxy Nexus
    Replies: 11
    Last Post: 08-07-2012, 07:34 PM
  4. Some crashes since mini update
    By scratchfwb in forum HTC EVO 4G LTE
    Replies: 4
    Last Post: 07-22-2012, 11:24 PM
  5. Google Nav Crashing on me the last 2 days
    By aruikis78 in forum AT&T ATRIX
    Replies: 4
    Last Post: 06-29-2011, 03:30 AM
LINK TO POST COPIED TO CLIPBOARD