03-02-2014 11:29 AM
150 123 ...
tools
  1. 321contak's Avatar
    Major problem with Google nav. Freezes and crashes since update. Also Google maps is not working very smoothly.
    12-14-2012 01:23 AM
  2. donntiger's Avatar
    I'm getting that too. Thought it was just me
    12-14-2012 03:04 AM
  3. youngusaplaya's Avatar
    Maybe we should start a apps that don't work thread after JB update Engadget isn't being too friendly either

    Sent from my EVO
    12-14-2012 03:21 AM
  4. piizzadude's Avatar
    Did you guys do a wipe on the apps?

    Sent from my X-Band Modem... TY Genesis
    12-14-2012 03:23 AM
  5. estebancam's Avatar
    Uh oh. I wish I would have read this before updating.

    Google Maps and Navigation is the application I use the most, next to music. I use it several times a day. I just moved to a different city, so it has been a life-saver for me.
    12-14-2012 03:24 AM
  6. piizzadude's Avatar
    Clear cache and data on the apps. If that doesn't work you can check out my normal signature for the fix. It's painful but it is the best upgrade path.

    Sent from my X-Band Modem... TY Genesis
    12-14-2012 03:33 AM
  7. donntiger's Avatar
    I have Sygic as a back up for navigation and TeleNav GPS Navigator works well and its free in the play store.
    12-14-2012 03:41 AM
  8. zqual's Avatar
    hopefully this gets fixed soon, Google nav worked so good before this update. I used telenav last night and the free version has ads -_-. each time Google nav crashed, I sent the error report. Hopefully its not overlooked.
    12-15-2012 08:31 AM
  9. 321contak's Avatar
    Did you guys do a wipe on the apps?

    Sent from my X-Band Modem... TY Genesis
    Wiped, Factory Reset. Still crashing. Maybe a google update to the Maps app needed?
    12-15-2012 12:27 PM
  10. Glenn's Avatar
    Have not encountered issue. Used Google Navigation everywhere I went for two days.

    Maybe give Waze a try? It's free, and sometimes have better traffic re-routing than Google Navigation.
    12-15-2012 01:37 PM
  11. zqual's Avatar
    I may have found a fix, I uninstalled google maps and then reinstalled updates to google maps. I did not open maps portion but only navigation. Also, I did not download any maps for offline use as well. I used the navigation last night for a 40 minute ride to my destination and then home and did not crash or freeze once. Also, if you are worrying about loosing bookmarked places, Google saves them so they will come back along with your recent history. Hopefully this will be a solution until Google/HTC come out with an update. O and the Group photo addition in the camera is really cool!
    12-16-2012 02:14 PM
  12. Mikey47's Avatar
    I may have found a fix, I uninstalled google maps and then reinstalled updates to google maps. I did not open maps portion but only navigation. Also, I did not download any maps for offline use as well. I used the navigation last night for a 40 minute ride to my destination and then home and did not crash or freeze once. Also, if you are worrying about loosing bookmarked places, Google saves them so they will come back along with your recent history. Hopefully this will be a solution until Google/HTC come out with an update. O and the Group photo addition in the camera is really cool!
    That happens with a lot of apps on an OS update, but first I've heard of with a Google app. My fingers are crossed for those of you with this issue.
    12-16-2012 03:45 PM
  13. shakerpm's Avatar
    I am having this same issue. Since JB update. It's making me crazy. The S3 (ATT) just keeps searching for the GPS. No navigation. But it gives me a directions list. And can see Traffic. What the hell? I've done everything suggested here except a hard reset.

    Also...my customized windows/screen folders disappeared today. Arggghhhh..
    12-16-2012 05:15 PM
  14. ufergus's Avatar
    I have been experiencing the same thing and I tried a factory reset without success.
    12-17-2012 07:07 AM
  15. ufergus's Avatar
    For those looking for an alternative until Google gets this figured out... Waze works but I would only trust it for major cities. Their maps can be pretty bad if you a travel through an area that doesn't have a good maintainer. I may have to try Telnav again, bah.
    12-17-2012 07:10 AM
  16. AetherJones's Avatar
    For those looking for an alternative until Google gets this figured out... Waze works but I would only trust it for major cities. Their maps can be pretty bad if you a travel through an area that doesn't have a good maintainer. I may have to try Telnav again, bah.
    I never use google nav, but I tried it today and mine freezes also. Doesnt matter to me cuz I'm a Waze guy anyway though.

    Sent from my EVO using Android Central Forums
    12-17-2012 10:46 AM
  17. ufergus's Avatar
    Google just pushed a maps update, let's hope this fixes it.

    Sent from my EVO using Tapatalk 2
    12-17-2012 06:07 PM
  18. xcrico's Avatar
    Yea I have the same problem.
    12-18-2012 01:48 AM
  19. FaisDogg's Avatar
    I used it today quite a lot, no issues here. What made it so much better is that voice commands are way improved, pretty darn accurate. I don't even have to touch my phone now. My car has a 8" display hooked up with HTC Media Link HD, everything is working beautifully. Best part about media link is that it doesn't affect the quality if sound unlike BT A2DP, sense make my car dash look beautiful.

    Sent from my EVO using Android Central Forums
    12-18-2012 03:32 AM
  20. ufergus's Avatar
    Maps update didn't fix it. I still get a crash if starting Google Nav from Maps.
    12-18-2012 08:34 AM
  21. zqual's Avatar
    Yup, still not working after update :-(
    12-18-2012 11:31 AM
  22. 321contak's Avatar
    +1 no work after update.
    Read article today that said Google Maps on IOS better then on Android. I used Google Maps on friends Iphone since the 3 up to the current 5 and google Maps is smoother and seems more polished on IOS. Bums me out as a dedicated Android user.
    12-18-2012 03:06 PM
  23. dagold99's Avatar
    Tried using it a little today. It seemed to work in the "regular Mode view" but I like to use the satellite view and it crashed all the time in Satellite View.
    12-18-2012 06:57 PM
  24. DavidJ726's Avatar
    The Telenav / Maps application continually crashes on me. Prior to the maps update yesterday Navigation crashed every 30 seconds as opposed to crashing every 3 minutes now. You can imagine how frustrated this was for me as I left from KC to Chicago for a honeymoon this past weekend and I had no navigation support. Not that I needed help getting there, or that the phone can actually pick up and lock onto a signal in the sea of concrete and steel superstructures, but there were times I could have used it.

    This really was and still is disappointing, that a major update screwed up like this so badly on a stock (un-rooted) phone.

    I guess I'll try to reset to factory defaults in a day or two... not that I relish the idea of rebuilding the pone from scratch....

    David
    12-18-2012 08:00 PM
  25. AetherJones's Avatar
    The Telenav / Maps application continually crashes on me.

    David
    Which one, Google Nav, or Telenav? Because if Google Nav is the one that youre having problems with then you can try Telenav... I haven't had any problems witb that one or Waze. It's just been the Google Nav thats been useless.

    Sent from my EVO using Android Central Forums
    12-18-2012 10:04 PM
150 123 ...

Similar Threads

  1. Contacts app crashes after JB update
    By bayou bandit in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 10-02-2012, 07:51 AM
  2. Instant upload not working since JB update
    By dqdude in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 09-27-2012, 09:00 AM
  3. Light Flow working since JB Update?
    By pounder001 in forum Google / Samsung Galaxy Nexus
    Replies: 11
    Last Post: 08-07-2012, 06:34 PM
  4. Some crashes since mini update
    By scratchfwb in forum HTC EVO 4G LTE
    Replies: 4
    Last Post: 07-22-2012, 10:24 PM
  5. Google Nav Crashing on me the last 2 days
    By aruikis78 in forum AT&T ATRIX
    Replies: 4
    Last Post: 06-29-2011, 02:30 AM
LINK TO POST COPIED TO CLIPBOARD