1. usadaytrader's Avatar
    Are there any fixes to this problem? I am Evo LTE #4 and all of them have this problem. 3g drops in places OGEvo wouldn't. I could be shopping at Wallys World with no 3g. Its a frequent drop. I am running latest stock ROM and updated PRL and Profile. This is so annoying.
    03-25-2013 12:59 PM
  2. IAmSixNine's Avatar
    The EVO 4G has better reception then the EVO LTE. Check out the FCC databse for that info.
    When the EVO LTE came out, on paper its antennas and radios were not as good as the first EVO.
    So its common that people who have the EVO LTE often have issues where the EVO 4G had decent signal.
    03-25-2013 06:32 PM
  3. SenseMonkey's Avatar
    My 3g in my area has improved significantly over the last year. It's actually usable now lol.. Lte is literally right around the corner for me. I get lte down the street but not my house.. Bummer.. Lol.. Is coming soon tho.. :thumbup:

    Courtesy of My LT3VO
    03-26-2013 10:02 AM
  4. Husker Z's Avatar
    Since the whole "network vision" started rolling out, my data is virtually unusable anymore, it's a joke. I'm in Overland Park, one of the first cities to get the LTE switch flipped and it has seriously gotten worse every week since they started. I get little to no phone or data at my work or home, it really stinks.

    I've been a loyal Sprint customer for 13 years now, but I'm done. I'm going to see what I can do to get out of my contract as they just flat out aren't holding up their end. My phone, unless on wifi, is a glorified paperweight most of the time.
    BlackedOutLT1 likes this.
    03-29-2013 12:27 PM
  5. IAmSixNine's Avatar
    Me to. Went with TMO after 11+ years of being loyal to Sprint.
    Im a lot happier now.
    03-29-2013 01:52 PM

Similar Threads

  1. Free phone like last year?
    By jjspigland#AC in forum T-Mobile
    Replies: 2
    Last Post: 06-12-2011, 03:47 PM
  2. Remember the Tour 2/ Bold 9650 delay from last year?
    By ninefall in forum Verizon HTC Thunderbolt
    Replies: 16
    Last Post: 03-07-2011, 10:00 AM
  3. Can't connect to 4G since last update
    By cocochannelle in forum Sprint Epic 4G
    Replies: 1
    Last Post: 09-21-2010, 10:40 AM
  4. Replies: 2
    Last Post: 08-24-2010, 03:26 PM
  5. Been stuck in "Authorizing Purchase" phase since last night
    By Richard_Danger in forum Android Apps
    Replies: 2
    Last Post: 07-26-2010, 01:06 PM
LINK TO POST COPIED TO CLIPBOARD