Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By pcaker
  1. Thread Author  Thread Author    #1  

    Angry Pull the ring to unlock won't respond

    Hello,

    Sorry if this repeats another thread. I tried to search for it various ways and couldn't find an exact match.

    Here is my problem.

    I have an HTC Evo 4G LTE. Within the past month or so, I have seen the following behavior:

    1. When I press power to turn on the screen and log in to the phone, all seems normal.
    2. I pull up on the ring at the bottom to unlock my phone.
    3. Instead of bringing up the keypad to let me unlock the phone, the ring just sits there pulled as far as I can pull it.
    4. The time at the top disappears and is replaced by the text "Pull the ring to unlock."
    5. After a few seconds, the "Pull the ring to unlock" message disappears and is replaced by the phone time display, but the unlock keypad still doesn't come up.
    6. Sometimes, depending on the time of day or maybe what is running in the background, I don't know yet, the ring responds and allows the keypad to pop up.

    This is very frustrating , because it prevents me from using the phone at all until the keypad comes up and lets me log in. Sometimes I just give up after 10-12 tries. At other times the keypad comes up after 2-3 tries or even immediately on the first try. Completely unpredictable. I also sometimes have seen a different (but maybe related) problem where my phone starts randomly and spontaneously typing long strings of text.

    Has anyone seen the above behavior? Is this a bug or app interaction? Has my phone been hacked or infected somehow? Or is somehow my touchscreen messing up? I've had the phone since around summer 2012.

    I tried installing SwiftKey, but that didn't help. Then I thought it was my messaging app, HandCent, so I tried Go SMS and then Chomp without success, and finally reverted back to the stock Android SMS app. Again, the problem persists.

    Thanks in advance for any help. Let me know if any other information can help diagnose this problem and let me fix it. It's driving me crazy.

    C. Gordon Algernon (with apologies to Daniel Keyes )
  2. #2  

    Default Re: Pull the ring to unlock won't respond

    I see a lot of problems with that dang ring. I wonder if you can delete cache and data from the lock screen process?
  3. #3  

    Default Re: Pull the ring to unlock won't respond

    I am also experiencing this same issue. I have an HTC One X, it is about a year old and has been working fine until just yesterday when I can no longer unlock it.
    Nothing new was installed unless some automatic update of an app caused this.
    Same symptoms as described above but I do not have a password unlock, I just usually pull the ring and it is unlocked. Now when I pull the ring it bounces around a bit but won't let me pull it more than a few millimeters from the bottom of the screen.
    I can pull down the notification bar and click on settings to get into the phone so it is still useable. And I can answer calls by dragging the green answer button to the ring, I just can't unlock by dragging the ring. Frustrating.
    Oh, and I have restarted a number of times including total power off to no avail.
    What's going on?

    Edit: As a work around I went to Personalize, selected 'Lock Screen Style', then chose to the 'No lock screen' style.
  4. #4  

    Default Re: Pull the ring to unlock won't respond

    can anyone help me it looks like my screen has frozen on the lock screen I try to pull the ring put it wont work for some reason I took the SD card out to restart it a bunch of times but there was no change has anyone had this problem my phone is a HTC Sensation as well can anyone help?
  5. #5  

    Default Re: Pull the ring to unlock won't respond

    Here is another WORK AROUND for an UNRESPONSIVE screen UNLOCK RING pull on an HTC phone, which I experience perhaps once every 6 months.

    From the top black bar on the screen, drag all the way down the notifications and quick settings - yes, it does respond!
    Press notifications tab at bottom left of screen, look for the horizontal row of previously used app icons near the top of the screen.
    Press any app icon, and that app will open. Then at bottom of phone, press either "return" or "home" buttons to go to home screen, which should now be unlocked.
    Finally, restart phone to clear likely causes of the original problem.
    Zookeeper63 likes this.
  6. #6  
    jc924's Avatar

    Posts
    44 Posts
    Global Posts
    218 Global Posts

    Default Re: Pull the ring to unlock won't respond

    I started having this problem recently. Not all of the time, but some times. If I turn off the screen (press the power button) several times, it will usually go away. I am also having frequent screen lock ups and have to turn the screen off to unfreeze it. This just started a couple of weeks ago.
  7. #7  

    Default Re: Pull the ring to unlock won't respond

    Fix : Hold the device in your hand and apply pressure directly to the back of phone with your index finger. At the same time swipe the unlock ring upwards with your free hand.

    This method relieves pressure from the bottom of the faulty curved screen.
  8. #8  
    barkway's Avatar

    Posts
    2 Posts
    Global Posts
    16 Global Posts

    Default Re: Pull the ring to unlock won't respond

    I have the same problem with an HTC Sensation 4G that just suddenly did this after a yank-the-battery reboot. Pulling the unlock ring does nothing. I cannot pull down notification bar. I can do NOTHING. Now what???
  9. #9  
    barkway's Avatar

    Posts
    2 Posts
    Global Posts
    16 Global Posts

    Default Re: Pull the ring to unlock won't respond

    Quote Originally Posted by irlpic View Post
    Fix : Hold the device in your hand and apply pressure directly to the back of phone with your index finger. At the same time swipe the unlock ring upwards with your free hand.

    This method relieves pressure from the bottom of the faulty curved screen.
    Nope. Didn't work
  10. #10  

    Thumbs up Re: Pull the ring to unlock won't respond

    pcaker is a genius!! Thanks for helping me "fix" my phone so I could read texts and listen to messages. I knew there must be a way to fix it. Who knew it would be so easy and cheap? Thanks again!

Similar Threads

  1. Pull Ring to Unlock...reduction in touch sensitivity...possible to disable?
    By seanwilliams78 in forum T-Mobile HTC Sensation
    Replies: 31
    Last Post: 02-01-2014, 12:28 PM
  2. i can' pull the rings to unlock my phone please help
    By manuel shala in forum HTC One X
    Replies: 2
    Last Post: 06-05-2013, 07:21 AM
  3. Disable Pull Ring to Unlock?
    By eKennedy#AC in forum HTC EVO 4G LTE
    Replies: 7
    Last Post: 05-26-2012, 09:07 AM
  4. No more ring to unlock the screen?
    By Hydraulic Jack in forum HTC EVO 3D
    Replies: 2
    Last Post: 09-10-2011, 03:08 PM
  5. any way to fix the pull ring to unlock?
    By wally27 in forum T-Mobile HTC Sensation
    Replies: 5
    Last Post: 07-18-2011, 07:57 PM

Posting Permissions