1. scratchfwb's Avatar
    Last two days battery drain due to Google Play Services has become worse. Today my phone discharged then charging kept cycling on and off until I unplugged and let it die. Seems to be charging now. I know there was an issue in Nov but what now?

    Posted via Android Central App
    01-07-2014 07:14 PM
  2. UJ95x's Avatar
    Last two days battery drain due to Google Play Services has become worse. Today my phone discharged then charging kept cycling on and off until I unplugged and let it die. Seems to be charging now. I know there was an issue in Nov but what now?

    Posted via Android Central App
    Uninstall the updates and see if that helps

    Posted via Android Central App
    scratchfwb likes this.
    01-07-2014 07:19 PM
  3. djjeffa's Avatar
    Yea it sucked 30% of my battery over night. Ill have to try to uninstall update unless they come up with a new update.

    Sent from my EVO LTE using Tapatalk 2
    01-12-2014 07:32 AM
  4. Zookeeper63's Avatar
    Google is rolling out Version 4.1 and it seems to have fixed the issues with 3.9
    crxssi likes this.
    01-12-2014 03:06 PM
  5. thsixscrews's Avatar
    I installed advanced task killer app and that seems to help. It's in the play store and it's free...:-)

    Sent from my EVO using Tapatalk
    01-13-2014 06:27 AM
  6. Old Stoneface's Avatar
    I used to have regular problems with either Google Services or Google Play Services going loopy and killing my battery, until I finally turned off all location services. Neither Google Services or Google Play Services has risen their ugly, battery-killing heads since then.
    01-13-2014 06:41 AM
  7. scratchfwb's Avatar
    I had had the problem previously with Android services but this one was new. All is well now. Either deleting FB or the Play update or both solved the problem

    Posted via Android Central App
    01-13-2014 03:55 PM

Similar Threads

  1. Replies: 3
    Last Post: 02-15-2014, 03:19 PM
  2. Spotify on N4 - how to get continuous play (no sleep)?
    By billdz in forum Google Nexus 4
    Replies: 18
    Last Post: 01-16-2014, 03:34 PM
  3. can anyone install this app and see if it works on your nexus 7 or not?
    By preppystud in forum Google Nexus 7 Tablet (2013)
    Replies: 7
    Last Post: 01-11-2014, 08:21 PM
  4. SGS3 stuck at Samsung Logo
    By Johnny Elishov Beckham in forum Samsung Galaxy SIII I9300
    Replies: 3
    Last Post: 01-08-2014, 11:08 PM
  5. Find my mobile - At&t
    By Gerard Jr in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 01-08-2014, 12:46 PM
LINK TO POST COPIED TO CLIPBOARD