Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 73
  1. Thread Author  Thread Author    #1  

    Default SD-Card Unavailable and USB port not working, discharges Battery while plugged In.

    Okay, so I bricked my EVO last night. You lose access to your SD card, and your USB port, both for charging (only a problem if phone is on) and for data. There is a FIX. If you need to charge. Turn off the phone then plug it it. It will charge this away. If you have phone online and you get the charge light it is actually discharging your phone.

    This is where i got the info at, but will re-type it here for easier access.
    Original instructions pulled from Calkulin: [Fixed] Well looks like I killed my EVO already... (Lost SD & USB) - xda-developers

    Fix SD (I found that if you wait to plug in your phone until you are in fastboot of the bootloader on your phone, Windows 7 finds it with no problem.)

    Press & hold vol down and power on the phone
    Select fastboot by pressing the power button
    Make sure in device manager the driver is installed(Win 7 x64 downloaded them automatically)
    Open command prompt like you would to use ADB and type

    fastboot oem enableqxdm 0
    fastboot reboot

    That should fix your SD card not being detected.


    Fix USB

    Press & hold vol down and power on the phone
    Select fastboot by pressing the power button
    Make sure in device manager the driver is installed(Win 7 x64 downloaded them automatically)
    Open command prompt like you would to use ADB and type

    fastboot oem boot

    It will give you a log, look for the line that says INFOCID is SPCS_001, if it says something different, then use the generator below to create one(or below)

    Download the mtd0.img attached or use this CID generator made by stevebrush over @ Modaco to create a custom one

    Download the flash_image below.

    Unzip both zips and copy both files to the SD card



    Open a terminal emulator (I used ConnectBot) change ssh to local, give it a name.

    and type
    su
    cat /sdcard/flash_image > /data/flash_image
    cat /sdcard/mtd0.img > /data/mtd0.img
    chmod 755 /data/flash_image or chmod u+x /data/flash_image
    /data/flash_image misc /data/mtd0.img
    reboot

    if you are trying to find the > symbol then follow Keith Newman's info.
    -Hit "12#" key on the Keyboard.
    -then the "1/2" key (it'll turn into 2/2)
    -the ">" key is on the second row, 5th key, directly below the "=" and above the first blank in the 3rd row.
    Issue: I can't get the cat function to work. I have even wiped my data and re-rooted with the pc36img.zip file. still no go. keep getting
    /data/flash_image: No such file or directory
    same with the mtd0.img This is because you no longer have BusyBox installed. If you have lost busybox, then follow Keith's info in the next post. To the letter.



    Thanks Go Out to Keith Newman; Calkulin and IEFtm And to brontron for pointing me to the info from the start.
    Attached Files Attached Files
    Last edited by Saepak; 07-13-2010 at 08:11 PM. Reason: better info.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
    Thanked by 2:
  2. #2  

    Default

    I see what you did... You are now using a ROM that DOESN'T have BUSYBOX setup.

    So... this is what you're should try... just thinking out loud here.

    1) Put koush's update.zip and RvU 1.3.2.zip on your root directory of the SD card, you gotta put it in your computer for that since you don't have USB yet.
    2) Install ROM Manager and make sure you have updated to the latest Recovery: ClockworkMod 1.8.1.7
    3) Reboot into Recovery using using fastboot. Real Simple, Power Off. Hold Down and Power On. Let it check your card for a second, you should have renamed toast's root img to something else right? Now, go to the second option that says Recovery, select it.
    4) In this recovery mode, hit UP and then Power. You should be back into Koush's recovery now. Wipe first and then flash RvU. Once down, redownload ConnectBot and try those commands. You now have a ROM with BB that can do cat command.
    Thanked by 2:
  3. Thread Author  Thread Author    #3  

    Default

    Thanks Keith, giving it a try now.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  4. #4  

    Default

    as far as the > issue goes...

    -Hit "12#" key on the Keyboard.
    -then the "1/2" key (it'll turn into 2/2)
    -the ">" key is on the second row, 5th key, directly below the "=" and above the first blank in the 3rd row.
  5. Thread Author  Thread Author    #5  

    Default

    Keith, that no workie. Loaded the files on the sdcard. Update.zip was already there. Then booted up the bootloader. down to recovery, power to select. Then in rebooted to a black screen with phone and a red triangle with an exclamation mark in it. Now it is just sitting there. i have to pull the battery.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  6. #6  

    Default

    You didn't do the rest of it... when the exclamation point comes up:

    Vol Up and Power Button.

    That gets you into Koush's recovery.
  7. Thread Author  Thread Author    #7  

    Default

    i am going to install Titanium since it will install busybox on my system for me. doing so now and will see if that helps.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  8. Thread Author  Thread Author    #8  

    Default

    I did do that also. sorry missed putting that in my post.

    edit: but will try it again just to make sure.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  9. #9  

    Default

    Quote Originally Posted by Saepak View Post
    i am going to install Titanium since it will install busybox on my system for me. doing so now and will see if that helps.
    It will install BB, but... I am not sure if all of the right symlinks are there.
  10. Thread Author  Thread Author    #10  

    Default

    the up thing worked this time, must not of held them down very well together. Thanks Keith, you are the man.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  11. #11  

    Default

    you forgot good looking too...
  12. #12  
    echto's Avatar

    Posts
    21 Posts
    Global Posts
    132 Global Posts

    Default

    Did you get your phone working?

    It's going to be a sad day if an EVO dies.
  13. #13  
    echto's Avatar

    Posts
    21 Posts
    Global Posts
    132 Global Posts

    Default

    Quote Originally Posted by Keith Newman View Post
    you forgot good looking too...
    HA! +1000 HAM points
  14. Thread Author  Thread Author    #14  

    Default

    that got all the commands to work thanks you so very much keith.

    And the phone is unbricked.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  15. #15  
    d3xn2o's Avatar

    Posts
    2,252 Posts
    ROM
    4.1.1

    Default

    Let us know if you fixed it...

    Ninja Edit: Just saw your new post...
    Arrogant Linux Elitist
  16. Thread Author  Thread Author    #16  

    Default

    oh and Keith, yes your Pooh Avatar is good looking too.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  17. #17  

    Default

    Quote Originally Posted by Saepak View Post
    Welcome back
    [CENTER][URL="https://plus.google.com/u/0/+KPSmith/posts"]Follow me on Google +
  18. #18  

    Default

    Quote Originally Posted by Frix View Post
    Did you get your phone working?

    It's going to be a sad day if an EVO dies.
    No Evo is going to die on my watch... :P
    Thanked by:
  19. Thread Author  Thread Author    #19  

    Default

    And now that I have done this I will be able to help anyone else that is having issues.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
    Thanked by:
  20. Thread Author  Thread Author    #20  

    Default

    I have edited the first page so that it has the info to do this fix. Hopefully others will be
    able to benefit from my errors and misunderstandings. I will also be uploading those files to a rapidshare later so they can just be pulled from here.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  21. #21  
    toenail's Avatar

    Posts
    4 Posts
    Global Posts
    5 Global Posts

    Default

    isnt the term "brick" supposed to mean your phone is useless meaning doesnt power on, doesnt do anything period.. just sits there like a brick!
  22. #22  
    echto's Avatar

    Posts
    21 Posts
    Global Posts
    132 Global Posts

    Default

    Quote Originally Posted by Saepak View Post
    that got all the commands to work thanks you so very much keith.

    And the phone is unbricked.
    Woo-hoo!
  23. Thread Author  Thread Author    #23  

    Default

    Quote Originally Posted by toenail View Post
    isnt the term "brick" supposed to mean your phone is useless meaning doesnt power on, doesnt do anything period.. just sits there like a brick!
    Technically yes. I am just going off what the other forums are calling this action. By what I am understanding is that up until like May 30th or so they were useless, because you had nothing but the phone. You couldn't write to a SD card, and you had no real way to charge the phone. Not sure if the other phones that this started with could be charged while powered off or not, luckly the EVO can. So is it a true brick no, but that is what it was being called. Not my terminology. On top of that I can't change the main title of the post. Just my headers, or atleast I don't know how.
    By By AT&T, I have Me an EVO. To me, the Phone of all Phones.
    Sae's Apps My EVO is sporting: CM7.1.
  24. #24  
    toenail's Avatar

    Posts
    4 Posts
    Global Posts
    5 Global Posts

    Default

    haha, yeah i know what you mean.. it seems the term has changed drastically! ive been on forums where someone will say he think he bricked his phone cause his wifi isnt working!! how times have changed, lol
  25. #25  

    Default

    Hello Keith. Meant to ask you intially. I know you will pull me out of the well!!!
    I'm clueless and new to smartphones. For my entry level I chose the EVO 4g and tried rooting.
    I think I was successful following rooting using this method.
    [TUTORIAL] *****-PROOF Root Guide! No ADB, no fuss! - xda-developers
    Afterwards when I rebooted as you all came across I have no SD card and no USB. Right now my phone is charging with the power off since I spent all night and didn’t go to work today to get back functionality. At step 25 is where I was running into problems trying to install omj's rom. Also rom manager didn't work for me. I was able to use titanium backup to get all my apps but wasn't able to recover since I have no SD card or USB functionality.
    When I try your method for getting the sd card to come back I get the same QUALCOMM drivers issue. I downloaded the drivers but am getting an error message. I am running windows xp 32 bit. I got the right drivers and device manager is showing the htc connected.
    So when I get to fastboot
    When I try to initate the command fastboot oem enableqxdm 0 i get

    C:\>fastboot oem enableqxdm 0
    'fastboot' is not recognized as an internal or external command,
    operable program or batch file.
    Can you do your miracles? Obvoiusly I'm missing something.
    Any help is greatly appreciated.
    Last edited by rlmandroid; 06-16-2010 at 09:53 AM. Reason: meant to send to Keith not Seapack.
Page 1 of 3 123 LastLast

Posting Permissions