Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. Thread Author  Thread Author    #1  

    Default no 3g

    I'm new to this rooting stuff. Finally got the courage to root my EVO. Went fine. Installed a ROM and that went fine except now the 3g isn't working. Any help is appreciated
  2. #2  

    Default

    What ROM did you flash?

    Sent from my PC36100 using Android Central Forums
  3. Thread Author  Thread Author    #3  

    Default Re: no 3g

    Here is the whole story. I first flashed DigitalKarmaV777Deluxe. When i noticed 3g wasnt working I flashed another rom, EVOlutionICSJB. 3g still didnt work so I flashed another rom, MikG-v3.11... i know, i know, i probably shouldnt have done that, but i thought the 3g problem might have just been with the roms i was flashing.
  4. Thread Author  Thread Author    #4  

    Default Re: no 3g

    i know when i was rooting the phone i created a recovery image that is in a folder on my computer. is there a way to use that to get back to that point right after i rooted the phone?
  5. #5  

    Default

    Yes there is.. have you been wiping your phone prior to flashing the rom?

    Sent from my evo 4g running JB
  6. Thread Author  Thread Author    #6  

    Default Re: no 3g

    Yes. I've been wiping in between every flash
  7. #7  

    Default

    I would run the backup and start all over.. what hboot version do you have

    Sent from my evo 4g running JB
  8. Thread Author  Thread Author    #8  

    Default Re: no 3g

    Can anyone tell me the steps of running the backup? Where do you find the hboot version?
  9. Thread Author  Thread Author    #9  

    Default Re: no 3g

    figured it out. hboot - 2.18.0001
  10. Thread Author  Thread Author    #10  

    Default Re: no 3g

    I'm messing around in recovery. i'm assuming i go to nandroid restore and click on a file there to restore an old version. when i go there i see 2 files. is there a way to see what file is what? and do i need to wipe everything before i run the nandroid restore?
  11. Thread Author  Thread Author    #11  

    Default Re: no 3g

    im figuring this out slowly by myself.. lol. i figured out what file i want to restore. just need to know if i should wipe everything before i run the nandroid restore? anyone have any idea?
  12. Thread Author  Thread Author    #12  

    Default Re: no 3g

    thanks for trying to help audiman. figured it out. got back to right after i rooted phone. 3g is working again.
  13. Thread Author  Thread Author    #13  

    Default Re: no 3g

    Ok now i seem to be having the same problem no matter what rom i try to install. I only get 1X internet and no 3g. I can get 3g back only by restoring phone (pre - rom). If anyone might know what im doing wrong, please help me out.
  14. #14  
    wanabee's Avatar

    Posts
    67 Posts
    ROM
    BlackIce / inbREDed

    Default Re: no 3g

    go back to stock rom or a gingerbread rom and update PRL+ User profile do this twice then go back to the rom you want to use...this should do it
  15. Thread Author  Thread Author    #15  

    Default Re: no 3g

    Wanabee.. i just tried that and i get the same result. I am only getting 1x. no 3g. the 4g works also.... to bad i dont have good 4g coverage where i live.
  16. #16  
    wanabee's Avatar

    Posts
    67 Posts
    ROM
    BlackIce / inbREDed

    Default Re: no 3g

    if your absolutely sure you had 3g before flashing your rom then i believe you not wiping completely before installing the next rom if this is the case you would be overwriting what you have there now instead of starting fresh this could be the fault of the recovery you have, suggest you start by replacing the recovery with this one >[Recovery] [09-Feb-2011] RA-supersonic-v2.3 - xda-developers after installed and after placing the rom.zip on sd card wipe everything except SD CARD twice then try installing/flashing this rom here> [ROM] Update!! 7-19MokeeOS_SharkBoy_Edition - xda-developers this is a rom I have run with no promblems and comes packaged with one of the best kernals available when actually installing/flashing recovery and rom do not do so with the usb cable connected after installing recovery/rom go back to recovery and remove the recovery zip file on sd card...
    hope this helps
  17. #17  

    Default Re: no 3g

    I am having the same issue. I've tried a bunch of different ROMs, and tried changing/updating the baseband as well, but no luck. I tried the ROM and recovery you have listed above. I do not have any 3G at all. If I flash a stock rom [ROM]STOCK 4.67.651.3 (new ota update)[ROM] - xda-developers (I used the odexed version), I have 3G and everything works, I just hate the stock sprint rom. Any ideas on where I can go from here?

    I've also tried a straight CM7 and Lewa OS [ROM][2012-09-05 | 2012-09-28] Lewa OS - xda-developers and updating the kernal to Tiamat's latest. [Kernel][AOSP] Tiamat 4.1.0 | 2.6.38.8 10/13/11 - xda-developers

    Model PC36100
    Baseband 2.15.00.12.19
    CPU Info shows ARMV7 Processor rev 2 (v7l)
    supersonic rev 0004
  18. #18  
    wanabee's Avatar

    Posts
    67 Posts
    ROM
    BlackIce / inbREDed

    Default Re: no 3g

    straight from XDA..hope it does you some good


    I've been running CM7 since it was being compiled by lithid. At some point my 3G broke and I tried to ask for help but never could find a complete answer. At some point someone said the words "##data#" and "call sprint." Below is a step by step guide to what I did to fix 3G and it's been working through numerous wipe/flashes since. If someone already posted this information I apologize. This has worked for me and at least one other person that I know of, so hopefully it doesn't ruin anyone's phone.

    1. Download MSL Reader from market, run it and write down results.
    2. Nandroid current rom.
    3. Flash cauklins format all
    4. Flash latest rooted OTA (I found one in the wiki)
    5. Boot OTA (I skipped all of the google login/set up stuff)
    6. Enter ##3282# (##data#) in to the dialer.
    7. Menu will popup select "Edit Mode"
    8. Enter MSL when it asks for password.
    9. Tap "Data Profiles"
    10. Tap Menu button, then "Restore"
    11. Phone will reboot in 10 seconds or you can click ok.
    12. Hands free activation will come up shortly after phone reboots, then PRL update and Firmware update. (It found no frimware updates I think because I used the latest OTA) Let it process all.
    13. Power phone off.
    14. Boot to bootloader (hold power + vol down)
    15. Select recovery.
    16. Flash format all again.
    17. Nand restore.
    18. Enjoy working 3g.

    I did all this the first time on the phone with sprint. As soon as I booted the OTA I had 3g again, I just told them it was broken and they gave me the steps. I just did it all again while typing this to verify that it works rather than try to rely on my memory of what i did.

    Hope this helps. I also did the ##gpsclrx# while I had that sprint garbage installed.

    If these are instructions to seriously break your phone, can someone who knows better than me please correct me. So far I've had no problems, other than fixed 3G
    Thanked by:
  19. #19  

    Default Re: no 3g

    It took a while, but I finally got through all that garbage. Whew! Glad to say that the instructions worked like a charm.. No issues at all! I have working 3G now! Thanks again!...

    (I know it's a lot of explanation points, but I've been messing with this literally all day--I'm quite happy.. no ecstatic even.. )
  20. #20  
    wanabee's Avatar

    Posts
    67 Posts
    ROM
    BlackIce / inbREDed

    Default Re: no 3g

    awesome...glad it worked for you

Posting Permissions