1. bmwguy330's Avatar
    OK I have searched and searched. Ive looked here followed the steps. Xda and followed the steps and the same with youtube. When i hook my phone up using usb cable and go to start--->search----cmd the cmd prompt comes up. I type in "adb devices" and it should have my phoen and serial number come up but it doesnt. I have installed the sdk and eclipse, java jdk and all that mess but i cant get it to work. any setting i need to turn on or off in the phone. the debug box is checked. ive been trying to get this to work for a while but cant. I am in need of help lol thanks
    02-12-2011 04:21 PM
  2. DroidXcon's Avatar
    OK I have searched and searched. Ive looked here followed the steps. Xda and followed the steps and the same with youtube. When i hook my phone up using usb cable and go to start--->search----cmd the cmd prompt comes up. I type in "adb devices" and it should have my phoen and serial number come up but it doesnt. I have installed the sdk and eclipse, java jdk and all that mess but i cant get it to work. any setting i need to turn on or off in the phone. the debug box is checked. ive been trying to get this to work for a while but cant. I am in need of help lol thanks
    make sure you have the latest drivers for your phone installed
    02-12-2011 04:26 PM
  3. bmwguy330's Avatar
    do i just DL the drivers from htc website. or how do i tell if i have the correct drivers
    02-12-2011 04:49 PM
  4. bmwguy330's Avatar
    ok i Dl the drivers and tried again. I cant fiigure out what im doing wrong
    02-12-2011 05:00 PM
  5. DroidXcon's Avatar
    Try restarting the phone whiles its connected
    02-12-2011 05:03 PM
  6. KommyDroid's Avatar
    Install HTC Sync and get the adb driver from there.


    You can uninstall Sync after
    DroidXcon likes this.
    02-12-2011 05:08 PM
  7. DroidXcon's Avatar
    Install HTC Sync and get the adb driver from there, worked for me.


    You can uninstall Sync after
    oh yeah i forgot about that and HTC
    02-12-2011 05:09 PM
  8. bmwguy330's Avatar
    still no luck. I DL the Drivers and tried again. I wonder if I should uninstall sdk and eclipse and start over. I have the Icons on my desktop. would that cause and issue
    02-12-2011 05:24 PM
  9. Jerry Hildenbrand's Avatar
    you need to be in the directory (sdk/platform-tools/) that has the adb.exe in it, or edit the PATH variable on your computer.

    Assuming windows vista or higher:
    Press windows key + E to open explorer
    Find your SDK folder
    Shift + right click on the platform-tools folder
    chose "open command window here"

    then try adb.
    bmwguy330 likes this.
    02-12-2011 05:33 PM
  10. bmwguy330's Avatar
    ok so that worked. your awsome. Am i gona have to do that everytime i want to adb. or is there a way to just type cmd and go from there? thanks
    02-12-2011 05:46 PM
  11. bmwguy330's Avatar
    nm i answered my own question on that one. thanks again. i love this forum
    02-12-2011 05:49 PM
  12. Jerry Hildenbrand's Avatar
    Easy way -- put a shortcut to the sdk folder on your desktop. Open it and shift+right click on the platform-tools folder when you need to use adb.

    Harder way, but the right way -- add your sdk\platform-tools and sdk\tools folder to your PATH:
    How do I set my system path under Windows? - MATLAB & Simulink

    then whenever you open the cmd window you can just type adb without worrying what folder you're in.
    02-12-2011 05:51 PM
  13. bmwguy330's Avatar
    thanks alot for the help. Now I just need to learn how to use it. I really want to start loading different bootanimations/splashscreens/themes and eventually make a theme or app
    02-12-2011 06:55 PM
  14. KommyDroid's Avatar
    thanks alot for the help. Now I just need to learn how to use it. I really want to start loading different bootanimations/splashscreens/themes and eventually make a theme or app
    Boot animations, splash screens, and themes are flashed though recovery
    02-12-2011 07:03 PM
  15. bmwguy330's Avatar
    Boot animations, splash screens, and themes are flashed though recovery
    I was reading in one of the forums that you can use adb to push them. Maybe i was confused. I have tried flashing them multiple times and havnt had any luck getting them to work on any rom i have tried.
    02-12-2011 07:13 PM
  16. KommyDroid's Avatar
    I was reading in one of the forums that you can use adb to push them. Maybe i was confused. I have tried flashing them multiple times and havnt had any luck getting them to work on any rom i have tried.
    Is your rom deodexed?
    02-13-2011 01:32 AM
  17. bmwguy330's Avatar
    Is your rom deodexed?
    I apologize for my ignorance but how do i know if it is? i am currently running fresh rom. but i have been switching between fresh and cm 133.

    Also I have been trying to flash new themes and had no success. I made sure the theme was compatible. it keeps aborting the flash when i do it. basically what ive been doing is
    1.DL the theme (zip) to my comp
    2 plug in my phone transfer the whole file to my SD card
    3. boot into recovery
    4. wiped cache
    5."select zip from sd"
    6. then selected the zip file i want to flash
    7. selected install file.

    Here is the link. Its the theme in the first post.
    http://forum.xda-developers.com/showthread.php?t=746689

    Is that correct? or am i way off. Thanks. I didnt want to creat another thread thats why i asked here
    02-13-2011 09:03 AM
LINK TO POST COPIED TO CLIPBOARD