1. User One's Avatar
    Does anyone know a quick fix (besides factory reset). I dread going to the Sprint Store and having them look at me like "I'm stupid" or them telling me they have to keep it for a couple of hours to try to "duplicate" the problem. Thanks in advance.
    07-19-2011 10:17 AM
  2. Gekko's Avatar
    test EVO with another wifi router first.
    07-19-2011 10:23 AM
  3. SmokeCrawler's Avatar
    Is the WiFi sleep policy set to never?

    Its under WiFi settings->menu button-> advance
    07-19-2011 10:35 AM
  4. User One's Avatar
    It doesn't work on any wi-fi router..it connects, but only for about 10 seconds before it disconnects..

    And yes, it is set on "never"...

    Sent from my HTC Evo using Tapatalk.
    07-19-2011 10:39 AM
  5. yodatom10's Avatar
    Does anyone know a quick fix (besides factory reset). I dread going to the Sprint Store and having them look at me like "I'm stupid" or them telling me they have to keep it for a couple of hours to try to "duplicate" the problem. Thanks in advance.
    There might be somethig wrong with the WiFi radio
    07-19-2011 11:56 AM
  6. User One's Avatar
    So is that something I can fix or do I have to take it in?

    Sent from my HTC Evo using Tapatalk.
    07-19-2011 11:58 AM
  7. Gekko's Avatar
    what apps do you have installed? any task killers? what type of wifi router is it and how old is it?

    also - temporarily turn off encryption on your wifi router and see if it works then.
    07-19-2011 12:38 PM
  8. User One's Avatar
    what apps do you have installed? any task killers? what type of wifi router is it and how old is it?

    also - temporarily turn off encryption on your wifi router and see if it works then.
    Not that many apps...no task killer....and it won't stay connected to any router..not just the one at home..not sure of the name, but it's the router that comes with AT&T U-verse

    Sent from my HTC Evo using Tapatalk.
    07-19-2011 01:22 PM
  9. Gekko's Avatar
    temporarily turn off encryption on your wifi router and see if it works then.
    07-19-2011 02:19 PM
  10. yodatom10's Avatar
    If turning off the encryption does not fix it. You should doa factory reset and if that fails. I would then take it in to sprint
    07-19-2011 02:30 PM
  11. BigDogAlex's Avatar
    My husband and I have the same problem on both our newer EVO's. Got phones in early June, my WiFi would connect at home, and disconnect immediately. It happened on our home network, several of our friends and even at the Sprint store when we took it in. After doing several resets etc, they decided to give us new phones. Three weeks later, it happened again. Took them back in, several resets etc and even downloading the upgrade at Sprint, phones worked less than a week. We're taking them back in this PM. Maybe they'll come up with a new solution. I am getting tired of having to download and reinstall all my APPs. Anyone have other solutions?
    08-18-2011 12:56 PM
  12. BigDogAlex's Avatar
    test EVO with another wifi router first.
    it's been tested on 3 different routers
    08-18-2011 01:39 PM
  13. BigDogAlex's Avatar
    Just got back from Sprint store. We got new phones (for the 2nd time (in 2 1/2 months) See what happens now
    08-19-2011 04:40 PM
  14. Steven Farkas's Avatar
    I do not understand why people bother to post when they do not know the solution. This link (HTC One X and One S Wifi gotcha down? Give this a try | Android Central) has a procedure for setting a fixed IP for the HTC One (mine is from AT&T). It would be best to go to one of your home PCs already connected to your network so you can run "ipconfig" in a command window so you can see the IP address pattern in your home network. I also used the 8.8.8.8 and 4.4.4.4 DNS addresses as suggested in the URL above.
    04-06-2014 12:24 PM
LINK TO POST COPIED TO CLIPBOARD