Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 15 of 15
  1. Thread Author  Thread Author    #1  

    Default Disable Bluetooth for Media but not Phone Calls?

    Is there a way to disable bluetooth for media sounds but leave it connected for phone calls?

    Even when I use the headphone jack with Pandora, it still wants to play out of my bluetooth speaker phone. And when my daughter plays games, the game sounds come out over bluetooth also.

    I don't want to turn bluetooth off entirely but in the music case, it's impossible to listen to Pandora in the car unless I do.

    Any suggestions?

    Thanks
  2. #2  

    Default

    Hmm. That may be something you have to change on the car. I don't have this problem, but my car only supports phone calls through BT, not media.

    See if there's a setting in the car's BT to shut off the A2DP profile.
    PLEASE, when asking for help provide as much information as possible. We can't help unless we know what the symptoms are and what you did before they began.

    LG G3 on Sprint. [Stumped and Bumped, Debloated, Startup apps managed, Trickster, Nova Prime, Swiftkey, G3 Tweakbox]--> Runs smooth as silk, now.
  3. Thread Author  Thread Author    #3  

    Default

    Cool, thanks, I'll take a look at that. It's a Blueant S1 which does have A2DP, so I'll see if I can turn that part off.
  4. Thread Author  Thread Author    #4  

    Default

    Cool, found this in another forum. It turns out you can choose to enable Phone and/or Media for each bluetooth device you connect to.

    Menu -- settings -- wireless -- bluetooth settings -- long-click the device for your
    car -- options -- and uncheck "media".

    After that, it will run calls through bluetooth and media through the wire.
    Thanked by 2:
  5. #5  

    Question Settings don't stick

    Quote Originally Posted by eKennedy View Post
    Cool, found this in another forum. It turns out you can choose to enable Phone and/or Media for each bluetooth device you connect to.

    Menu -- settings -- wireless -- bluetooth settings -- long-click the device for your
    car -- options -- and uncheck "media".

    After that, it will run calls through bluetooth and media through the wire.
    I did exactly what is noted above and it works, however once I turn off the bluetooth device (Jawbone Icon) and turn it back on the settings are back to both phone and media being checked. Anyone else experience this? If so, how did you fix it?
  6. #6  
    VAJeff's Avatar

    Posts
    6 Posts
    Global Posts
    7 Global Posts

    Default

    Quote Originally Posted by CouchFisher View Post
    I did exactly what is noted above and it works, however once I turn off the bluetooth device (Jawbone Icon) and turn it back on the settings are back to both phone and media being checked. Anyone else experience this? If so, how did you fix it?
    I too experience this with a Jabra SP700. I have to go to the BT setting for the Jabra overtime the phone connects to uncheck media. It can be annoying.
  7. Thread Author  Thread Author    #7  

    Default

    I have a Blueant S1 speaker phone and I haven't had to readjust the setting yet.
  8. #8  
    VAJeff's Avatar

    Posts
    6 Posts
    Global Posts
    7 Global Posts

    Default

    Quote Originally Posted by eKennedy View Post
    I have a Blueant S1 speaker phone and I haven't had to readjust the setting yet.
    If I were going to use the FM Modulator (which does not work too well in the area I live in, unless you like static with the sound), I would be just fine. Instead, I want to use the 3.5mm port and run a hard wire connection to my car for the podcast/music on the phone.

    No matter what, when the phone pairs to the Jabra, it always pairs both Media and Phone profiles (even if I have unchecked Media Profile on the last connection). I always have to go into settings and uncheck the media profile after the phone pairs.
  9. #9  

    Default

    Quote Originally Posted by jpohl View Post
    If I were going to use the FM Modulator (which does not work too well in the area I live in, unless you like static with the sound), I would be just fine. Instead, I want to use the 3.5mm port and run a hard wire connection to my car for the podcast/music on the phone.

    No matter what, when the phone pairs to the Jabra, it always pairs both Media and Phone profiles (even if I have unchecked Media Profile on the last connection). I always have to go into settings and uncheck the media profile after the phone pairs.
    Ugh! It is very annoying. Especially since I'm typically in the car DRIVING when I want this setting to be corrected. I wonder if A2.2 Froyo fixes this?
  10. #10  

    Default App?

    ... perhaps there is an app that would correct this? Anyone?
  11. #11  

    Default

    What about trying to turn the profile off when the device is not paired?
  12. #12  

    Default

    Quote Originally Posted by scoobdude View Post
    What about trying to turn the profile off when the device is not paired?
    I tried that as well.

    Bottom line- if you disconnect the device, either from the phone or from the bluetooth headset when the connection is established again, it will reset to the default configuration.
  13. #13  

    Default Re: Disable Bluetooth for Media but not Phone Calls?

  14. #14  

    Default Re: Disable Bluetooth for Media but not Phone Calls?

    Quote Originally Posted by woodslink View Post
    Thanks for the suggestion, but it kind of treats symptom, not the problem. This app forces media audio to go through a wired connection. That's perfect if you just want to keep media audio from playing over bluetooth, but the media player apps still open and still tries to play audio. So the app (in my case, poweramp) is running and draining power.

    It doesn't solve the issue of not being able to uncheck 'media' in the bluetooth settings (or rather that the profile automatically re-checks 'media').

    Good looking out, though. I think we just haven't found the solution yet.

    Glad I'm not alone with this issue.
  15. #15  
    demon311's Avatar

    Posts
    4 Posts
    Global Posts
    15 Global Posts

    Default Re: Disable Bluetooth for Media but not Phone Calls?

    Has anyone found a fix for this? My cars BT only supports Phone Audio but I have a BT to AUX adapter that supports both Phone and Media Audio. My phone automatically connects to my car BT when I start the car, but the BT/AUX adapter does not. If I connect to the adapter, my car BT gets disconnected and the BT adapter enables both the Phone and Media Audio profiles. I would like to disable the Phone Audio profile on my BT/AUX Adapter.

    I have a SGS3 running JB.

Posting Permissions