1. nags#AC's Avatar
    Anyone else experience this? I'll get a text from someone... Reply immediatley. Then their reply to mine will come 3 minutes later.. Yet be above my last text. This happens to me quite often and with more than one contact
    07-03-2010 05:13 PM
  2. jasonmoore's Avatar
    I am not sure why it happens but it happens to me when I am in an area that does not always give me service.
    07-03-2010 05:28 PM
  3. EVO1Android's Avatar
    Has also happened to me. I believe it happens when service is not great. You could also try power cycling your phone.
    07-03-2010 05:33 PM
  4. nags#AC's Avatar
    It's happening to me non stop right now and I'm at my house where I always have full bars. I'll try a power cycle right now.
    07-03-2010 06:48 PM
  5. ArkAngel06's Avatar
    Always happens to me.

    It's persisted through many hard resets, and it happens in ChompSMS, and the stock Messages App.
    07-03-2010 07:03 PM
  6. alextrox69's Avatar
    Yeah it happens sometimes...thats the only problem i have with my evo
    07-03-2010 07:03 PM
  7. nags#AC's Avatar
    Only other problem I've had is sometimes I'll click on a text and it'll open someone else's text from hours earlier.
    07-03-2010 08:05 PM
  8. dontspamtheman's Avatar
    Yup...mine does this also
    07-03-2010 08:08 PM
  9. meyerweb#CB's Avatar
    It's a Sprint issue, not an Evo issue. I'm not a real big texter but my kids have complained about this many times, and they've never had Evos (or any other smart phone).
    07-03-2010 08:12 PM
  10. dontspamtheman's Avatar
    It's a Sprint issue, not an Evo issue. I'm not a real big texter but my kids have complained about this many times, and they've never had Evos (or any other smart phone).
    I never had this problem with sprint before my Evo
    07-03-2010 08:13 PM
  11. eye4ni's Avatar
    Happens to me too, try handcent sms app, it will at least keep them in order.
    07-03-2010 10:29 PM
  12. sonso's Avatar
    Not uncommon for me.
    07-04-2010 10:44 AM
  13. nags#AC's Avatar
    I tried handcent last night but wasn't a big fan
    07-04-2010 07:06 PM
  14. Robbie317's Avatar
    I never had this problem with sprint before my Evo
    Happened to me on and off with my Hero and on and off with my EVO. My iPhone did it now and again too.... It's probably a network issue reading the wrong times.. If you see the time stamp for some messages will be off by an hour or three.... then all other messages will show as coming before that one..

    Even my Nexus One on T-Mobile did it a few times here and there....
    07-04-2010 07:28 PM
  15. Jim_Phone's Avatar
    I started receiving text messages with times stamped four hours ahead from a few friends this weekend while I was visiting my parents. I surmised that perhaps it happened because I had traveled from the Fort Lauderdale area to the west coast of Florida. I had previously installed Handcent SMS as well and wondered if that may have had something to do with it as well. No idea if either of these things were connected, but hopefully this will not happen anymore in the default Android Messaging app now that I am back home again. It is really annoying to have my threaded text messages listed out of order.
    07-04-2010 07:57 PM
  16. dwaynewilliams#WN's Avatar
    This happens when you are roaming. If you turn the roaming off, the issue will stop. I did this with my Hero and now with my EVO. Of course, you won't have service sometimes, but you can pick your poison.
    07-04-2010 09:13 PM
  17. hodedofome's Avatar
    After installing handcent I haven't had this happen to me again. Who knows.

    Sent from my PC36100 using Tapatalk
    07-04-2010 11:00 PM
  18. fastamx79's Avatar
    This happens when you are roaming. If you turn the roaming off, the issue will stop. I did this with my Hero and now with my EVO. Of course, you won't have service sometimes, but you can pick your poison.
    Same here... only time mine screws up is when I am roaming. The messages that are sent to me will show a time stamp of 5 or 6 hours ahead. My Evo does this, my Pre did this, my v950 did this... really annoying.
    07-05-2010 07:26 AM
LINK TO POST COPIED TO CLIPBOARD