Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. Thread Author  Thread Author    #1  

    Default Wrong phone Number in phone indentity

    hey,
    just ported from verizon to sprint. The phone number on both my hero and Evo is wrong under the phone indentity. Also when i hold the number "1" to get the voicemail the number it dails is that wrong number. However my real numbers work for incoming calls and also show up correct on caller ID for outgoing calls. I believe this issue is also preventing my visual voice mail from working as it wont send the activate message - keep getting an error that says "there is a delay in setting up your voicemail.....
    Is there a way to fix the number issue without calling support? Are they open this weekend?
    thanks
  2. #2  
    Dave Blake's Avatar

    Posts
    1,393 Posts
    Global Posts
    7,159 Global Posts
    Carrier
    cyanogen_speedy-toastcfh

    Default

    I had this happen on my Hero a hard rest fixed it. It happened again when I swapped the phones with my wife I think I went in to voice mail and opened chang greeting followed the steps but did not change anything and that fixed it but its been a while I can't remember for sure. I know the factory reset fixed it though.
  3. #3  
    akelley's Avatar

    Posts
    2 Posts
    Global Posts
    3 Global Posts

    Default

    I had the same issue - Sprint CSR said that is normal and takes up to 72 hours for the phone to fix itself. Regarding voicemail, there was a setting I found that allowed you to specify the voicemail number to dial so I just changed it there myself.
  4. #4  
    Dave Blake's Avatar

    Posts
    1,393 Posts
    Global Posts
    7,159 Global Posts
    Carrier
    cyanogen_speedy-toastcfh

    Default

    In voice mail/settings check under from name and make sure it has the correct phone number.
  5. Thread Author  Thread Author    #5  

    Default

    Quote Originally Posted by Big D5 View Post
    In voice mail/settings check under from name and make sure it has the correct phone number.



    Thanks. But changing the "from name" in the voice mail settings doesnt help. is there another setting that im overlooking?
  6. Thread Author  Thread Author    #6  

    Default

    Thanks for all the replies. Called sprint and they reset it.
  7. #7  

    Default

    Under setting, go to the bottom and click on update phone, the click on the option to update profile. When you do that it forces the phone to register with Sprints network. Then afterwards shut down the phone and restart it up.
  8. #8  

    Default

    Lol oh my bad Haha, I'm glad to hear Sprints got it fixed.
  9. #9  

    Default

    By the way, you can change your number yourself by dialing ##020533## and entering edit mode. I had the same problem as the OP and took it to the Sprint store, the guy called up CS and did this and I copied down the code they told him to tap in.
  10. #10  

    Default

    the problem with mine is that my @sprintpcs.com email name is misspelled. i had them correct it on their system so i don't know why it didn't change on my phone. i even did a reset. its no big deal but its really annoying when someone misspells my name when i stated it to them clearly. like for the e thats supposed to be a c, i said c as in cat. ugh!
  11. #11  

    Default Re: Wrong phone Number in phone indentity

    This is incorrect; ##020533# will only work on YOUR phone. The correct way to change these settings is with ##enter your unique msl here#.
    Quote Originally Posted by SilverZero View Post
    By the way, you can change your number yourself by dialing ##020533## and entering edit mode. I had the same problem as the OP and took it to the Sprint store, the guy called up CS and did this and I copied down the code they told him to tap in.

Posting Permissions