1. analog_roam's Avatar
    Whenever I plug my Evo into my computer I get this error that the "USB device is not recognized" by windows. It still charges and worked just fine about 3-4 days ago, however now I cannot access the SD card as a drive on my computer. I can get to the SD card on the phone just not as a drive on my computer.

    Any thoughts?
    07-13-2010 01:58 PM
  2. Jerzyiroc's Avatar
    I've been having the same problem for weeks. I made a post and nobody had an answer. Hopefully someone does now!!
    07-13-2010 02:01 PM
  3. Darth Mo's Avatar
    Try installing HTC Sync and it should work then.

    Application Upgrade - HTC Sync 2.0.33
    07-13-2010 02:01 PM
  4. Jerzyiroc's Avatar
    Try installing HTC Sync and it should work then.

    Application Upgrade - HTC Sync 2.0.33
    I have HTC Syn on my computer and it still wont work. It works with my old Hero though with no problem.
    07-13-2010 02:01 PM
  5. analog_roam's Avatar
    Try installing HTC Sync and it should work then.

    Application Upgrade - HTC Sync 2.0.33
    I have HTC Sync installed, newest version. That was the first thing I did actually.
    07-13-2010 02:15 PM
  6. jpdaballa's Avatar
    when this happens to me (never happened on evo)

    i just restart

    and if that doesn't work i restart with every single usb cable out of the computer then plug them all back in one by one once windows boots all the way up.... (also try plugging your usb cable in a different port then normally used)

    try it might work for you too.

    also make sure you try restarting your evo
    analog_roam likes this.
    07-13-2010 02:27 PM
  7. Jerzyiroc's Avatar
    when this happens to me (never happened on evo)

    i just restart

    and if that doesn't work i restart with every single usb cable out of the computer then plug them all back in one by one once windows boots all the way up.... (also try plugging your usb cable in a different port then normally used)

    try it might work for you too.

    also make sure you try restarting your evo
    no l;uck
    07-13-2010 02:34 PM
  8. Wmadchef12's Avatar
    You have to uncheck debug and check mock location. Turn off your phone and restart. Then for sync options just got to usb. It worked for me i had the same issue i hope this solves yours!
    07-13-2010 02:59 PM
  9. analog_roam's Avatar
    I restarted my phone, uninstalled HTC Sync, restarted my computer, and plugged the cable into a different USB port and now it seems to be working fine. Thanks for your suggestions!
    07-13-2010 03:05 PM
  10. Cynikal1234's Avatar
    i had this same problem. i have 2 cables. one replacement USB cable i got from radioshack and the stock USB cable. For some reason, with my replacement USB, i got the USB device not recognized. But when i used my stock USB, it read everything just fine.
    07-13-2010 03:05 PM
  11. MAD WIL's Avatar
    ...this happened to me once, the USB icon wouldn't show up. I restarted my EVO and it worked again. Maybe setting the default to "usb drive" will help, but I doubt it.
    ..
    07-14-2010 06:57 AM
  12. MAD WIL's Avatar
    ...this happened to me once, the USB icon wouldn't show up. I restarted my EVO and it worked again. Maybe setting the default to "usb drive" will help, but I doubt it.
    ..
    07-14-2010 06:58 AM
  13. Cares's Avatar
    Sorry to bump an old post but I currently have this issue. It charges fine while plugged into the computer but just not recognized and I can't mount it.

    I'm reading some forum posts that this is a known issue and the EVO USB just breaks randomly. True or false? Any fixes?
    08-29-2011 03:19 PM
  14. Miguel Farias's Avatar
    im having same issue with no luck
    01-14-2013 05:07 PM
  15. Kishuna's Avatar
    I'd like to say I'm having this same problem.

    I've tried many other USB cords, I've factory reset my phone, I've tried everything I can think of, but cannot get ANY computer to recognize my phone. :S

    And I realize the guy above me bumped an old thread, but figured if it's on the first page, might as well post here than make a new thread. HTC Sync is not compatible with the Evo 4G anymore as well. :S
    02-09-2013 07:03 AM
  16. OperationA7X's Avatar
    I'd like to say I'm having this same problem.

    I've tried many other USB cords, I've factory reset my phone, I've tried everything I can think of, but cannot get ANY computer to recognize my phone. :S

    And I realize the guy above me bumped an old thread, but figured if it's on the first page, might as well post here than make a new thread. HTC Sync is not compatible with the Evo 4G anymore as well. :S
    The HTC EVO 4G USB ports are notorious for breaking, like the solder points stop connecting. I had that issue when trying to mod one. I had to have someone type the commands while I kept the cord very still. It will charge but mounting wise, Windows keeps telling me that the "Device has malfunctioned".

    Sent from my HTC Vivid WCX using Android Central Forums
    02-13-2013 11:20 PM
LINK TO POST COPIED TO CLIPBOARD