1. phaseIII's Avatar
    VERY annoying youtube issue..
    With just about ANY video i try to play on youtube while using EVDO, i am greeted with this message after about a 30 second "loading" loop




    I have been able to find others with this issue.. but no fix:
    Android Youtube App Problems - YouTube Help
    YouTube on the HTC Hero – what gives?
    Youtube will not play - Droid Forum - Verizon Droid & the Motorola Droid Forum
    Sorry, this video cannot be played - Android Help
    The YouTube app on my Hero says "Sorry, this video cannot be played" when I try to play a video. - Android Market Help
    07-18-2010 01:20 AM
  2. Predator-1's Avatar
    Yep. I get that a lot. Not sure if its a Youtube problem or app problem but im leaning more towards app problem.
    07-18-2010 01:40 AM
  3. phaseIII's Avatar
    Its funny how long this issue has been present, there are posts from 2009 complaining about this problem...Sad
    07-18-2010 01:44 AM
  4. piggyman's Avatar
    It's from the user who uploaded the video.

    If you ever uploaded a video to Youtube, it gives you the optional to restrict access to mobile devices.

    07-18-2010 01:53 AM
  5. phaseIII's Avatar
    No it isnt, because if i try to play a video 7 times, it will work about 2 out of those times.
    There are workarounds some people have found like:
    1) instead of directly tapping the video, if you press the "i" which shows its related videos and allows you to view comments, rate, favorite, share, flag. It seems to work more often than just directly pressing the video from a search.
    2) When getting the "Sorry this video cannot be played" error, if you press the back key, then press the search key on the phone, type in a bunch of letters then delete and press back key, go to the video and it plays more often than not.
    3) when using m.youtube.com the video will play

    Also want to add this happens with almost every video.... and if the uploader even did deny mobile phones, it would even show up in the search when using the app

    One more thing.... the videos play flawlessly while on wifi... issue is only present when on evdo (3G)
    07-18-2010 02:25 AM
  6. thomasanderson's Avatar
    This seems to happen everytime Youtube updates something on the server end. People had this issue with the Hero until the 2.1 update.
    07-18-2010 09:46 AM
  7. Kedar's Avatar
    I had this issue with my palm pre all the freaking time. After I got a replacement for the oreo issue, I saw it much less, if ever after that.
    07-18-2010 10:14 AM
  8. pwnst_r's Avatar
    The youtube app needs that fixed an a UI overhaul. That has to be the ugliest low res interface I've ever seen.
    07-18-2010 11:11 AM
  9. EVUK's Avatar
    Phasell,
    did you ever resolve "this video cannot be played" issue ?
    I have exactly the same...fine on WiFi - no video will play on Vodafone network at any location, any time of day/night.
    10-03-2012 12:36 PM
  10. Xi NZ's Avatar
    hi there
    I saw this thread was old. just wondered if anyone reported this issue has the problem solved now.
    me also have this issue. I m using LG P500 andriod just to watch youtube etc. and got this 'sorry this video cant be played' . !
    1. it works perfect fine on wife with my phone.
    2. i tried reset to factory status , not working
    3. tried clear browser caches, and reset to default , not working
    4. i dont have Flash playing installed. as i m using the youtube app.,
    5. upgrade to latest version of youtube app, didint work
    6. use YouTube on browser, didnt work . same error
    7. some times when i turn off then turn on.. and without log into youtube my account, occasionally one or two videos i randomly picked worked. but afterwards, the same message show up.
    8. I walked into a phone shop, begged the guy to try my sim on his phone, and he checked youtube using my sim card. we randomly checked a few videos. All worked.
    07-15-2013 01:52 AM
LINK TO POST COPIED TO CLIPBOARD