1. reagan247's Avatar
    My Evo has never had a problem, not once. And all of a sudden today, I was on the phone and I noticed the phone was scorching hot. I had it on speaker phone, which I've done many times before - without problem - and when I went to pick it up, it was insanely hot... so much so, that I almost dropped it.

    I instantly turned off the phone and pulled the battery out. After letting it cool down, I restarted it. Now my Wi-Fi radio will not turn on - at all. Under Settings, the option for Wi-Fi (with the check box to the right) simply says Error under it.

    Any suggestions before I call CS? I'd rather fix this myself, and even factory reset, before having to deal with CS...
    08-22-2010 04:32 PM
  2. reagan247's Avatar
    Turns out... it was my MicroSD card. It was hot, and no longer works... turns out that shut off the wifi?
    08-22-2010 05:14 PM
  3. Dave Blake's Avatar
    Glad you got it fixed
    08-22-2010 07:22 PM
  4. pwnst_r's Avatar
    Turns out... it was my MicroSD card. It was hot, and no longer works... turns out that shut off the wifi?
    Wow, that's strange.
    08-22-2010 10:01 PM
  5. IAmSixNine's Avatar
    After reading this i am going to back up my SD card right now.
    If you happen to call customer care and get any info pass it along. It would be interesting to know if its a bad SD card that shorted out or if the EVO caused some problem to kill the SD card.
    08-23-2010 08:49 AM
  6. reagan247's Avatar
    Yeah it was difficult to figure out because I was monitoring the heat of the phone and it got up to 118*F and I got freaked out. So I took out the battery and tried putting the SD card into my laptop and it wouldn't work at all. So I switched it out when the phone cooled off and BAM everything works - not only that, but the phone's temp hasn't risen past 97*F. It's very weird. I just can't figure out why the wifi would stop working and post an error.
    08-23-2010 08:51 AM
  7. reagan247's Avatar
    After reading this i am going to back up my SD card right now.
    If you happen to call customer care and get any info pass it along. It would be interesting to know if its a bad SD card that shorted out or if the EVO caused some problem to kill the SD card.
    That's the most upsetting thing, I had forgot to back up my SD card lately and lost some seriously awesome photos... and some data. But I've already posted my experience to Sprint & HTC's forums.
    08-23-2010 08:52 AM
  8. waidom's Avatar
    This just happened to me today. I was on my way home from a college visit and noticed my phone was hot but didnt think anything of it. a couple hours later i dropped my evo into a cup of water. Yes i know im an *****. I restarted my phone any everything worked besides the wifi. It said their was an error when i went to try to turn it on. I thought it was the water that caused the problem but after reading your problem i removed my sd card to see what would happen. And just like that, my wifi worked again.
    01-26-2012 10:58 PM
  9. sublimestylee's Avatar
    confirmed.
    02-05-2012 03:36 PM
LINK TO POST COPIED TO CLIPBOARD