1. One_Deep's Avatar
    Day 18 with my evo and now i got an issues with getting picture messages.. it always say message not downloaded.. anybody else got this issue? I cant deal with it any more its been happening for 2 weeks now..
    01-18-2011 02:27 PM
  2. dpg's Avatar
    usually happens to me when im in an area with little signal other than that i haven't had that error
    01-18-2011 02:29 PM
  3. One_Deep's Avatar
    I got an good signal full bars since I'm posting this from my phone i even turned off and on mobile network.
    01-18-2011 02:32 PM
  4. MissJennell#IM's Avatar
    I only get that when I am on wifi.
    01-18-2011 02:34 PM
  5. One_Deep's Avatar
    I don't even use wifi.. could this be a sprint issue or a evo issue?

    Edit: now im getting 'unable to send message' Generic network failure
    01-18-2011 02:45 PM
  6. dpg's Avatar
    have you tried powering off your phone and pulling the battery for a moment and starting it back up? if anything you may have to do a hard reset
    01-18-2011 02:58 PM
  7. RUSH's Avatar
    Call Sprint technical support and discuss your problem to them.
    Before doing that...

    Try this: Menu - settings - system update and update data profile.

    (Btw) Is your phone rooted?
    01-18-2011 03:00 PM
  8. prittyboy203's Avatar
    I have had this error from flashing roms here and there i will see it come up when my family is sending me a multimedia chain letters and I have my mobile network off to save battery I just turn it on look at the message and turn off again but the Evo keeps looking for data to download the message until I do that it comes up with the generic error but that's weird that trick usually fixes it for me ?

    Sent From PrittyBoy's Evo 4G
    01-18-2011 03:09 PM
  9. One_Deep's Avatar
    Just updated the profile data about to reboot now and i haven't rooted yet since d I'm still under 30 days and wanted to see how the phone work first
    01-18-2011 03:16 PM
  10. One_Deep's Avatar
    Alright I rebooted and now I'm able to see the mms I been getting. I don't know if the profile data update fixed it or the battery pull but tested it and able to get it mms now. Thanks guys and gals
    01-18-2011 03:35 PM
  11. RUSH's Avatar
    Just updated the profile data about to reboot now and i haven't rooted yet since d I'm still under 30 days and wanted to see how the phone work first
    Either one of those steps should fix that problem. If problem persist contact Sprint.

    I'm not rooted either, frankly... I don't need too. What more do I need my phone to do.

    Rooting is not an option for my phone, it's more of a preference.
    01-18-2011 03:38 PM
  12. Go Android!'s Avatar
    Alright I rebooted and now I'm able to see the mms I been getting. I don't know if the profile data update fixed it or the battery pull but tested it and able to get it mms now. Thanks guys and gals
    I used to have to restart my old Samsung Rant to get picture messages to come through sometimes. It's probably a Sprint problem but just rebooting should solve it.
    01-18-2011 11:48 PM
  13. One_Deep's Avatar
    Alright guys im back with the same problem. I can't get on send picture again. Im still under 30 days so can sprint replace my phone? Only problem is i have a white evo so will they have to order me one?
    01-21-2011 01:03 PM
  14. prittyboy203's Avatar
    Ya you could do that but you might wanna call and make sure they have one in stock I didn't do that and I ended up with a black because radio shack had sold me the only white in stock so to save you the disappointment of going and having to go to another store so you could do the swap and get the phone ASAP so you can be back up and running :-)

    Sent From PrittyBoy's Evo 4G
    01-21-2011 08:49 PM
LINK TO POST COPIED TO CLIPBOARD