Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Bluetooth Connectivity Problems while Wifi is connected

    I have an Evo 4g that will not connect to bluetooth while it is connected to a wifi network. I have a Jawbone Icon and a 2011 Ford F-150 with Sync that both experience this problem. The bluetooth will connect as soon as I am out of range of the wifi network or if I turn wifi off on my Evo. Is there a setting on the phone or the wifi network itself that I can change to solve this problem? I moved from an iPhone 4 and didn't have this problem with either the Icon or Ford Sync.

    Thanks
  2. #2  

    Default Same issue here

    I have to say, I never noticed this before Sprint pushed out their Froyo update. Since everything on this phone is worse since doing the update, I think I am just going to dump the sprint official Android release and root the thing. My suspicion is that Sprint put so much crap that you can't kill running in the background that it is interfering with the normal operation of the device.

    Hopefully I'll do the root this weekend and post back when I'm finished to see if it helped.
  3. #3  

    Default

    My EVO is rooted and I don't have any problem connecting to my Jawbone Icon when I am also connected to WiFi. I suspect that Thunderscore may be correct and it is a result of either Sprint software bloat or the way that HTC writes the stock Bluetooth stack (that's why it only works with general Bluetooth devices after root).

    Best of luck!
  4. #4  
    SmokeCrawler's Avatar

    Posts
    1,288 Posts
    ROM
    Stock for now

    Default

    My Evo is rooted also and I never ran into problems with Bluetooth not working when connected to WiFi. Can't say anything about it when I wasn't rooted. Didn't have a Bluetooth device during that time. However, I do feel the same as illwood and Thunderscore.
  5. #5  
    hopefulfarm's Avatar

    Posts
    537 Posts
    Global Posts
    551 Global Posts
    ROM
    CM7 on the Nook Color

    Default

    Quote Originally Posted by empfgd View Post
    I have an Evo 4g that will not connect to bluetooth while it is connected to a wifi network. I have a Jawbone Icon....
    I too have the Jawbone Icon. And sometimes I have trouble with it dropping connection, which is REALLY annoying when you're on a phone call! The phone can be 2' away from me and it will just drop the BT connection.

    I'm not sure who to blame. I haven't had issues with the Icon when I had my crackberry, so I tend to blame the Evo.

    I do tend to leave WiFi turned on at all times, even when I'm not near a WiFi connection. Not sure if that's part of the problem, but I will do some testing on my end to see if my issue is similar to yours.

    I know, not really helpful, but I feel your pain.
    Rockin' the Sprint Samsung Galaxy Note II & the Hisense Sero 7 Pro!
  6. #6  

    Default

    I sometimes have issues connecting my Plantronics a2dp bluetooth headphones when wifi is on. It is not all the time, but turning off wifi allows it to conect. I just recently realized wifi was the cause.

    I read somewhere that wifi and bluetooth are on the same chip (same as on the Palm Pre).
  7. #7  

    Default

    I don't connect to wifi very often so I've never noticed it. Actually I don't think I've ever had bluetooth and wifi at the same time.

    However.. When I have wireless tether going I notice my bluetooth connecting and disconnecting all the time. Very irritating when it does that. Hopefully the next update will fix that.

Tags for this Thread

Posting Permissions

B