Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
  1. Thread Author  Thread Author    #1  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default Changed Phone number, now have MMS issues

    A few weeks ago I had to change my phone number due to some issues in the private life, and ever since I have not been able to download any attachments on my MMS messages. I have checked the voice/data in the sprint zone app and its fine. I can surf the web, get on facebook, the app store, etc. Voicemail is fine and calls are fine. Its just my mms. I have make sure Profiles and PRL's are up todate, but even after I update them and go to the spring zone it still tells me there are updates available. I have pulled the battery out while the phone is on, cleared the stock message app and go sms app's cache, and when I called sprint today they had me reprogram the phones phone number and MEID numbers and reboot the phone, and when that didnt work they promptly hung up on me.

    So does any one have any thoughts on what is up? Did they not re-provision the phone correctly when they changed my number? When they changed my number and had me reboot the phone it never did any kind of handshake like they told me it would, so they had me call some 1-800 number that told me the phone was activated so I am wondering if something is still not set up correctly. Does any one have the APN information for MMS that i could program it in to see if that works? Or does any one know if there is another bank of cache some where that info is being pulled from? I am not rooted and I really dont want to do a factory reset on the phone and I have the feeling if i go into a sprint store or call them back they are just going to have me do a factory reset. I would rather root the phone and put a custom rom on first.

    any thoughts would be appreciated, I seem to have gotten quiet a few mms in the last few weeks and would love to see what im getting.
  2. #2  

    Default

    Friend had the same issue porting from tmobile to sprint with an evo. Not sure details of what they did in the system but was he explained it they had to completely clear him out of the system and set him back up. Took forever for him to get the right person to do it.
  3. Thread Author  Thread Author    #3  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    Quote Originally Posted by kcpowercat View Post
    Friend had the same issue porting from tmobile to sprint with an evo. Not sure details of what they did in the system but was he explained it they had to completely clear him out of the system and set him back up. Took forever for him to get the right person to do it.
    Dam, guess that means I got to keep calling sprint?
  4. #4  
    boggs3010#AC's Avatar
    Banned

    Posts
    288 Posts
    Global Posts
    282 Global Posts

    Default

    Reprogram the phone and or have Sprint "refresh " your account. By reprogram "re activate the phone as if new, manually if possible. ##123456# and edit then enter your phone number and MSID.
  5. #5  
    RkyMtnHigh's Avatar
    Banned

    Posts
    624 Posts
    Global Posts
    626 Global Posts

    Default

    Which text program are you using? If it's handcent, you will have to re-register your account, assuming you created one for all their MMS goodness.
  6. #6  

    Default

    My wife changed her number, long story short the end result was to go to a Sprint store and they re-provisioned the phone. It workded
  7. Thread Author  Thread Author    #7  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    Yeah, I called sprint and had them reprogram the phone and when that didnt work (maybe they still didn't re-provision on their end) thats when i was "disconnected". I guess i will just have to go into the sprint store. Im using Go SMS and have the stock sms installed as well....doesn't work in either.
  8. #8  

    Default

    yeah my friend went into the store. A few employees tried to talk him into just changing phones instead...
  9. #9  

    Default

    Have them change your NAI and then update your profile.
    Sprint wants me to make this clear: The postings on this site are my own and do not necessarily represent the positions, strategies or opinions of Sprint.
  10. Thread Author  Thread Author    #10  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    Quote Originally Posted by TheEngineer View Post
    Have them change your NAI and then update your profile.
    Okay, I will try this next. Is this something they can do over chat, or i will have to call in from another phone and do first (getting to another phone or me is harder than it should be).

    What is a NAI? (Just so i know)

    *EDIT - I tried this, it still didnt work.
    Last edited by burzlurker; 04-16-2011 at 11:19 AM.
  11. #11  

    Default

    I'm wondering if this has nothing to do with changing anything. It might have more to do with everything all backed up. How many messages are you holding in that phone right now? Have you cleared out everything and started from scratch? Go SMS lets you back up before doing this so, you won't lose anything by trying.
  12. Thread Author  Thread Author    #12  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    I tried this since I did have a lot of messages. Backed it up, uninstalled go, deleted all 2000 msgs, deleted the cache and data in the messages app, reupdated my profile rebooted then had a friend try a small (60k) pic. No luck.... hard reset is in my future I fear....
  13. Thread Author  Thread Author    #13  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    something else i noticed, I can get MMS to send when its text only, but when an attachment is on there it wont send or receive.
  14. #14  

    Default

    I have this happen most often when I'm on wifi.
  15. #15  
    drjb74's Avatar

    Posts
    275 Posts
    Global Posts
    297 Global Posts
    ROM
    Stock

    Default

    I would suggest to go into a store and explain the problem. If they can't fix it, you could ask them to replace it. Perhaps a new device would solve this problem.
  16. Thread Author  Thread Author    #16  
    burzlurker's Avatar

    Posts
    24 Posts
    Global Posts
    91 Global Posts
    ROM
    CM7

    Default

    Seeing as I have good friday off and dont really know any one in Chicago, i said eff it and did a factory reset. Problem solved. I was just hoping to avoid that, but oh well. Now I gotta figure out how to root using an old mac, but thats another thread... =)
  17. #17  
    ar_garza's Avatar

    Posts
    78 Posts
    Global Posts
    100 Global Posts

    Default

    I had issues not being able to send MMS with GO SMS installed on my phone. After I unistalled MMS worked fine.

    EDIT: I didn't see the second page so never mind.

Posting Permissions