Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default 3G not working..

    I'm running Fresh 2.3.3 and for some reason, my 3G connection is not working. Whenever I go to the market or Facebook or anything that requires data, the phone will just give me an error saying it couldn't connect, and that I should turn on WiFi. Everything works just fine when WiFi is on, but whenever I'm using only 3G, nothing seems to work. My PRL version is 60670 and my baseband is 2.42.00.03.10. Can anyone help me fix this? Do I need to get another radio that works better?
  2. #2  

    Default

    call your service provider and tell them you need to do a manual reactivation
  3. #3  

    Default

    I am running the CM6.0 froyo rom right now but used Fresh 2.3.3 for a few weeks and had the same issue. The only solution I came up with was to manually disable and then re-enable data. The easiest way to do this is to long-press the red end call key and press mobile data to turn it off. Then long press end call again and select mobile data to re-enable it. This worked for me, but was definitely a nuisance.
  4. #4  

    Default Re: 3G not working..

    I had the same issue but the data was disabled. I must of hit it when I powered off the phone. I didn't even know that button was there. Thanks for the information!
  5. #5  

    Smile Re: 3G not working..

    Check that your APN exists and defined according to your mobile provider settings

Posting Permissions