Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
  1. Thread Author  Thread Author    #1  
    TylerLannan#AC's Avatar

    Posts
    13 Posts
    ROM
    CM7 w/ stock CM Kernel

    Default DamageControl v2.0 released. Built on Sprint 2.1!!

    Here's the latest from one of the greatest cookers. How did he get it?? I don't know, but it's awesome. Go check this out if you want it. ==>

    [ROM] DamageControl v2.0 - FULL SPRINT RELEASE!!! - EVERYTHING WORKS! VVM, EVERYTHING - xda-developers
  2. #2  
    sfox's Avatar

    Posts
    22 Posts
    Global Posts
    42 Global Posts

    Default

    So far, the second release looks like it works AWESOME!

    S
  3. #3  

    Default

    Working pretty well for me. Only thing is I'm missing some apps that I did actually enjoy. Shop Savvy being the biggest concern - that saved me $40 in one $40 purchase...

    Then aCar is gone as well...
  4. #4  

    Default

    it runs ok. a bit slower than the previous version, and yes its missing a few apps, wifi tether and cachemate namely. i may go back to the previous version b/c this one is just not running well for me.
    HTC Hero > HTC Evo 4G >
    Motorola Droid Bionic > Samsung Galaxy Nexus
    Chromebook
    Chromecast x 2
  5. #5  

    Default

    I've lost two widgets I really liked. Digital clock by maize worked on the prior release. I may do back to v1 since that ran everything I had before.
  6. #6  

    Default

    give it some time...when the updates come out things will run much better
  7. #7  

    Default

    I do not recommend using this rom. I've got problems with sync never stopping. Phone will not sleep. Alarm clock is not working either. The sync issue is killing my battery. The fix posted doesn't work. I stopped syncing Facebook and it still hangs.

    I have to say use v1 until all the bugs are out on v2.
  8. #8  

    Default

    I too have that sync issue. I keep having to cancel all and sync all in order to get it to run right. Wasn't there some bug on v1 as well?
    HTC EVO 4G

    It kicks tail!!!
  9. #9  

    Default

    I flashed it, and couldn't get Google to sync, and then sometimes the contacts would be there, sometimes they wouldn't, the calendar wouldn't sync.

    Then some widgets were missing, i cleared the HTC Sense cache as suggested, restarted the phone, and there were more problems.

    What's funny is that when i restored my nandroid of my DC 1.0 ROM which i love, the Facebook sync started working out of no where.

    But yes, i'll wait for a better version of the new ROM.
  10. #10  

    Default

    Flashed this over about a half an hour ago. Phenomenal! Everything synced right back, all apps present. Initial boot up is scary slow but after that it runs smooth. I just rooted and flashed Fresh 1.1 last night for the first time and then saw this thread this morning and decided to give it a shot. Love it! Thanks to Damage!
  11. #11  
    Andrew Ruffolo's Avatar

    Posts
    3,808 Posts
    ROM
    Stock

    Default

    I have everything working. You may have to do extra stuff (like me) to get everything running smoothly. Battery life is great (on par with gumbo 1.5c for me). If you have questions, search is a pain there.
    The facebook.apk and HTCfacebook.apk are what causes the sync to go on and on and kill battery. You need to replace them with a program like PreKitchen or figure out how to pull/push files through adb. You will then need to re-sign in to facebook if you want it to sync
    Alarm clock doesn't work due to sprints update program. Don't know why, but once I remove it, it works. I really don't care as long as Sprint TV still works (and it does) and SPrint Nav works as a backup to Google Maps Nav.
    You may see "Time without signal 50%" Putting the phone in airplane mode, then removing gets rid of this.
    Uptime is 100%, but it isn't killing my battery, so I'm leaving that alone.
    MMS is increased to 2Mb (SWEET) so now, you don't have to resize your pictures!!! my guess, this is what the April 9th update will be as well as another fix.
    There are warnings with this ROM, check to make sure you have a PRI ending in 3 before flashing and all should work.
    There is also a patch for Apps2SD which worked, but you have to add in comand line prompts after applying the patch.
    Flash from DC1.0 and you will have protected apps in the market, don't use marketenabler, its annoying looking, useless and sometimes still doesn't work.
  12. #12  

    Default

    So if I were to go back to DC1.0 and then upgrade again back to DC2.0r2 then I should be able to get the protected apps back?? Help me out on the logic on that. I'd really like to be able to get ShopSavvy back, however, I think I'd rather stick with 2.1 than go back to 1.5.
    HTC EVO 4G

    It kicks tail!!!
  13. #13  
    Andrew Ruffolo's Avatar

    Posts
    3,808 Posts
    ROM
    Stock

    Default

    OK, Heres what you do:
    If you have Apps2SD working:
    Make Nad+EXT of current setup
    Wipe Data and Dalvik (both)
    Reflash DC1.0 Nand with apps in market
    Flash Nan + EXT and it should work
    Worked like a champ, and about 5 minutes + you didn't even have to redownload all your apps that you had cause they are in the nad backup I was happy about that.
  14. #14  

    Default

    After going through my apps (all free, I've not found a paid app that I'll use yet) I've found that dPod doesn't work properly with this ROM. When I download episodes from my subscriptions and go to play them it says No Music Found. I'm going to load some music into the music player tonight to make sure that works properly and while I'm in there I'm gonna check to see if dPod is loading episodes into the right place or if something changed. I'll update later (probably tomorrow) and let people know what I've found. Anyone else using dPod and this ROM with different results?
    Is there a better pod catcher that does work? And I tried Listen, it's not only a terrible interface (IMHO) but I could never get it to update my subscriptions properly.
  15. #15  

    Default

    Make sure you have not flashed a ROM from an eris dump before you flash this rom. It will change your PRL and you will have problems with the rom. easy fix if you have your MSL password to revert back to the old PRL. Nice Rom when everything works. Still not like the good old Gumbo
  16. #16  
    Andrew Ruffolo's Avatar

    Posts
    3,808 Posts
    ROM
    Stock

    Default

    Quote Originally Posted by mQuinn View Post
    Make sure you have not flashed a ROM from an eris dump before you flash this rom. It will change your PRL and you will have problems with the rom. easy fix if you have your MSL password to revert back to the old PRL. Nice Rom when everything works. Still not like the good old Gumbo
    Not everyone gets affected by this. DC v1.0 was built off of the Eris dump. I used that prior to DCv2R02 and my PRI is fine (not PRL, btw). But yes, PLEASE CHECK PRI PRIOR TO FLASHING.
  17. #17  

    Default

    Yes PRI. Sorry about that.
  18. #18  

    Default

    I tried to flash this last night and it hung on the HTC white screen for hours. Not sure what happened.
  19. #19  

    Default

    rufflez,

    Are you using App2SD? If so, how do you like it? I'm using the latest DamageControl v2.0r2 rom and I've reinstalled all my apps, however, I only got 15 mb space left on my internal memory. I'm thinking it might be time for me to start using App2SD, but I dunno how it works or if it works correctly with the new 2.1 roms. Any feedback on the app will be greatly appreciated
  20. #20  
    Andrew Ruffolo's Avatar

    Posts
    3,808 Posts
    ROM
    Stock

    Default

    Quote Originally Posted by bruceleroyjr View Post
    rufflez,

    Are you using App2SD? If so, how do you like it? I'm using the latest DamageControl v2.0r2 rom and I've reinstalled all my apps, however, I only got 15 mb space left on my internal memory. I'm thinking it might be time for me to start using App2SD, but I dunno how it works or if it works correctly with the new 2.1 roms. Any feedback on the app will be greatly appreciated
    Works great. Honestly, once I upgraded my SD card to 8GB, I have yet to remove it. If you have to remove it, then you are kinda screwed with apps working. It works fine with the 2.1 ROMs if you apply Darch's patch and then type commands in the command prompt if you have the SDK installed, or you can do it on the phone with slightly different code with a terminal emulator from the market. I would uninstall all apps, then reinstall them after a reboot post-command prompt/ install busybox. If you have any other troubles, PM me and I'll try to help you out as best as possible. I noticed I had like no room after installing the ROM as well which made me look for a patch ASAP. BTW, you will need to partition the SD card, make a backup onto your computer first, then partition, then upgrade partition from EXT2 to EXT3 and it works great. Good thing about it:
    I switched back to Gumbo 1.5c today for battery life reasons. I made a Nandbackup + EXT though of r02 just in case I HAD to use a 1.6+ app. And I can flash back and forth without having to reinstall my apps.

    Heres the code you need to type in on command prompt, then do a reboot of the phone for it to apply.
    adb remount
    adb shell
    busybox --install /system/xbin
    mkdir /system/sd
    a2sd
    Do them 1 at a time, best bet is to copy and paste.
    Last edited by Andrew Ruffolo; 03-31-2010 at 10:37 PM.
  21. #21  

    Default

    I am pretty much a newbie with rooting and all but this forum has made it quite simple and very interesting! I installed V2.0 r2 over a week ago and was at first very pleased. Then I noticed that after the phone was up for a couple of hours I would lose data connection. (Phone still working fine on Sprint network for calls and text!!) I had not wiped before the install (honestly, once upon a time I used to be able to read and follow instructions!) so I re-installed stock ROM from nandroid back-up and once I was sure the phone and data serviced were working fine ( 48 hours) I did a wipe and re-installed DC 2.0 v2. Phone worked perfectly for almost 2 days. This morning I did an HTC sync and afterwards once again got my "no data connection" messages when I went to the internet, Gmail and marketplace! Any ideas??? Is this a pure coincidence or could it be somehow connected to the sync??
    On another note-and tell me if I need to post this elsewhere-I have only recently rooted my phone and have noted that most of the time (9 out of 10) when I push home and power buttons to boot into root/recovery program it does not happen! I get to what I think is a "stock" Sprint Hero program ("hard reset) asking me if I want to wipe all data/applications. I have to pull the battery about 10 or 15 times in a row and eventually I do get to my recovery program. Is this odd or is this the Hero???
  22. #22  

    Default

    Quote Originally Posted by drjoed View Post
    I am pretty much a newbie with rooting and all but this forum has made it quite simple and very interesting! I installed V2.0 r2 over a week ago and was at first very pleased. Then I noticed that after the phone was up for a couple of hours I would lose data connection. (Phone still working fine on Sprint network for calls and text!!) I had not wiped before the install (honestly, once upon a time I used to be able to read and follow instructions!) so I re-installed stock ROM from nandroid back-up and once I was sure the phone and data serviced were working fine ( 48 hours) I did a wipe and re-installed DC 2.0 v2. Phone worked perfectly for almost 2 days. This morning I did an HTC sync and afterwards once again got my "no data connection" messages when I went to the internet, Gmail and marketplace! Any ideas??? Is this a pure coincidence or could it be somehow connected to the sync??
    On another note-and tell me if I need to post this elsewhere-I have only recently rooted my phone and have noted that most of the time (9 out of 10) when I push home and power buttons to boot into root/recovery program it does not happen! I get to what I think is a "stock" Sprint Hero program ("hard reset) asking me if I want to wipe all data/applications. I have to pull the battery about 10 or 15 times in a row and eventually I do get to my recovery program. Is this odd or is this the Hero???
    I've noticed there is a new build out. Hopefully it will fix most of the issues. I rolled back to v1.0 because it feels more stable.
  23. #23  

    Default

    Thanks! Moving quickly in the ROM update world. First of all I realize that in order to boot into my recovery mode I need to hold the home button and press and release the power button! Don't know why that was not obvious to me but instructions seemed to say hold down both. Second I realized that my loss of data service did not correlate with my sync but rather with my signing on to facebook! This increased my battery drain significantly and somehow caused me to loose data connection in an hour or two. Don't know why but that is what is happening. Anyway, I upgraded to 2.05 and will let you all know how that goes!

Posting Permissions