08-30-2016 11:43 AM
41 12
tools
  1. Ed Hughes's Avatar
    I can't get Google contacts to sync on my Sprint hero.
    Gmail and calendar work fine.

    But contacts won't sync...

    Any ideas. It just times out and says sync not available now.
    05-19-2010 01:33 PM
  2. beezy's Avatar
    I can't get Google contacts to sync on my Sprint hero.
    Gmail and calendar work fine.

    But contacts won't sync...

    Any ideas. It just times out and says sync not available now.
    Go to settings>accounts&sync>google>sync now. If that dont work uncheck/check sync contacts if it don't start to sync press sync now.If that fails reboot and it should sync.
    05-19-2010 01:47 PM
  3. mkansgen's Avatar
    I'm in the same boat. Not sure why contacts won't finish syncing.
    08-22-2010 11:33 AM
  4. markyflies's Avatar
    Same here. Been that way since June 16. Gmail and calendar sync no problems. I'm sure a reset would fix, but I do not want to do that. I do not want to set up my phone again.
    Can't wait until November. I will be going with a EVO
    08-23-2010 02:14 PM
  5. rynomite's Avatar
    Are you rooted?

    If so, use rootexplorer to navigate to /data/data. Find the directory labeled "com.android.providers.settings" and delete it. Reboot, and your Google contacts should now sync!
    09-13-2010 11:12 PM
  6. mouseglider's Avatar
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    foszz, JED427, hakimmmmm and 7 others like this.
    09-26-2010 02:45 AM
  7. pkn's Avatar
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    This worked for me! Thanks!
    02-05-2011 12:11 PM
  8. jwgrenning's Avatar
    Thanks so much for the solution. T-Mobile wanted me to do a factory reset.

    I thought I would fill in a few gaps in the menu and screen traversal

    Home/Menu/Settings/Accounts & sync
    Turn off Background data
    Home/Menu/Settings/Manage Applications/All/Contacts Storage/Clear data

    Home/Menu/Settings/Accounts & sync
    Turn on Background data

    thanks again, James
    m.jrdn likes this.
    03-01-2011 06:43 PM
  9. kestrel#AC's Avatar
    In this step

    Home/Menu/Settings/Manage Applications/All/Contacts Storage/Clear data

    Does clear data get rid of my contacts.
    04-29-2011 01:41 AM
  10. m.jrdn's Avatar
    this worked flawlessly. have been trying to get done for a month. thanks.
    05-13-2011 12:29 AM
  11. smmoore2's Avatar
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    My problem is that the clear data button is greyed out. why can't I clear my data?
    open the "Contact Storage" and click "clear data" of "Contacts Storage"
    09-01-2011 03:52 PM
  12. SSHGuru's Avatar
    I got the Bionic and everything Sync's but the gmail contacts. I can't do those steps because the options are greyed out.

    Any advice?
    09-17-2011 07:48 PM
  13. brettian's Avatar
    Thank you MouseGlider. Your solution worked perfectly to get my contacts to sync from google to my android phone.
    10-23-2011 10:07 AM
  14. Vance14's Avatar
    Mine still is having problems even after this fix. I have cleared all my data and it tries to resync everything, but then it just stops after a while and the small "syncing" spinning icon just goes still, but doesn't go away. And, new contacts from my browser UI are not synced into my phone. And, it is showing that the last sync was yesterday morning, even though it has tried numerous times since then.

    Edit: after doing this process a few times, it finally did sync and shows a new sync date and time, but for some reason, the little icon won't go away. Regardless, it finally did sync!
    11-01-2011 01:52 PM
  15. bassamme's Avatar
    Thanks for the tip. Worked great. My contacts had not synced since Jan 13, 2011.
    11-15-2011 08:01 AM
  16. docedt's Avatar
    Mouseglider's recommendation worked perfectlt. I had Sprint do hard reset and they re-entered contacts that had been saved not realizing that Google would re-sync contacts so I ended up duplicate set of contacts. This led to Evo not wanting to sync Google contacts. Thanks again for the tip.
    01-03-2012 12:18 PM
  17. Ricochet11's Avatar
    FIX WORKED GREAT!!!!!
    Thanks Alot!
    01-31-2012 10:26 AM
  18. hakimmmmm's Avatar
    Try this:

    thanks alot man
    i tried so hard to get it sync n searched the net for hours but couldnt find anything

    this forum and ppl like you rock

    thnxx again

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    monica18 likes this.
    05-04-2012 11:18 AM
  19. ben63vw's Avatar
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

    @mouseglider

    Thanks for the fix!!! Worked perfectly on my Samsung Captivate Glide with INC3PTION custom rom. It was the only thing not syncing after installing INC3PTION and restoring my settings from backup.
    06-30-2012 04:46 PM
  20. speedlever's Avatar
    Kudos to mouseglider for this fix. I've been struggling for a while trying to figure out why my Google contacts won't sync to my Galaxy Proclaim running GB. If I add new contacts to the phone and choose Google (instead of Phone) to save the contacts, the new contacts shows up in my Google contacts but weren't showing in my phone.

    However, if I received a call from the new contact, the contact name would show up. But maybe that's caller ID instead of my contact list providing the info.

    IAC, after following mouseglider's instructions, my contact list downloaded and I have my latest contact additions on my phone now.

    Hopefully the sync will work as expected in the future.
    08-02-2012 10:34 PM
  21. dmsachs's Avatar
    You are a lifesaver! Verizon said "Do a factory reset." Thanks so much!
    10-10-2012 08:00 PM
  22. devo1929's Avatar
    Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

    I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.
    11-05-2012 07:52 PM
  23. Nathan Bliss's Avatar
    Thanks a lot for this information mouseglider. Following your clever and brilliant instructions for resolving gmail sync'ing problems with Android has caused me to lose most of my important contacts. Far from a successful sync resolution, this has caused a one-way sync from Gmail, which only had a fraction of the contacts that were on my HTC Wildfire. End result: Most of my important contacts are now deleted from my contacts list.
    11-18-2012 03:39 PM
  24. Rodrigo Pereira's Avatar
    Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

    I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.
    That's MY EXACT problem. Whenever I add a contact using Contacts EX (edit, just tried to add a contact using the default Contact app instead of Contacts EX and the problem will also occur), my sync will just fail. If I remove all contacts and try to sync again, it will all work flawlessly. If I add a contact on gmail and sync, it will bring it to my phone, but whenever I try to change something on contacts EX, it won't work and the syncing will no longer work from then on.

    That's a very serious issue and even though Contacts EX is updated, I've never had a solution to this problem. Does anyone?

    Thanks
    12-22-2012 01:46 PM
  25. Mary DeVine's Avatar
    Hi my contact wont sync
    02-06-2013 07:57 PM
41 12
LINK TO POST COPIED TO CLIPBOARD